Jump to content


KotOR and KotOR2 Savegame Editor (KSE) - Current Version: 3.3.3


Recommended Posts

v1.3.1 released


Patched a bug that disallowed force powers from being added to NPCs who got a jedi class addition.


Note: If you add a jedi class to an NPC, you must still add one force power -- that bug hasn't been fixed yet. If you don't the game will crash if you open up that NPC's 'Powers' menu.


Edit: I've got Canderous running around as a Soldier/Guardian using 'Fear' on Hulak Wraids.

Link to comment
Share on other sites

  • Replies 1.2k
  • Created
  • Last Reply

v1.3.2 released


Patched a bug that disallowed force powers from being removed from NPCs who got a jedi class addition.


T7 or anyone else, I'd like to hear whether or not your savegames remain legit after multiclassing. Just be sure to keep a 1-force power minimum on jedi classes.

Link to comment
Share on other sites

Originally posted by Kitty Kitty

Hold up a sec Goran,


We weren't saying that the romance mod broke anything.


The problem is if you use KSE to hack your save game and actually set yourself to be both genders - which while similar, is NOT what the romance mod does - breaks the game.


Well, it doesn't "break" it, but it causes a problem in some places.. the first of which being between the Endar Spire and Taris.


It will also happen if you use the editor to make your ORIGINAL class anything but the 3 you can choose at character creation.



I know the problem is in a check in a script someplace.. the trouble is figuring out a way around it, since most of them aren't available as source - just compiled versions. =/




Some where I missed a paragraph. Must not have had my coffee yet or something lol.


I meant to say that, to by pass the gender prob, I was using an outside gender mod.


I haven't tinkered with the NPC non Jedi's as far as powers go.

But I did give everyone in the group all feats possible.

I am gonna run through it again with the new editor, and see if i can have the full party as Jedi's.


All though I did not give my non jedi's any jedi powers, I did use the editor on all the Jedi's, including my main char once I got trained as a guardian, to give them all the powers possible, and completed both light and dark sides with no ill effect.


Has anyone tried this editor out yet?

Can I get Jedi powers at the very begining, with out having to worry about the cut scene?


and BTW if I haven't said it before TK, I appreciate all the hard work and effort you have put into this.

Link to comment
Share on other sites

The cutscenes still get you stuck entering and leaving Taris. The problem is buried in the compiled scripts for the cutscenes.


(Was able to contact Lil' Jawa by email though and asked him to take a peek at the problem in his spare time.)

Link to comment
Share on other sites

I think I know what causes the problem where if you're not a male/female and you're not one of the three normal starting classes you won't be able to complete the endar spire->taris cutscene successfully.


In the module STUNT_00 there is a cut00_convers.dlg. Each of the starting entries for this file has a startingconditionals script associated with them. The scripts that fire are:


k_small.ncs for male scoundrel

k_small_female.ncs for female scout

k_medium.ncs for male scout

k_medium_female.ncs for female soldier

k_tall.ncs for male soldier

k_tiny.ncs for female scoundrel


If you're not one of the above combination, then the conversation will proceed no longer (and you're stuck in the cutscene). This conversation eventually calls k_ren_visionland which loads tarm02af module.


One fix for this is to add a starting entrylist to this dlg file which has no script associated with it (blank "active" field). This way, you can get pass the cutscene regardless of your combination.


Now, if you do this, you'll run into another similar problem. In the module tarm02af (Taris apartment) there is a tar02_carth022.dlg file that also contain class/gender check. This is found in the third ReplyList's EntriesList field. The associated scripts this time are:


k_pend_bedtall.ncs for male soldier

k_pend_bedmed.ncs for male scout or female soldier

k_pend_bedsml.ncs for male scoundrel or female scout

k_pend_bedtiny.ncs for female scoundrel


Again, if you edit this .dlg file and add another entry with no script in the active field, you would be able to get pass this dialog.


I stopped testing at this point, but there may be other cutscenes dialog file that you need to edit if you want to play through with a nonstandard class/gender combination.

Link to comment
Share on other sites

Great freaking detective work H!






Question --

I'm looking at the cut00_convers.dlg file right now. I see the StartingList and the CResRefs listed in it. My question is: How does swkotor.exe define k_tall, etc.? If that could be fooled or defaulted, then the problem would be solved without having to remove the StartingList altogether.

Link to comment
Share on other sites

Wow what band is that, tk102? ;)


You actually don't delete the startinglist entries. Just add one more (for cut00_convers.dlg that would be #6) and for the active field, leave that blank. That would then be the default. For the Index DWORD, just put any valid entries, say 2. That might screwed up the cut scene a little but that wouldn't be a big problem.


k_tall returns true if the PC is a male soldier, false otherwise. If k_tall is true then StartList entry 0 will fire, calling EntryList 10 (read from Index field) , which then calls ReplyList 10(read from EntryList 10->RepliesList ->Index field), which then runs k_ren_visionland (read from ReplyList 10->Script) [and also calls EntryLists 11 and so on].


Your suggestion also works: if we remove k_tall from the active field of StartList 0 then this branch will fire if all other branch's ACTIVE field script returns false. This should also solve the problem.


Hope this makes sense

Link to comment
Share on other sites

Thank you for explaining that so well. When I get a little time, I'll package the modified .dlg files with KSE and hopefully that will be that.


P.S. That's my band from college. I'm that electric bass player.

Link to comment
Share on other sites

v1.3.3 releasd


Found and eliminated a pesky bug that caused KSE to close when opening up a savegame near the Jedi Enclave on Dantooine.


(For those who care: It was due to a case sensitivity issue -- the savenfo.res referred to the lastmodule as "Danm13" while the savegame.sav stored it as "danm13".)

Link to comment
Share on other sites

Using the Padawan Mod and the Both gender mod is fantastic with this editor.

I have already run through it Lightside and Darkside.


With the editor I am able to give everyone in my party Force powers, and I do mean all the force powers, not to mention feats. It's freaking awesome.


I can boost or lower my stats to make it easier or harder.



Great Job Man!!!


Best Savegame editor I have ever played around with!!!




I bosted all my team mates stats so high, that I almost had a neverending battle on the temple summit when I went over the darkside. It was fantastic. Took me an hour to defeat Jolee and Juhani lol. Mainly cause I was letting auto attack do all the work.


Link to comment
Share on other sites

Awesome Editor tk... One thing I'm having a problem with is HP and FP for the main character. They aren't taking in the new values.


I also am wondering if you'll be adding inventory hack to this as well. Keep up the good work!! :)

Link to comment
Share on other sites

More like you can't die. Your minimum hitpoints become 1 (alive barely) instead of 0 (dead/unconscious). So it's not the same as the invulnerability cheat.


I think it's used for things like the Juhani fight, the Bastilla fight, etc. where the game doesn't let you kill the opponent in order to further the plot.

Link to comment
Share on other sites

I was still just wondering if anyone else is having issues with giving say your Fresh new lvl 1 Charater say 200 HP to start with and then starting the game and s/he doesn't have said 200 HP's? I have been trying to figure this out. Anyone else having this problem or am I just a morron and I'm doing something wrong? :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...