Jump to content

Home

How the hell do I get rid of... "write protection"?


Wester547
 Share

Recommended Posts

Write protection? In JKA?

 

I modify the jaconfig file so in addition to it there is:

 

seta g_sabermorerealistic "2"

seta helpusobi "1"

 

I save the changes, and I go to my command line of my jedi academy single player shortcut and add +seta g_sabermorerealistic 2 +seta helpusobi 1

 

Start up the game, it says both values of helpusobi is 1 and g_sabermorerealistic is 2.

 

Okay, I load a map, and both are 0.

 

No matter what I do.

 

I try to change helpusobi to 1, that's successfull.

 

I try to change g_sabermorerealistic to 2, it says that is write protected. How do I get rid of write protection? Is this an engine built in? Does anyone know?

 

Cheers,

 

Wester547

Link to comment
Share on other sites

"Write Protect" means that you can't change it in game.

 

There are two ways around this:

 

1) Put the command in a shortcut to launch the EXE, such as putting the command with a + after the exe file in the target window of a shortcut.

 

c:\program files\lucas arts\jedi academy\jamp.exe +g_sabermorerealistic 2

 

For example.

 

Now I had a TON of problems with getting this right after the 1.01 patch, so I would point you to the various stickies up there about getting realistic dismemberment, etc. in this and other forums (try the search if you can't find the exact thread).

 

2) Reload the map with cheats. You can't use devmapall anymore in 1.01, so you have to use helpusobi 1 really. You can add this to a command line too. Or you can try using devmap <mapname> to load with cheats (though this is really for MP). With cheats on, you should be able to modify these commands more easily. If not, try solution #1

Link to comment
Share on other sites

Just a note:

 

In the main menu (or even in game) you can type in devmapall Map_name and it will load with cheats on automatically. I know this because I do it when I test a map (unless I have some kind of mapping modification which lets me use the command, but I don't think I do)

 

However, just typing "devmapall" in, does NOT enable cheats, it only works if you are loading a new map.

Link to comment
Share on other sites

An important distinction there, I'll have to try that.

 

Also, the shortcut method can be done from within a batch (*.bat) file you create. So there's another way to do it.

 

Or you can open up Command Prompt (aka DOS Box) and launch the command line there too, although that's the long-hand way to do it.

Link to comment
Share on other sites

 Share

×
×
  • Create New...