Jump to content

Home

Report your experience with 30 FPS Servers


[RNGD]Tyrant
 Share

Recommended Posts

I set my server up with the command line tweek to 30 FPS

 

 

Since then I have noticed that it is hard to get into vehicles...you hit the E key and you hop in and out again...kind of weird.

 

I have also noticed the alternative weapon key togles itself too

 

 

anyone else notice anything strange? or any other performance issues?

Link to comment
Share on other sites

if i where to take a stab at the issue..

 

just from the description it sounds like hte /tps increases the amount of bandwidth the server is using..

 

jsut a guess but what maybe happening is the server is lagging the player out (maybe a desync issue) and not recording the action of entering a vehicle.

 

i know BF42 has a similar effect when you are getting heavy PacketLoss..

 

 

just a guess.. but worth looking into ..

Link to comment
Share on other sites

Originally posted by [RNGD]Tyrant

I set my server up with the command line tweek to 30 FPS

 

 

Since then I have noticed that it is hard to get into vehicles...you hit the E key and you hop in and out again...kind of weird.

 

I have also noticed the alternative weapon key togles itself too

 

 

anyone else notice anything strange? or any other performance issues?

 

Yea, i'm having the exact same problem with my server. i set FPS to 50, and last night it was just horrible trying to get into vehicles. I'm going to put it back to 20 until the server is patched (if the patch helps with this problem).

Link to comment
Share on other sites

i run fine and it is so smooth with a 60 fps setting but my other clan mates clan it lags them so bad. But then agian i am running a x800 pro 1 gb of ram and a 3400 64 bit. So i dunno. I also notice my ping goes to normal like 60 when i do that. When it is set to 20 my ping is 100. Hmmm. But i cant use more then 20 cause it lags my members. But i run fine and it feels so good at 60 for me.

Link to comment
Share on other sites

Well I was amazed to find the multiplayer side of SWBattlefront to have a capped frame rate of 20fps client side.

 

The Single players great but Mutliplayer is a joke! I thought someone had removed my graphics card and I was running in software mode!...but no...it rearly was crap!

 

Servers set to run at 30fps are enough to overcome the jerky graphics, TV set's work fine at 25 fps - yes you end up with the vehicle entry problem but it is far worse if you increase above 30 as not everyones graphics card can keep up..hence lag! on there machine.

 

We need to see a patch!...fast!

Link to comment
Share on other sites

If the /tic setting is any correlation to other game engine settings, it's in reference to the processing of a 'frame' of data. A ticrate of 30 would mean the server processes 30 seperate frames of data, taking from the input buffer, and crunching that data, spitting it out to clients in the form of a frame, rinse and repeat.

 

The drawbacks to high framerates are obvious - increased CPU load, and the possibility the timing of other functions will be disrupted due to changing the default rate.

 

There's also an issue that if the buffer can't be emptied, some data sits and waits for the next frame. If the rate is too low, there will be a constant lag effect, beyond ping. You could also run the rate too high, where there isn't any data in the buffer, yet a frame is still pushed to clients, which is wasted bandwidth.

 

Until we get some explanations as to what it is, and what we can do with it, I'd not suggest screwing too much with it. We need some developer interaction here rather than speculative answers.

Link to comment
Share on other sites

A data point from outside the curve:

 

I'm running a dedicated server on an Athlon 750 (768MB RAM) and had to set the TPS to 15. At 20 there were weird warping issues; at 30 it was entirely unplayable (connecting with an Athlon XP2000, 1GB DDR266, nVidia 5600 Ultra 128MB)

 

Strangely enough, at 15 it's quite smooth. I haven't measured the client performance with any tools but I'd have to guess that I'm getting far more than 15fps.

 

This box also runs my mail, web, ftp, etc.

 

Based on my experience and what I've read in the forums, it looks like TPS is for data frames not video frames - and my poor little server doesn't have power to push more than TPS 15.

 

Also noticed that SWBF seems to use significantly less CPU than BFV.

Link to comment
Share on other sites

 Share

×
×
  • Create New...