Jump to content

Home

Dedicated Problem! net_ip: "localhost"??


Jumms65
 Share

Recommended Posts

Hello, I see that I'm facing the same problem as a lot of other people here, but my answer hasn't been found through my searching the other posts all day yesterday. Here's my problem. I have started a dedicated server with a correct config. I have the 1.2 DC Public Mod on it. BUT it seems no one can join or find it. I believe the problem lies behind

net_ip: "localhost"

I have forwarded ports "28070~28099" for my LAN connection. I have a linksys modem. I'm not sure how to set a new net_ip for my server. And if that is not the case please help!! My version is up to date, I also have the dedicated server up to date! All replies are greatly appreciated! THANK YOU!

 

EDIT: This is for a JK2 Dedicated Server. I've heard that I might need a different program to run my jk2ded server besides the jk2ded.exe.

 

EDIT: Here is the url to my config file:

[edit: removed by bill pending some changes to it]

Link to comment
Share on other sites

  • 9 months later...

YES PLEase. I'm having the exact same problem, cept im running on JA+ mod, which really shouldn't make a difference. My IP changes every time i reconnect, but that really shouldn't be the problem either.

 

NOBODY, not even me, can see my freaking server, and I've tried everything on my own-- i set the net_forcenonlocal to 1, did absolutely nothing. I can't set the net_ip to anything but localhost without it completely not working.

 

I've set the port to 21000, that's default, and dedicated to 2, and set the com_hunkmegs (whatever that is) to 64. That is all the defaults for my dedicated server.

 

SOMEbody please help us, come on.

 

EDIT: I forgot to mention, i'm using jedi academy, but it really has the exact same problem as jk2 does, they use the same engine.

 

EDIT: Also, I work behind a router, but my network admin insists that there is no interference by the router .. is he mistaken??

Link to comment
Share on other sites

  • 2 weeks later...

I might can help alittle, but not for sure.

If you have internal ip like 192.168.0.1, then you need to forward the ports, i dont remember the Jedi Outcast port numbers.

Even if its working or not, you will see it as local dedicated server, because you are on the same network as the dedicated computer is, doesnt matter if its your or the one next to you.

Disable Firewalls and Virus scanners or what ever you have.

If that doesnt work, try to remove the router and connect only that computer and see if you get Public or Internal ip, if you get internal ip, you might gonna have to pay to get a single Public ip, just like i did couple of times.

Good Luck.

Link to comment
Share on other sites

  • 2 weeks later...

Seeing this late but a couple things to verify. Are you sending heartbeats to the master server? If you are, you can try +set net_ip "123.123.123.123" (insert your WAN IP) on the command line to launch your server. Typically though this is used to support multiple server instances/IPs on a single server box. I'm not even sure it's a valid JA/JK cvar but it is in the q3a engine.

Link to comment
Share on other sites

 Share

×
×
  • Create New...