Jump to content

Home

Problems running Kotor or TSL in Vista....


stingerhs
 Share

Recommended Posts

i just got finished building a computer about a week ago. I installed kotor 2 and at first everything seemed fine until i got to Peragus, then it shuts the game down and says"program has stopped" I had a video card error and it said i need "detonator 54,23 or sumthing like that. i have a 8500 gt graphics card so i used the disc that came with that and installed the drives again. I also went to nvidia's site and got the lastest patches for the g cards. That didn't fix the problem so i uninstalled the game and attempted to reinstall it but now it wont work. I put the disc in and nothing happens, it's almost as if there is no info on the disc. my computer has: windows vista business, an AMD Athlon 64 x2 dual core processor 4800 + 2.51 GHz, 2046MB of ram. my jedi academy,outcast games work as well as jedi knight and mots. If anyone can help that be great!!!

Link to comment
Share on other sites

  • 2 weeks later...
  • Replies 176
  • Created
  • Last Reply

Top Posters In This Topic

I have only had this computer for 13 days and I am thinking of returning it simply because I dont wanna use Vista, oh thank the dumb-dumbs for such a great idea. You'd think after the time it takes to make something run you'd do it right the first time or at least be in the process of fixing it ok sry about the ranting but i had to get it out.

 

I am trying to play KotorII but it doesnt like to run once I take the disc out and watch a movie and the only thing that fixes it is reinstalling the game and updating it to v2.10. I have it set to 'xp sp2 comp. mode' and am running it under 'administrator'. But still it works for a couple of runs but after that it flips me off again. I am about to throw this thing outta a window.

 

Heres my system specs:

Compaq Presario F572US

Windows Vista Premium (32-bit)

AMD Athlon 64 (x2) TK-53 - 1.70 GHz

NVidia GeForce Go 6100

960 MB Total Memory

287 MB Graphics Memory

 

Component Details Subscore Base score

Processor AMD Athlon 64 X2 Dual Core Processor TK-53 4.6 2.4

Memory (RAM) 960 MB 4.5

Graphics NVIDIA GeForce Go 6100 3.0

Gaming graphics 287 MB Total available graphics memory 2.4

Primary hard disk 35GB Free (66GB Total) 4.9

Windows Vista Home Premium

 

System

Manufacturer Hewlett-Packard

Model Presario F500

Total amount of system memory 960.00 MB RAM

System type 32-bit operating system

Number of processor cores 2

64-bit capable Yes

 

Storage

Total size of hard disk(s) 75 GB

Disk partition (C:) 35 GB Free (66 GB Total)

Disk partition (D:) 2 GB Free (8 GB Total)

Media drive (E:) CD/DVD

 

Graphics

Display adapter type NVIDIA GeForce Go 6100

Total available graphics memory 287 MB

Dedicated graphics memory 64 MB

Dedicated system memory 0 MB

Shared system memory 223 MB

Display adapter driver version 7.15.10.9815

Primary monitor resolution 1280x800

DirectX version DirectX 9.0 or better

 

Network

Network Adapter NVIDIA nForce Networking Controller

Network Adapter Microsoft Tun Miniport Adapter

Network Adapter Broadcom 802.11b/g WLAN

Link to comment
Share on other sites

I have a problem with kotor1, after the game changes from a "movie" scene to an in-game scene I can't see anything, just a black screen. I can still hear the sounds, and if I can do anything I can also see my mouse and do anything I want (as far as I know), the problem being that I can only see my mouse pointer. Restarting the game makes it fine, until the next time it hapens. So, anyone got an idea how to fix this? I have mannaged to get to the blast-the-fighters bit when leaving taris, but there being unable to save screws me over (try to ble that part with your eyes closed). So if no fix is known, any way to skip from when you are about to enter the ebon hawk to when you can quicksave next will be greatly apreciated. I can post my specs if neede, though someone will have to tel me how.

Link to comment
Share on other sites

@JMartin25: What patch version of Kotor were you using? The game ran fine for me out of the box (even with the scan complaining about the video drivers and OS version); when I used the updater, I started getting a SecuROM error about "emulation"... I don't have any disc emulators installed, so I'm baffled about why it would think I do.

Link to comment
Share on other sites

Hey, I'm new here and I have a problem with TSL:

Whenever I board the Ebon Hawk on Peragus, I fight the turret scene, then the game either freezes at the next loading screen, or the screen after the Ebon Hawk leaves the hanger. This happens in new games and old, PLEASE HELP!

:mob::lazerhead

Link to comment
Share on other sites

  • 2 weeks later...
i just installed TSL on mine, vista ultimate, the game doesn't seem to recognize my nvidia beta driver,8600GTSx2, when i scan hardware it says i fail video. when i press play it "stopped responding"

 

heres my config report

 

[sWKotOR]

ReportDateTime=10/13/2007 9:17:48 PM

SysInfoVersion=v1.00.60

GameExists=1

GameVersion=v2.10.427

GameInstallLocation=C:\Program Files\LucasArts\SWKotOR2\

 

[OS] i dont know why it says its xp but its vista ultimate

Name=WinXp

Version=Windows XP v5.1 build 2600 Service Pack 2

Service Pack=None

Status=Pass

 

[swapFiles]

?:\pagefile.sys=0

 

[CPU]

CPUCount=1

CPUSpeed=2399

CPUFamily=6

CPUModel=15

CPUStepping=11

CPUVendor=Intel

CPUName=Intel® Core2 Quad CPU Q6600 @ 2.40GHz

Status=Pass

 

[Memory]

RAM=2048

Status=Pass

 

[Disk Free Space]

C: (NTFS), UNICODE=113.58GB

Status=Pass

 

[CD-ROMs]

DriveLetters=D:\

Drives=SONY DVD RW AW-Q170A ATA Device

 

[Video]

Video Card Name=

Video Memory=1024

Desktop Resolution=0x0x0

DirectX=DirectX 9.0c (4.09.00.0904)

OpenGL Version=2.1.1

OpenGL Vendor=NVIDIA Corporation

OpenGL Renderer=GeForce 8600 GTS/PCI/SSE2

NVidia Driver=(null) im using the latest driver

Vid Card Status=Warning

Vid Card Driver Status=Fail

GL Status=Pass

DX Status=Pass

 

[Audio]

Sound Card Name=Speakers (Realtek High Definition Audio)

Status=Pass

 

 

;Game Options from swkotor2.ini

 

[Display Options]

FullScreen=1

Disable Movies=0

Disable Intro Movies=0

Sort Modules=1

Width=640

Height=480

BitsPerPixels=32

RefreshRate=60

 

[sound Options]

Sound Init=1

Disable Sound=0

Force Software=0

 

[Graphics Options]

EnableHardwareMouse=1

FullScreen=0

RefreshRate=60

Width=1280

Height=960

V-Sync=1

Texture Quality=1

Anti Aliasing=0

Emitters=1

Anisotropy=1

Frame Buffer=1

Soft Shadows=1

Brightness=57

 

[Game Options]

Disable Movies=0

 

[config]

firstrun=0

Link to comment
Share on other sites

I'm having the same problem for TSL as manoface, same graphic card too. Well actually I think mine is an 8600m GT.

 

EDIT: Ok I did some snooping around the swkotor2.ini and found something. I opened it and found that there was a blank area at the very top, just above [display options]. I removed the blank area, saved the file, and attempted to run TSL. It ran the game.

 

EDIT: EDIT: Well it seems to be a more random occurrence if the game works or not. Sometimes I get it to work other times it doesn't. I think there is still a bigger answer here.

Link to comment
Share on other sites

Ok I have a HP Pavilion Laptop. It has a NVIDIA GeForce Go 6150 graphics card. It has Windows Vista Home Premium. Right now I do not have Kotor 1 installed becasue it didnt work. But when I did have it installed I could install it perfectly. I could hear sound. I could get it open to the Main Menu where Malak is standing. The graphics seem to be a little fuzzy and the smoke and Malak move slowly. I can click on Options and Movies. And everything works perfectly there. But when I go to New Game the screen goes black. I will mostly be able to hear the music that goes with Character creation. Also for some reason I cant enable cheats in the .ini file. That may be because of something I am doing wrong but I cant save.

Thanks in advance to those who can help.

Link to comment
Share on other sites

  • 1 month later...

I've just upgraded to Vista Home Premium, but can't get KOTOR 2 to run. It fails on the video check, then crashes when loading up. The error message says that I need the latest NVidia drivers. Funny thing is I'm running an ATI Radeon 1900-XT :mad2::mad2:

 

Ok I have a HP Pavilion Laptop. It has a NVIDIA GeForce Go 6150 graphics card. It has Windows Vista Home Premium. Right now I do not have Kotor 1 installed becasue it didnt work. But when I did have it installed I could install it perfectly. I could hear sound. I could get it open to the Main Menu where Malak is standing. The graphics seem to be a little fuzzy and the smoke and Malak move slowly. I can click on Options and Movies. And everything works perfectly there. But when I go to New Game the screen goes black. I will mostly be able to hear the music that goes with Character creation. Also for some reason I cant enable cheats in the .ini file. That may be because of something I am doing wrong but I cant save.

Thanks in advance to those who can help.

 

This may not be a Vista related problem. I had similar problems back on my old XP machine (running an Intel Integrated chip). My solution was to heavily turn down the graphics, things like soft shadows. Didn't look pretty, but meant that I could now load game areas...

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Hey there, I'm new to this site and I apologise if this question has already been asked.

 

I have both KotOR's and they both run perfectly fine on my Vista and everything. I have already finished both and would like to play them again but I wanna play them with cheats. Here's the problem: Vista will not allow me to save changes made to the swkotor.ini file which made me wonder if I need to change certain settings (I tried looking up all sorts of stuff on the Vista site).

 

Any help will be greatly appreciated. :)

Link to comment
Share on other sites

  • 2 weeks later...

Hi I am new and yes i have vista.

 

I've installed the Kotor II and i have the some problem as most, I start it and a message says that it stopped working and windows is trying too look for a solution (not much can they do uh?) but sometimes or should i say *rarely* it starts normally i can create my character and all, but when its time to play, it crashes.

 

also in the hardware scan, says i need to update the video driver, which is stupid since the pc is new and everything is up to date, i also made a scan with driver detective to make sure and see if some things are not updated, well its not the issue, since it says clearly that it IS updated.

 

I have a:

 

HP pavilion dv6604nr Entertainment notebook PC

NVIDIA Geforce Go 7150m graphics

 

 

EDIT: I think i have somehow fixed it, by reading some guy's post in gamespot, he said that he disable sound and he had managed to make the game work, so he downloaded the K1 sound version and it played.

 

http://files.filefront.com/Mss32dll/;6695046;/fileinfo.html

 

But after his game crashed because of the movies, so he disable it them, since then he has managed to play, and me too!! i hope there will be a fix for the movies though...

 

viva star wars!

Link to comment
Share on other sites

Hello all!

 

I'm running Windows Vista home premium and trying to run Kotor 1

 

I can play the game perfectly fine but when I try to edit my swkotor.ini file in my game folder it says

Cannot creat the C:\Program Flies\LucasArts\SWKotOR\swkotor.ini file.

Make sure that the path and file name are correct.

 

When I go ever to my old computer running XP Home it dose everything fine.

 

I have tried everything I can think of(even doing what it tells me ;) ) and I can't get it to work!

Please help me out here

 

sorry if something like this has been posted before. But I need help

Link to comment
Share on other sites

yeah i dont know if this has anything to do with it being on vista,but,i did that whole add the "enablecheats=1" to the SWKotOR.ini file and saved all that worked but i found that (like i said i dont know if this was only bacause i ran the game on vista or if it was just a result of the cheats) in some areas there would be long lines of color, usually brown but they would run through the entire map and go through peopl and they were all in the sky and whenever i would see those , like on dantooine my game would become really laggy, saying extremley laggy would be an understatement.but when, say i turn my guy so i couldnt see those streeks of solor everything would be fine. no lag.

Link to comment
Share on other sites

Hello all!

 

I'm running Windows Vista home premium and trying to run Kotor 1

 

I can play the game perfectly fine but when I try to edit my swkotor.ini file in my game folder it says

Cannot creat the C:\Program Flies\LucasArts\SWKotOR\swkotor.ini file.

Make sure that the path and file name are correct.

 

When I go ever to my old computer running XP Home it dose everything fine.

 

I have tried everything I can think of(even doing what it tells me ;) ) and I can't get it to work!

Please help me out here

 

sorry if something like this has been posted before. But I need help

 

 

heres what you do: go into the program files/lucasarts then click on the swkotor.ini and drag it to youre desktop, then go to (just type this in in the bar on the top) user\whatever the name\AppData\Local\Virtualstore then click on prgram files, then lucas arts, then swkotor then the swkotor.ini file. then add the enablecheats=1 line and save. then go to the swkotor file on youre desktop and do the same then drag it back into the program file that you took it out of. check both of the swkotor.ini files to make sure they are the same. if you really want to check if they work first go into the file and change "disable sound=0" to "disable sound=1" ***ON BOTH SWKOTOR FILES*** if you do not make any changes to both files nothing will happen. but be carefull read my first thing about the whole color streeks because that might happen to you.

Link to comment
Share on other sites

EDIT: Never mind I uninstalled the game with the intention to reinstall but my computer hates me so yeah.

 

 

Thanks I'll give this a try right-a-way!

 

 

EDIT: I was able to save the file perfectly doing that, Thank you!

But now when I went to run the game a Window came up that says

Conflict with Disc Emulator software detected. See http://www.securom.com/emulation for more details.

I don't understand this myself. It says its not the original disc. and it is.

 

EDIT: btw it had done that before but It stoped doing it for some reason?

 

 

I can't wait till I switch to Linux.

Link to comment
Share on other sites

I finally have the answer to this kotor and vista problem- upgrade to xp that's right i said "upgrade" to xp because vista on the whole is crap anyway when i tried kotor1 it worked but i had strange graphical issues and thats running a 7900gtx with latest vista drivers ! aa and antistrophic filtering were unselectable in the options so was eax settings in the sound options i also have a creative sound blaster card with vista drivers ! work that out

Link to comment
Share on other sites

Yes Darth Ding Dong go back to xp if you love kotor enough, there are some fixes for kotor on vista but none of which are 100% i mean hell i paid around 100 quid for vista 64-bit and realised i had to buy a new antivirus, nero also has issues as does limewire just to name a few programs, the one software that worked was fraps! ooooooh big deal! maybe in a few years vista might be good to have, but until then:

 

IF IT AIN'T BROKE DON'T FIX IT.

Link to comment
Share on other sites

  • 2 weeks later...

Microsoft has come out with a graphics hotfix that may solve some of the Kotor problems. I don't know for sure about that, but here is the link if you want to try it. This is apparently one of the fixes that's going to come out in Vista's SP1 sometime this year. It is apparently not yet available on Windows Update.

Link to comment
Share on other sites

  • 1 month later...

hi well im running it on vista with an intel pentium duo core T2080

 

game runs fine til i reach the taris undercity it runs perfect til i get to the taris undercity...freezes when it loads the to scavangers asking for credits for useing there elevator but it freezes half way to that part and i tried a super skip taris mod and it freezes again at the dantooine ruins...any help will be great i've tried compatiability,reinstall,patched,turn of grass,shadow,movies,and sound none work and everythings at lowest :(:(:(:(:( but Kotor 2 runs fine :confused::confused: so help :D

Link to comment
Share on other sites

 Share


×
×
  • Create New...