Jump to content


Problems running Kotor or TSL in Vista....


Recommended Posts

I disabled the UAC, unsurprisingly KOTOR 2 still wont load, I still get that program must close because of error message. I found the permissions thing in the properties tab but I dont know how to proceed from there.


Edit: I managed to get the game working finally, not sure how long its gonna last. When I disabled the UAC I tried to extract the patch for the vista update and it worked this time and when I replaced the file the game was able to launch sucessfully. I also used win xp sp 2 compatibility mode.


Congratulations :)

Link to comment
Share on other sites

  • Replies 176
  • Created
  • Last Reply

Top Posters In This Topic

Surprisingly I was also able to use a number of mods on KOTOR 2, some I had trouble installing because they couldnt extract or copy the files sucessfully but they seem to work for the most part and dont have any adverse affect on my game.


Very good. Perhaps switch your zip file program to winRAR. I can't say for sure, but it might fix the problem with extracting the files.

Link to comment
Share on other sites

Very good. Perhaps switch your zip file program to winRAR. I can't say for sure, but it might fix the problem with extracting the files.


I had that program on my computer before and it worked really good but after a while they started charging me for its useage and thats why I tried 7zip instead because I simply needed a program to extract files from zip files and didnt need alot of fancy features or anything like that. If I get some money maybe ill use winRAR and see if theres a difference or not.

Link to comment
Share on other sites

I had that program on my computer before and it worked really good but after a while they started charging me for its useage and thats why I tried 7zip instead because I simply needed a program to extract files from zip files and didnt need alot of fancy features or anything like that. If I get some money maybe ill use winRAR and see if theres a difference or not.


Right. All the best to you :)

Link to comment
Share on other sites

Only problem im having now is when I installed some mods for the Telos levels I cant get B4D4 to use his usual dialogue when I start a level on citadel station, he uses the normal dialogue he would if I visited the czerka offices. I dont know which mod is causing this and ive uninstalled most of them which would affect that area.

Link to comment
Share on other sites

I hate bumping old topics but I have no choice. OK here's the deal, brand new PC originally running Vista 32bit, on which KotOR II ran perfectly with the Vista Mss32.dll patch file, but for various reasons I upgraded to Vista 64bit. Now KotOR II fails to run no matter what I do. I've tried multiple intalls, various different Mss32 files, running in compatibility mode, you name it I've probably tried it. Does anyone have a suggestion that I might have missed somewhere? Or is KotOR II dead to me unless I downgrade?


Oh and for the record, Windows Vista is single handedly the worst OS I have ever worked with in my life. And also unrelated to this problem I just thought I'd mention that my graphics card doesn't work properly because of Vista and nVidia's incompetence. Thinking of buying a new PC? Don't install Vista whatever you do.

Link to comment
Share on other sites

ok i am new and very nearly computer illiterate. i know that this has been discussed but i did not understand exactly how to fix the problem. running kotor on my vista has produced better quality visuals that are much more fluid than my last computer, but i cannot enable cheats. i know what i have to do and even know where the file is, but it won't let me save the change, because it is a "read only file". PLEASE have mercy and tell me how to fix this problem...

btw, Bill Gates is a loser!

Link to comment
Share on other sites

so yea i just bought a new gateway dx4200-ub001a computer with windows vista 64 bit. 6 gb memory an ati radeon 3450 hd video card with all the new catalyst drivers.

the new drivers fixed the lag i was having on dantooine.

but now i am on the become a jedi quest and when i go thru to the grove where you find juhani and my game crashes on the loading screen about half way thru.

ive tried all the graphics configs i can think of and it still happens!

i have tried this about 30 times now....and it still wont work.

as far as mods i have......

10 male heads pack.

all party is jedi pack.

realistic lightsabers pack.

multi kill and multi plague.

jolee is yoda.


and thats about it.....

is there anyone AT ALL that can help me!?!?

this game is tight as hell lol.

all i wanna do is play it with some extra stuff.....ya know?




i also have tried taking off all the mods but then it screws up my save game.......because of the male heads.....

but i wouldnt think that an extra head added in the game would make it crash like that......


someone please help! =]

Link to comment
Share on other sites



This worked for me brilliantly and took hours to solve the problem, but the game runs wonderful now without any crashes. (Just don't alt-tab while playing, the game doesn't like it.)


PART 1 : INI file


Go to c:\program files\lucasarts\kotor2 and move swkotor2.ini to desktop, be sure the graphic options part is as follows :


[Graphics Options]






Frame Buffer=0

Anti Aliasing=4

Texture Quality=2


Soft Shadows=0






Sound options are as follows :



[sound Options]

Number 3D Voices=16

Number 2D Voices=24

2D3D Bias=1.00

Force Software=1


Sound Init=0

Music Volume=85

Voiceover Volume=85

Sound Effects Volume=85

Movie Volume=85

Disable Sound=0


After editing the file if required, remove it back to c:\program files\lucasarts\kotor2 folder.


PART II : NVIDIA Control panel


Go to your desktop right click and open NVIDIA control panel, now to the manage 3d settings and select global settings, change it as follows :


Anisotropic filtering : 16x

Anti-gamma : On

Antialias mode : App-cont

" - transparency : supersampling

Conformant text clamp : Use hardware

Err rep : Off

Ext. limit : off

Force mipmaps : Trilinear

Max. prerendered frames : 8

Multidisp/mix GPU : Single performance

Tex-filtering neg. bias : Clamp

Tex-filt. quality : High Q

Thread opt : off

Trip buffer : off

Vsync : force off


PART III : Registry setup


Click start, click start search, type regedit, run it. Search for "_swkotor2.exe" (without commas). For me there were 3 entries and one of them is like :




Under this folder, you will find _swkotor2.exe entry. All entries must be REG_BINARY.


Check and add these entries :


_swkotor2.exe:D3D_16579523 01 00 00 00

_swkotor2.exe:D3D_30913648 01 00 00 00

_swkotor2.exe:D3D_60461791 47 67 41 08

_swkotor2.exe:D3D_94118636 00 00 00 00

_swkotor2.exe:D3DOGL_03385531 02 00 00 00

_swkotor2.exe:D3DOGL_12677978 60 16 62 51

_swkotor2.exe:D3DOGL_67207556 11 00 00 00

_swkotor2.exe:D3DOGL_70835937 27 00 32 22

_swkotor2.exe:D3DOGL_74095213 10 00 00 10

_swkotor2.exe:OGL_25631692 02 00 00 00

_swkotor2.exe:OGL_DefaultSwapInterval ff ff ff ff

_swkotor2.exe:OGL_ExtensionStringVersion 00 00 00 00

_swkotor2.exe:OGL_TexClampBehavior 00 00 00 00

_swkotor2.exe:OGL_ThreadControl 02 00 00 00

_swkotor2.exe:OGL_TripleBuffer 01 00 00 00



Close the registry editor, restart your computer and goodbye crashes... I believe OGL_ThreadControl is the critical point here. But to be sure I write all entries. Also changing all _swkotor2.exe entries to _swkotor.exe solves kotor 1 crashes, you may add them as seperate entries.


Also I changed my swkotor.ini file as follows :



[Graphics Options]



Frame Buffer=0

Anti Aliasing=4

Texture Quality=2



Soft Shadows=0









PART IV : Bad TDR, Bad TDR...


This is an application for graphics drivers. When a driver stops responding, vista resets the device driver so the system continues stable. But the problem is old games sometimes stops responding naturally and vista thinks the game crashed. There is a fix for that problem incase your problem consists of this :


start regedit and go to [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\GraphicsDrivers], add a new REG_DWORD entry as


TdrDdiDelay 120

TdrDelay 60


Close regedit.




Somehow these changes requires restarting the computer to take effect.




Start your game in SP2 compability mode. Old mss32.dll is required also.


The game starts in windowed mode, but when you changed the resolution from the graphic options, it turns to fullscreen.


You should try turning on frame buffer effects and shadows as well from the ini file (Just set them to 1). I didn't care so I didn't try. But you may if it is important for you.


The game is also buggy and rarely crashes to desktop after these settings so save often. Good game although, or may be best...


RESULT : NVIDIA Drivers somehow sucks... These crashes are not hardware or directly vista problem in my opinion. My assumption is NVIDIA drivers somehow fail to change registry keys of executable game files due to vista protection schemes. Manually adding them solves the problem.




Change your vista theme to classic to turn off windows aero subsytem. Also close the sidebar. As an option use CPU-control program and direct all processes to CPU1 incase you are using dualcore cpus.


PART VIII : Feedback Please


I wonder if this all in one solution worked for you too. Don't be lazy to report your results. Many people suffering may benefit from this if confirmed to solve crashes... Even NVIDIA support team may take a note and try to fix the problem...

Edited by omnipace
Link to comment
Share on other sites

I have an eMachines model 5274 (or something close). I'll check what issues on gateway computers K2 has since my brand is actually a branch off of gateway.


Have a vista with XP service pack 2 (I don't know why, probably to keep unrevised microsoft programs from having conniption fits--but whatever).


For what good they might do I have some reports:



Scan hardware reveals red flag on the OS claiming it is not XP, but plays anyway.

Everything else is Green, so it's a go. I got a really great sound system on it for my money. No issues there that I can tell. 2.00GHZ Intel dual core pentium processor.


Caution on video graphics card --I believe that, yes it is an integrated chipset family... PnP genaric intel (yes they make graphics cards too). Meets minimum standrards at least. Has trouble in the undercity of taris--turn off shadows and it will tolerate it--grumpily. With shadows can be a real pain, but it will work with a higher tenedcy of glitch and crash.


Else, It has its few loading glitches and a couple other small things related to that--nothing a good quit and reboot of the program wont fix.

"Running" animations for movement might not trigger sometimes. OTherwise nothing else is wrong.



K2TSL: Before the patch

I tried the 12-15 times opening just to get it to play. NOPE--won't even acknowledge the game after a double click... Just slows for a second and then ignores it.


After I Patched with the latest Vista-fix-patch at kotorfiles.com: it will open, BUUUT after character creation and the opening text crawl cinematic, I get a message that vista has encountered a problem with the program K2:TSL and gives me the option of close and find solution online, or close program simply.


Absolutely refuses to play beyond that point. I'm out of ideas and I believe I have all but exausted options.


Hardware scan Reveals everything is a green for go (strangely, even the OS) and only a caution on the graphics card.


(Shrug) Guess it's really finicky, even on the lowest graphical levels???


In any case, I have exausted all options except disabling sound... but I don't see why I should if my sound system passed with flying colors...


Maybe buy a better graphics card (when I can afford it)...I think my model may even accompany an NVidiaGE 8800... If anyone has any other suggestions, send me a PM.


Hope this helps anyone with similar OS and model.



---in fact, now that I have uninstalled K2, it won't even acknowledge the discs, or it will let me select auto run but nothing happens......Could my disc set be deffective???

Edited by Darth Avlectus
spelling errors
Link to comment
Share on other sites

  • 1 month later...

Hi all. I've been trying to get TSL and kotor to work on both my vista laptop and desktop. When i get to around 17% on first disk, i get..

Component: DefaultComponent

File: F:\data2.cab

Error: Data error (cylic redundancy check).


I get this for both games on both computers. Do i need to install something for this to work, or?

Link to comment
Share on other sites

  • 2 weeks later...

Well... I've been playing the Best of PC version on my laptop for months, now but last week it stopped working. As soon as I open the .exe it crashes. I've already tried reinstalling and using the alternate .exe provided earlier in this thread. (When I use that, it doesn't detect my Best of PC DVD.) Suggestions?



Nevermind foolish old me. Turns out it was because I had to change my Depth Buffer Bit to run GameTap which I coincidentally got a week ago. :p

Link to comment
Share on other sites

I want to start playing Kotor2 but this keeps happening:


Problem Event Name: APPCRASH

Application Name: swkotor2.exe

Application Version:

Application Timestamp: 00000000

Fault Module Name: StackHash_fd00

Fault Module Version:

Fault Module Timestamp: 00000000

Exception Code: c0000005

Exception Offset: 00000000

OS Version: 6.0.6001.

Locale ID: 1033

Additional Information 1: fd00

Additional Information 2: ea6f5fe8924aaa756324d57f87834160

Additional Information 3: fd00

Additional Information 4: ea6f5fe8924aaa756324d57f87834160


When I run the config it always says that my gfc is out of date, but it is not. My gfc is a NVIDIA GeForce 9400 GT, and i just updated the drivers for it when I got it last week. I could really use some help here.


My Kotor 1 works ok it also told me the the gfc is not up to par, but is still runs.



Link to comment
Share on other sites

  • 2 weeks later...

Hi y'all.

I first ran KOTOR 1 on XP before and all worked fine. Since my old computer became quite unstable and hardware redundant, I switched to a completely new hardware set, P5Q, Intel Dual Core etc. Now I need to get KOTOR 1 running on Vista, and I'm encountering some issues.


The only requirement that is marked (with a yellow dot) in the system config settings test is the video card. After the issued warning it goes : (null) 4098MB. Graphics recommended: ATI Radeon 9200 or better or NVidia GeForce 4 Ti or better (128 VRAM).


I checked what videocard I have: an ATI ASUS EAH4850 series, driver version 8.511.0.0. I already updated the install version of KOTOR and set all .exe files in the KOTOR folder on the drive on Windows XP compatibility mode and I also tagged it as me being 'moderator'-(mode). Should I tweak anything for the graphic card or is it 'so new' it won't work for the elder KOTOR 1?


I managed to get past the character customization screen, and when pressing 'play' it first exited because of an error. When trying a second time to get past, the opening title video camle up just fine without noteable glitches. But when I pressed ESC to skip it, the error came up again.


Details (the specs were in Dutch, I roughly translated them):


Problem signature:

Event name of problem: APPCRASH

Name of application: swkotor.exe

Application version:

Datestamp: 00000000

Name of error module: StackHash_0774

Version of error module :

Timestamp of error module: 00000000

Exception code: c0000005

Exception margin: 00000000

Driver system version: 6.0.6001.

Land properties-id: 2067

Additional information 1: 0774

Additional information 2: e26977578855e2637f4d717e90e466ab

Additional information 3: 1ac6

Additional information 4: 02c0455592725ced0ee0adf3523662e9


Read our privacy statement:





Someone got an idea to work around this error message or how to fix it?

Thanks a million !

Link to comment
Share on other sites

My 4850 doesn't like the character creation screen of either K1 or TSL. It causes the GPU to become non-responsive requiring a system reset. Only way to play either game is to start from a save made on another machine. I have a scoundrel save for K1 and a consular save for TSL if you want to try that. These are at the very start with empty inventories etc.


K1_Starting_Save_Scoundrel.7z (179 KB)


TSL_Starting_Save_Consular.7z (193 KB)


You can change the sex, class, and head to whatever you prefer in KSE.

Link to comment
Share on other sites

  • 5 weeks later...

what mine does well for the first kotor is when play the game if i save the game it switches videomodes so i only see a tiny peace of the screen the same thing happened when i tried running it in 1024 the screen would do the same thing but if i run it in 800x600 it runs and only glitches when i save the game usually goes to a black screen and alt tabing generally lets me back in and all is fine but some times it goes back to the wrong video setting. also the same thing happens if i enable vsinc. i can play this like this but it would be better if i did not half to shut the program down if it gets stuck in that video mode cause alt tabing or anting like that wont set it back to 800 x 600 its like its showing a quarter of screen on its maximum resaution setting..


im running a gforce go 256m dedicated 7600 im pritty sure that i have the right drivers but then again i should of confirmed that before posting here. thanks if anyone knows about this also id like to state now that im a terrable speller so i hope this post is understandable

Link to comment
Share on other sites

  • 3 weeks later...

Yeah well the problems aren't over yet... I managed to play aboard the first scene, got into the escape pod with Carth, I get the video of the escape pod crashing into the Corsuscant street, then of the character lying on the bed. But then the game encounters another error and closes down. WTF? Must be a security error of somekind. Dunno if my Norton360 has anything to do with it... A hand?

Link to comment
Share on other sites


  • Create New...