Jump to content

Home

Siege is borked?


razorace
 Share

Recommended Posts

Spawning bots manually is the problem. And they are still completely dumb. Even with considerations, their supporting skill is very poor. And in some cases as soon as you choose your team, it hangs up. I messed up with the dll to solve it. It seems that OJP siege gets broken when the dll is changed after playing base JKA or another mod.

Link to comment
Share on other sites

Siege works but its fairly pitiful currently. It doesn't seem to update with the rest of the code meaning the saber system and gunnery system is quite an old version. The bots as already posted are also unbelivably stupid (e.g. in the Hoth map they never attack the Turbolaser turrets, only ever use one tech and don't try to go through the Wampa cave) and sveral classes seem useless (e.g. classes with the concussion rifle, which is now very underpowered).

Link to comment
Share on other sites

Well, that's weird. The TABBots should attack the turrets and sometimes go thru the Wampa Cave. I spent a lot of time getting that to work.

 

Anyway, if you mess around with the OJP dlls, you're going to break OJP since all the major changes occur in those dlls.

Link to comment
Share on other sites

Hello, I was the person that posted the thingie about it.

 

I don't really know why it does it.

 

It just doesn't start the map, It comes up with "Unexpected EOF" sort of stuff.

 

As I said on the bug ticket, I added bot support for Geonosis1a by P!ng, and that was the level I played the most, but when I upgraded to 0.1.0, it didn't work.

 

But it still does it with other maps

 

 

-Alec

 

 

P.S. Woot! First post!

Link to comment
Share on other sites

Hello, I was the person that posted the thingie about it.

 

I don't really know why it does it.

 

It just doesn't start the map, It comes up with "Unexpected EOF" sort of stuff.

 

As I said on the bug ticket, I added bot support for Geonosis1a by P!ng, and that was the level I played the most, but when I upgraded to 0.1.0, it didn't work.

 

But it still does it with other maps

 

 

-Alec

 

 

P.S. Woot! First post!

 

That isn't a OJP bug, that is because you have too many custom siege maps.

Link to comment
Share on other sites

That isn't a OJP bug, that is because you have too many custom siege maps.

 

You think so? Well, whats the limit to custom siege maps? I only have 2 or 3.

 

 

 

 

EDIT: Well, whadda you know, I deleted JASiegedestroyer, and guess what???? IT WORKS. Thank you for the help.

 

 

EDIT 2: Well, It's a shame that Sith-j-cull's maps don't work, I mean, They just...sit there, (See more details on the bug ticket, name: a few problems)

-Alec

Link to comment
Share on other sites

Yes, though I think this might just be me. I've always had a problem with OJP's bots; with issues like the bots not attacking, only going along one route etc. They seem to correct themselves after extended time. This is just the first issue that has stayed after reloading the level or proceeding to the next round. I'm currently using the latest revision, and have made no changes of my own.

Link to comment
Share on other sites

You think so? Well, whats the limit to custom siege maps? I only have 2 or 3.

 

 

 

 

EDIT: Well, whadda you know, I deleted JASiegedestroyer, and guess what???? IT WORKS. Thank you for the help.

 

 

EDIT 2: Well, It's a shame that Sith-j-cull's maps don't work, I mean, They just...sit there, (See more details on the bug ticket, name: a few problems)

-Alec

 

Well here is the scoop: maps that use completely new classes/teams you can only have up to 3 of those.

 

See: http://www.adminunity.com/ja/

 

Maps marked with red * are those that you can only have up to 3 of at a time.

Link to comment
Share on other sites

 Share

×
×
  • Create New...