Jump to content


Dark Forces 2 - 256 colours.. help


Recommended Posts

Ive bought and installed the Jedi knight dark forces 2 game but when i try to run it i get this error message "Jedi knight requires that your display is set to at least 256 colours"

I really dont know how


Well ive tried to right click on the Jedi knight icon- then Properties- compatibility - and then run with 256 colours but it didnt work.

Please tell me if im doing anything wrong or if you have another way of doing it right..



Link to comment
Share on other sites

Hi, please excuse Phlex if I'm attaching to your post, but I have the same problem.


With my old machine the game ran fine in compatibility mode (Athlon xp 2400+, radeon 9800pro, mb asus a7v a333), but when I bought ne new pc I got the same error.


Could it be an hardware incompatibility ?

My new pc is a Pk5 with intel core 2 duo 2,66 ghz (64 bit), video card ati hd2600 (xt, I not remember), Operating system XP pro sp2 32 bit. The monitor is an Eizo lcd S1931.


I've tried to install the game with all the options the installer gives, but the result is the same. Using all the options of xp 'compatibility mode' tab didn't make any effect.


the only thing reported is that under the monitor color panel I can choose only among the 16 bit mode and 32. There is no more the '256 color' option. But it shouldn't be a problem, seeing the JK's faq, the game should be runable either with 16 bits enabled.


Anyone there has got this same error ?



Thanks a lot



PS. I tried to use a win98 installation under vmware, but neither the mb and the video card drivers support this o.s. anymore.

I’m trying to install the game under cedega too (open suse10.3), but there are some problems too in mounting the CD game…. Arrgg !!! ;-)

Link to comment
Share on other sites

  • 2 weeks later...



finally I came back to this forum after some problem with my user :-O

Thanks JKLE for your infos, I've installed the patch you linked to me, but it didn't work for me unfortunately.


I'm trying to get it work under linux, but with wine emulator I get heavy graphical artifacts and, with cedega, the app doesn't install at all.


Anyone here has the same problem ?


thanks again,


Link to comment
Share on other sites

  • 2 years later...
  • 4 years later...

  • Create New...