Jump to content


XWA DirectDraw issue


Recommended Posts


I have been playing XWA on my computer for the past week or so, and as of today, i started getting this error- "DirectDraw init FAILED at 2"

the specs of the machine are as follows -

Athlon64 x2 5600+

Asus Crosshair motherboard (NVidia 590 SLI chipset -15.01 drivers)

Geforce GTX280 graphics

2gb RAM

Windows Vista x64 Ultimate


I was running 177.79 drivers for the GTX280, but now upgraded to 177.91 to try and fix problem.

I have tried running in all sorts of compatibility modes.

the problem is, it was running fine up until today.

Link to comment
Share on other sites



dropped desktop reolution down to 1024x768, restarted XWA - worked!

BUT! - the game lost all my remapped joystick buttons, graphics settings etc...

bumped desktop up to 1680x1050 again, and it still works like normal. any way i can export the key mapping etc to back it up? otherwise i will have to use the logitech software to do it for me.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...