Jump to content

Home

[Fixed] Get KOTOR 1/2 Working on Vista


Astrotoy7
 Share

Recommended Posts

mind me asking seraph,

 

i followed it to the letter for boht kotor 1 and 2

 

same problems, cant get it working

 

did you finally figure out the trick to get it running? (at least executing, minus the crashing afterwards?)

 

 

 

at anyrate, im on kotor 2, and i did everything in thread to the letter (like mentioned before) however when i get to the part of setting affinity, my dumb computer tells me that i cant do that :p

 

and then, what do you know, still crashes.

Link to comment
Share on other sites

  • 4 weeks later...
  • Replies 201
  • Created
  • Last Reply

Top Posters In This Topic

Do you have to do all the switching before installation? My computer keeps telling me that KOTOR II TSL has stopped working every time I get to the battered Ebon Hawk floating toward Peragus. I cannot even get to the intro section where I could actually save it and be past it.

 

Edit: To get KOTOR 1 working I replaced the msdll32 file from KOTOR with the msdll32 file from TSL and it worked beautifully. I just can't get TSL to work no matter what I do.

Edited by RedHawke
Combined DP...
Link to comment
Share on other sites

  • 3 weeks later...
at anyrate, im on kotor 2, and i did everything in thread to the letter (like mentioned before) however when i get to the part of setting affinity, my dumb computer tells me that i cant do that :p

 

and then, what do you know, still crashes.

Hm. There are other ways of bringing up the task manager. Try Ctrl/Alt/Delete to bring it up before you launch the game and then Alt/Tab or just hit the Windows key to get to the task manager after launching. Setting affinity to one core is a must with these games.

 

Everyone who's reading this thread now should check the edit that I made to Post #2 regarding the Dantooine lag fix. It's basically a requirement for every GPU now.

Link to comment
Share on other sites

  • 3 weeks later...

I'm on Vista 64-bit with the nVidia 190.38 driver, I've followed RS7's Vista Fix guide, made changes spoken using the nhancer program to OpenGL and added the "Disable Vertex Buffer Objects=1" to the swkotor.ini file and saved it. I'm pretty sure I haven't missed anything out from the guides and advice available, but my KotOR I still crashes on the Endar Spire. One time I managed to escape to the Taris Apartment, got outside, and guess what, it crashed then instead. :p

 

I really want to just play my KotOR on my PC, its been like a dream for the past 6 years at the back of my mind. I gave up on an old PC because it wasn't up to spec. But with my new Vista, I thought I'd give the game a shot again, but argh... my attempts are just so far - failing.

 

Does anyone have any help or suggestions to offer? Pleeeeeeaaaasssee!! I don't want to give up on this game. :(

 

 

EDIT: Actually, one detail I did not complete with the nhancer program was "to select the open GL driver version". As I didn't know how to do this. Could this be the solution?

 

EDIT II: I think I found the right option and set the driver to the highest option available to me, 3.1. That didn't help though. So... I did some more searching on these star wars forums... found another page with yet even more advice to get the game working... http://www.lucasforums.com/showthread.php?t=194296

 

After following Part II and Part III, just now I've managed to play through the Endar Spire and explore the Upper City Taris without a problem. When I get the chance, I'm gonna start from the beggining now and play through the whole game properly.

 

I couldn't have done this without the community, so thanks!

Edited by TheDirective
Link to comment
Share on other sites

Hey,

 

I'm having problems with TSL in Vista. However, as soon as I get past the character generation, the game crashes right after it plays the first movie. I followed every direction in the post #1 and #2 of this thread (which is how I managed to get even that far, but now I'm completely stumped. I just finished kotor with a minimum of problems so I don't know what's wrong.

 

Also, hardware scan yielded:

[sWKotOR]

ReportDateTime=9/8/2009 4:32:35 PM

SysInfoVersion=v1.00.60

GameExists=1

GameVersion=v2.00.424

GameInstallLocation=C:\Program Files\LucasArts\SWKotOR2\

 

[OS]

Name=WinXP

Version=Windows XP v5.1 build 2600 Service Pack 2

Service Pack=Service Pack 1

Status=Pass

 

[swapFiles]

?:\pagefile.sys=0

 

[CPU]

CPUCount=1

CPUSpeed=1995

CPUFamily=6

CPUModel=7

CPUStepping=10

CPUVendor=Intel

CPUName=Pentium® Dual-Core CPU T4200 @ 2.00GHz

Status=Pass

 

[Memory]

RAM=2048

Status=Pass

 

[Disk Free Space]

C: (NTFS), UNICODE=128.70GB

E: (NTFS), UNICODE=7.69GB

Status=Pass

 

[CD-ROMs]

DriveLetters=D:\,F:\,G:\

Drives=TSSTcorp DVD+-RW TS-L633B

 

[Video]

Video Card Name=

Video Memory=2048

Desktop Resolution=1024x768x32 @ 60Hz

DirectX=DirectX 9.0c (4.09.00.0904)

OpenGL Version=2.0.0 - Build 7.15.10.1637

OpenGL Vendor=Intel

OpenGL Renderer=Intel Cantiga

Vid Card Status=Warning

Vid Card Driver Status=Pass

GL Status=Pass

DX Status=Pass

 

[Audio]

Sound Card Name=Speakers / Headphones (IDT High Definition Audio CODEC)

Status=Pass

 

My system specs:

OS Name Microsoft® Windows Vista™ Home Premium

Version 6.0.6001 Service Pack 1 Build 6001

Other OS Description Not Available

OS Manufacturer Microsoft Corporation

System Manufacturer Dell Inc.

System Model Inspiron 1545

System Type X86-based PC

Processor Pentium® Dual-Core CPU T4200 @ 2.00GHz, 2000 Mhz, 2 Core(s), 2 Logical Processor(s)

BIOS Version/Date Dell Inc. A07, 5/13/2009

SMBIOS Version 2.4

Windows Directory C:\Windows

System Directory C:\Windows\system32

Boot Device \Device\HarddiskVolume3

Locale United States

Hardware Abstraction Layer Version = "6.0.6001.18104"

Installed Physical Memory (RAM) 4.00 GB

Total Physical Memory 3.46 GB

Available Physical Memory 1.71 GB

Total Virtual Memory 7.11 GB

Available Virtual Memory 5.59 GB

Page File Space 3.75 GB

Page File C:\pagefile.sys

 

Please help me!

Link to comment
Share on other sites

Yeah, I gathered that you had an Intel GPU. You might want to tun off all of the eye candy and turn down the resolution to minimal.

 

Is v-sync turned on?

 

I've tried it with both v-sync on and off. I've also tried with both movies and sound disabled (which I don't think is the problem since I was able to play the intro movie just fine), with grass and shadow turned off, at 800x600 resolution with low texture. The character generation and movies run very smoothly, it's just game play that doesn't work.

 

I've tried changing my desktop resolution to 800x600 as well.

 

Just one question, is there a reason why the hardware scan didn't recognize my graphics card. I mean, where the name of the card is supposed to be displayed, there's only a blank.

Link to comment
Share on other sites

Intel GPUs are not supported. For every person who reports success in getting these two games to run on Intel integrated graphics, we get someone else for whom it is not possible, so it will either work or it won't.

 

I have no freaking idea what kind of settings your graphics driver has, but have you played around with them at all? There was a fix for older Intel GPUs, but it's for very old chipsets and very likely outdated.

Link to comment
Share on other sites

  • 2 weeks later...

That flipping policy setting can be changed to "blit" by clicking on "3D Settings" in the main Intel driver settings menu. The option should be there. Sorry that I didn't post this earlier, but I only got KotOR 2 installed on my cheap laptop which has an Intel GPU last night. Hopefully you'll see this and be able to get it to work like I did.

Edited by Q
Link to comment
Share on other sites

  • 3 weeks later...

I've done the fixes people have mentioned and am still experiencing some issues with both games.

 

I have done the install with both KOTOR and KOTOR2 as admin, did the "Run as admin" and "compatibility with XP SP2" options for both, and replaced the mss32.dll file in both directories.

 

The problem I am experiencing on both games seems to be the same issue however, I get into the games, I can play the games up until there is an explosion. In KOTOR I was doing the tutorial bit still before reaching the escape pod, where it crashed was the room with the robot you can reprogram and the console you can use to cause the explosion. I caused the explosion which caused my game to crash.

 

In KOTOR2 its pretty much the same issue, I play through for a couple hours on Peragus and when I get to the part where I have Kreia and Atton with me and we fight the assassination druid after his whole speech about how he organized the killing of the stations inhabitants. I defeat him, he does his self-destruct countdown and blows up, soon as he blows up game crashes.

 

Anyone else having this issue or might know how to fix it?

 

Running Windows Vista SP2 64-bit Quad-Core Processor @ 2.20Ghz & 4GB Ram w/ Dual ATI Radeon HD 4850 Graphics Cards in Xfire

 

Edit. I seem to have found a quick fix for it, I had to turn screen resolution down to 800x600, turn shadows off, turn off anti-aliasing and anistropic and set texture quality to "low" and turn off frame buffer effects.... going to have to toy around with this later so I can find stable settings that I can play on that will look nice and still not crash.... I was running at 1600x1200 High Textures "8 Sample AA" and "Antistrophy 8x" though it could got o 16x (game said to run 8x for best)

 

Edit 2. Ok still having the issue, have tested with all the different settings, been running at 800x600 with both samplings and the frame buffer effects turned off as well as shadows, it doesnt crash as often but I am still experiencing crashing due to explosions. My latest was on the surface of Telos when you run into the woman with the 2 droids and the mines in front of them all, she through a grenade and crashed the game for me :(

Edited by bemtoto
Link to comment
Share on other sites

1) Have you done the Dantooine lag fix as instructed in post #2?

 

2) Are you setting CPU affinity every time you launch the game as instructed in post #2?

 

3) In my experience, both games run better on a single GPU.

Edited by Q
Link to comment
Share on other sites

I have done the Dantooine lag fix where you add that line into the ini files, have done everything that people listed as issues that i could do.

 

When I tried to follow the steps outlined for the setting multiple core affinity going through the task manager and administrator rights it doesnt let me change that option.

 

I have done more research/testing into this problem as well it really seems to be the "Frame Buffer Effects" option which kinda sucks in KOTOR2 since all the stealth things are visable with a really ugly shield looking graphic around them when i turn that off

Link to comment
Share on other sites

Yes I am using an admin account and setting affinity didnt work prior to my using the "Show all Processes" which is odd because the list didnt change... it worked after but still no effect on the crash issue with explosions when the frame buffer effects is enabled, there a fix available for this frame buffer problem other than just disabling that?

 

I would like to be able to play the game with it turned on as when the "Frame Buffer Effects" is disabled as i mentioned in the last post, anything that uses Stealth can be seen without the camo effect. It will be the normal graphic for the model + a shield effect around them with what looks to be a electrical current(best i can describe it, i guess the current is what you'd normally see when something is destealthed from stealth but is seen all the time running like this)

 

Edit. I was playing around with a few player made mods on the site here, visual improvements and such and seem to have fixed my issue somehow... i tested it alot to make sure... used about 40 grenades of all types to see if i could crash myself (before 1 ion grenade was enough to do it) and cant seem to reproduce the issue. Thank you for attempting to help solve this issue, guess just needed some override files :)

Edited by bemtoto
Link to comment
Share on other sites

while i am still looking for a permanent fix, i have found a temporary solution. my game will run fine but crashes after about 5 minutes unless i save every three minutes(actually more like before and after every cut-scene). this gets me past the endar spire where i can play for about 2 hours then it crashes again. the only fixes that i have tried are running the game in compatibility for xp2, as administrator, and changing the affinity(it told me i couldn't change it), and jacking up the graphics settings to as high as i could get it.

Link to comment
Share on other sites

  • 3 weeks later...

I'm having problems with Kotor 1 being closed before it can be launched by Data Execution Prevention. I've made it so it'll let my launcher be a exception but it'll still close despite this, I'm on a Vista but I'm running it was a XP service pack 2 and as a admin but nothing's working.

Link to comment
Share on other sites

 Share


×
×
  • Create New...