Jump to content


Ultimate Sith Edition: Glitchy skies


Recommended Posts

Okay I installed USE on a new PC (notebook actually, HP Pavilion dv7-6185us), immediately installed the 1.2 patch and I ran it in 1600x900 with high detail, and here's what happened.


It was somewhat choppy (I searched in vain for a way to uncap the 30 fps limit, I found a program that purported to allow 60 fps but it was only for Force Unleashed 2), but the skies were really messed up. Basically as soon as I moved around or looked with the mouse, I got the infamous "hall of mirrors" blurry effect, and some slowdown. I thought my drivers were up to date, and my direct X as well but I'm not sure what's going on.

I tried running it with "high detail" unchecked in the launcher but I have the same problem as before.


My specs are (over the recommended):


Win7 professional (64 bit), Intel Core i7 (up to 2.9 Ghz, iirc), 6 GB DDR3 Ram, Radeon HD 6409M, 1600x900 60 Hz display, BluRay/DVD Supermulti drive.


PS: I have the latest DX 11 drivers and (I think) the latest manufacturer HP graphics drivers. Any help is appreciated!

Edited by Kurgan
Link to comment
Share on other sites

Hmm, that's weird, it's now working just fine. All I did was exit out of the game, start it back up again and try out some of the other missions. I played through Hoth without a hitch. I fired up Tatooine (but got stuck in some background architecture near the beginning and had to quit, that was silly). The next time I started up I went to the Jedi Temple and it was fine (though the game did freeze up and crash when I got into a saber lock with a "training droid" later on in that level).


So I guess this just a glitchy game as everyone has been saying, but the "skies" problem has been solved. I already sent a support ticket to Aspyr media. I wonder what they'll say (if anything).


Thanks anyway!

Link to comment
Share on other sites

  • 2 weeks later...

Well this was Win7, so yes. But the problem is completely gone. I never had to change any background processes. Apparently a few computer restarts fixed it. Back in the day a lot of windows programs demanded that you restart your computer after installing before running the program the first time. They don't do that anymore, but apparently some still want you to do that. The only other thing I did was try installing the same video drivers again over the top of the previously (freshly) installed video drivers. Not sure what actually fixed it.


But now it works fine.

Link to comment
Share on other sites

  • Create New...