Jump to content


The final texturing - run into a little bump


Recommended Posts

I hope it's okay I created a new thread for this, because it's no longer about getting the model into jk2, but about texturing.


I textured my model while it was still in one piece, and it looks nice and seamless in 3DS max:




The resolution is good in 3ds Max, and for texturing the model I'm using a single 2048 x 2048 jpg. It looks fine in 3DS max also after segmenting the model, no seams can be seen.


Problem: When playing with it ingame, it is textured but the texture resolution seems a bit lower than what it appears like in 3DS max. So it seems to lose its seamlessness by showing parts of the dark untextured areas in the texture. Not so visible in these screenshots, but it gets clearer when going further away from the model for some reason. (It does not have LODs)






I understand the ideal thing would be to create a map for each different part, but I fear I would have to redo the whole process of texturing this (done in Zbrush to get it seamless)... unless anyone knows a nice solution to it? Here's a picture of the texture that is used for the whole model:




(fullsize link: https://photos-1.dropbox.com/i/o/Q-gNiJrtRXWvTi9JGeWhxl_qo18ezLkIK5r-NNXaowM/58757568/1331665200/e5a5af2/duckskin.jpg )


Any ideas? I really struggle to find a suitable tutorial... they mostly cover unwrapping basics. I need it to maintain its seamlessness and to cover the whole texture ingame...



EDIT: I realize not everyone's seeing the pictures. But this link should work, and here's all the screenshots I talked about: http://www.dropbox.com/gallery/58757568/1/Stash?h=87fecc

Link to comment
Share on other sites

The problem you are seeing is called downsampling or texture filtering. What's happening is the empty or black areas of your texture (gutters) are being "bled" into your colored areas (UV shells).


The fix is pretty simple, you need edge padding (in other words your UV shells need to be colored bigger than they actually are) Also, changing the gutter color to something closer to your texture will help a lot.

Link to comment
Share on other sites

I see! It does leave some challenges to making it seamless yet, though. I suppose I'll have to generate some new and bigger texture files if I want one part at a time. Thanks for the tip though!


Still there's one strange issue. There's not a very catastrophic seam between the hips and torso, but it looks actually detached in-game, as if a shadow comes between at certain angles (in certain lightings). I don't think it has to do with the texture. In modview, it doesn't behave that way obviously since there's no lighting, so that might prove that it has to do with the lighting in-game. Any idea what causes this?


Modview: modview.jpg


In game: shot0011.jpg


Texture file: duckskin.jpg

Link to comment
Share on other sites

The first thing on your mind when you unwrap: always hide your seams in spots that won't be noticeable.


There's a photoshop filter for the downsamplng issue, but it requires to install a standalone app called xnormal. To make sure it doesn't happen tho, it's preferable to use edge padding when baking your maps, there's probably an option for that in zbrush, i just don't know where it is.





Put this file in your photoshop plug-ins folder, when you load photoshop, you should find it under filters>xnormal>dilation


It's best to use this on each UV shell so get rid of the empty background when you use it because it's gonna grow all border pixels by the amount you entered.


The other problem you are seeing is caused by your split mesh. It's not exactly a problem, but a result of how polygons are rendered in game engines. Whenever a mesh is split, normal information changes on both surfaces and will alter the shading (think of it as smoothing groups if you know what they are).


When you compiled your model, did you check the boxes in assimilate where it says "smooth all groups" or remove duplicate vertex during compile? I don't remember exactly which one (or both or none?) might resolve the problem. So try compiling all 4 ways and see how it looks in the game.

Link to comment
Share on other sites

Might be assimilate isn't guilty of it though.


Even in 3DS Max, it looks very segmented when it is segmented.




I don't know if there is a way a model can be segmented and still look like one piece. This way, it's not about the seams of the texture, only about the visible seams of the segmentation - if you'd weld them together, it wouldn't look segmented. I think that's the final big mystery before this starts seriously looking great! I see other models have hid such seams under clothing and the likes, but this duck is naked, it's just more natural for it.

Link to comment
Share on other sites

Yeah same deal in 3d max, because that's how vertex normals shade polygons, it won't be visible when your texture is 100% lit like in modview. Try this when compiling in assimilite:


Double click on humanoid, it should open a window with build parameters, there's smooth all surfaces and remove duplicate verts from mesh during compile, try one box, then the other and both to see if it makes a difference. I doubt it will work, but worth a shot.


The only alternate solution would be to weld back the lower body to the torso then create a dummy "hips" object (a simple triangle) hide it inside the character and re-do the hierarchy.


If you don't want to go that route, you could probably use a shader to tell the engine to use your texture as 100% diffuse, i don't remember what the code looks like from memory, but i could probably find it.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...