Jump to content


Windows xp/flight yoke help


Recommended Posts

I bought an upgrade to my pc. I went to a windows 7 home edition to a windows 7 premium edition. I did that so I could get my xp mode to work so I can play my video games I used to play on my old xp pc. The xp mode works great. My problem at first was the screen resolution was too big to play the games so I shrinked it to size to fix that problem. My problem now is my joystick. Windows 7 detects it but Windows xp mode dont. It is a Logitech attack 3 joystick. I even went to Logitech's website to download some software and still it didnt fix the problem. My games wont play if it dont detect the joystick. Windows 7 wouldnt even load or play my games before I got the upgrade. My joystick is even plugged in when it dont detect it. I even swapped it with my mouse and still it dont work. Any help would be great so I can get it to work again. I would appreciate it. Also how do I get the games to play with a bigger screen resolution? It will only let me play with the smallest screen resolution. I am trying to get my x-wing series related games to work and having no luck. Logitech dont have drivers for windows xp anymore; they did last year. The games wont work without it being at 640x480 screen resolution. Is there a way to get my games to work on windows 7. I could use step by step instructions on how to solve my problems. My games will install only but that is what they will do. Is there a way to transfer the games files from xp to windows 7 without messing up the programming of the games or hard drive? My games used to work on my old pc that had windows xp on it. Any help would be appreciated.


Also I need a mod to pm me please when they get a chance.

Link to comment
Share on other sites

I am using a usb port.

I never heard of a mouse interfering with the detection.

I believe it is the game that isnt detecting the joystick.

I used another game of one of my friends and the joystick worked fine and it worked on windows 7 even though the joystick wasnt calibrated so I had to use the mouse to play the game of one my friends let me borrow.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...