Jump to content

Home

Graphics troubles


Alkonium
 Share

Recommended Posts

I have recently installed KOTOR on a laptop running Windows 7 with a graphics card the game does not recognize. While it is capable of soft shadows and post-process effects, based on my experience with other games, these are disabled on KOTOR. Is there a way to trick KOTOR into thinking my laptop has a display adapter it recognizes?

Link to comment
Share on other sites

Try opening swkotor2.ini and replacing graphical options with this (changing resolution to your desired one);

 

[Graphics Options]

Grass=1

Shadows=1

EnableHardwareMouse=1

FullScreen=1

RefreshRate=60

Width=1600

Height=1200

Emitters=1

Anisotropy=16

Frame Buffer=1

AllowSoftShadows=1

Soft Shadows=1

Brightness=57

V-Sync=0

Texture Quality=2

Anti Aliasing=8

Disable Vertex Buffer Objects=1

Link to comment
Share on other sites

Try opening swkotor2.ini and replacing graphical options with this (changing resolution to your desired one);

 

[Graphics Options]

Grass=1

Shadows=1

EnableHardwareMouse=1

FullScreen=1

RefreshRate=60

Width=1600

Height=1200

Emitters=1

Anisotropy=16

Frame Buffer=1

AllowSoftShadows=1

Soft Shadows=1

Brightness=57

V-Sync=0

Texture Quality=2

Anti Aliasing=8

Disable Vertex Buffer Objects=1

 

I tried that and it didn't seem to work.

 

In addition, I seem to be having weird shader problems:

KotOR0000_zps04ea5166.png

KotOR0001_zps4adbce10.png

KotOR0000a_zps5bd1f915.png

KotOR0001a_zps899cd1f8.png

 

To clarify, the Sith Troopers are using the vanilla textures, and I'm using mjpb3's Latex undies mod.

Edited by Alkonium
Link to comment
Share on other sites

I recently installed KotOR 2 on a new laptop with a Core i3 and it's still safe to say that you'd need most of the eye candy turned off even if it was available. You can max anisotropy and texture quality, but the only other option that will work is shadows. The HD 4000 that I have won't render grass correctly and antialiasing slows the frame rate to an unacceptable degree.

 

Every other option is grayed out, and hacking the .ini didn't work for me, either.

Link to comment
Share on other sites

I recently installed KotOR 2 on a new laptop with a Core i3 and it's still safe to say that you'd need most of the eye candy turned off even if it was available. You can max anisotropy and texture quality, but the only other option that will work is shadows. The HD 4000 that I have won't render grass correctly and antialiasing slows the frame rate to an unacceptable degree.

 

Every other option is grayed out, and hacking the .ini didn't work for me, either.

 

Ok. Thanks anyway. Any idea on what's wrong with the shaders? It looks like that even without a modded appearance.2da file.

Link to comment
Share on other sites

 Share

×
×
  • Create New...