Jump to content


Jedi Academy crashed in SP


Recommended Posts

hi everyone, i'm a new entry from italy


I have an incredible problem with my SP JA. i've to say that i got cracked version from web but it work perfectly until yesterday night for unknown reason.


here's the sign of problem:

When i started the game (i got tons of mods that doesn't gimme any problems) in SP, i choose my character skin and than the saber type and style. At last i select my saber, at the theory i start the game but when we have the "wait" screen with female zabrak before the famous "A LONG TIME AGO…" the game crash.


I tried to cut away all mods but the problem "works" perfectly. At the end i decided to reinstall the all game from the DMG (MAC) but nothing to do.


i guess that the problem is on my mac but it's possible ?? This the MP academy works perfectly with all mods installed



let me know something !!!




…and may the force be with everybody

Link to comment
Share on other sites

Probably because it is a cracked version.


Simple fix though:

1. go to Steam

2. search for Star Wars Jedi Academy

3. purchase

4. install


If the problem still persists after that we'll try to help you with specs and settings.




i've deleted my JA on computer and than purchased the steam version but the problem remains but why?, anyway i have bought the app store version and it's OK for now.


By the way thanks a lot for your reply :thmbup1:

Link to comment
Share on other sites

Hey there. This is an odd problem indeed. What version of Mac do you have?


I use the app store version primarily and it works great for me. I have the Steam version as well and it worked fine. Must be an issue with your computer.

Link to comment
Share on other sites


  • Create New...