Jump to content

Home

KotOR1 640 X 480 mod


GameMan

Recommended Posts

Hi,

 

I would like to play KotOR 1 in 640X480 resolution. These are the steps I have executed:

 

1. Patched to exe to v1.03 (I have a retail 4 CD version)

2. Ran Uniws to patch the new exe - selected KotOR (800X600) from the drop menu and set the boxes below to 640, 480 before running the patch

3. Downloaded KoTOR - 1440X900 override folder created by one of the users of this forum - it has some tga and gui files

4. Downsized the tga files from 1024X512 to 640X480 res

5. Scaled all Extent fields in the gui files (used the nwn GFF editor for this) according to the target resolution - for width and left fields used 640/1440 * the value in those files and for height and top fields transformed according to 480/900*existing values

 

My problem is that the main menu is not loading-up properly. Once I get into the game the dialogs, UI and maps are not visible. But if I alt-tab and reneter the game the UI and dialogs become visible - the mainmenu still doesn't show buttons though.

 

 

My PC config is:

Win 7 Home Premium 64 bit SP1

Core i7 from 2015

Asus Mobo

16 GB RAM (Gskill)

Geforce GTX Titanx (single card config)

60 GBB SSD (Kingston)

PS/2 keyboard and mouse

Viewsonic E771 17 inch CRT monitor

LG DVD drive

 

Request help to resolve the above. TIA

Link to comment
Share on other sites

Hi,

 

I would like to play KotOR 1 in 640X480 resolution. These are the steps I have executed:

 

1. Patched to exe to v1.03 (I have a retail 4 CD version)

2. Ran Uniws to patch the new exe - selected KotOR (800X600) from the drop menu and set the boxes below to 640, 480 before running the patch

3. Downloaded KoTOR - 1440X900 override folder created by one of the users of this forum - it has some tga and gui files

4. Downsized the tga files from 1024X512 to 640X480 res

5. Scaled all Extent fields in the gui files (used the nwn GFF editor for this) according to the target resolution - for width and left fields used 640/1440 * the value in those files and for height and top fields transformed according to 480/900*existing values

 

My problem is that the main menu is not loading-up properly. Once I get into the game the dialogs, UI and maps are not visible. But if I alt-tab and reneter the game the UI and dialogs become visible - the mainmenu still doesn't show buttons though.

 

 

My PC config is:

Win 7 Home Premium 64 bit SP1

Core i7 from 2015

Asus Mobo

16 GB RAM (Gskill)

Geforce GTX Titanx (single card config)

60 GBB SSD (Kingston)

PS/2 keyboard and mouse

Viewsonic E771 17 inch CRT monitor

LG DVD drive

 

Request help to resolve the above. TIA

 

Can't even imagine why you'd want that resolution when you have a Titan and 16GB of RAM... but if you're referring to the text not showing up on the main menu's buttons, I've had that issue before and never got it fixed.

 

Also, I'm pretty sure editing the .gui files was unnecessary, since I'm pretty sure they start at 640x480 and upscale to the resolution.

Link to comment
Share on other sites

Can't even imagine why you'd want that resolution when you have a Titan and 16GB of RAM... but if you're referring to the text not showing up on the main menu's buttons, I've had that issue before and never got it fixed.

 

Also, I'm pretty sure editing the .gui files was unnecessary, since I'm pretty sure they start at 640x480 and upscale to the resolution.

 

I dont know... the vanilla version only allowed 800x600, 1024x768 resolutions. editing the .ini wasn't helpful either.

 

Regarding the resolution - I experience eyestrain on higher resolutions, had to fish out a CRT from my brother, maybe I need spectacles but its not that acute.

 

Am I missing some files here - I have only looked at mipc210x7.gui, tooltip6x4.gui files that came with the override folder.

Link to comment
Share on other sites

I worked out a resolution to the alt-tab issue - need to disable themes in windows. But the main menu still shows no buttons. Either ways, there is a workaround to the issue - memorize button placements and use arrow keys.

 

But, would be thrilled to know a solution to the problem. TIA.

Link to comment
Share on other sites

Hi,

 

I would like to play KotOR 1 in 640X480 resolution. These are the steps I have executed:

 

1. Patched to exe to v1.03 (I have a retail 4 CD version)

2. Ran Uniws to patch the new exe - selected KotOR (800X600) from the drop menu and set the boxes below to 640, 480 before running the patch

3. Downloaded KoTOR - 1440X900 override folder created by one of the users of this forum - it has some tga and gui files

4. Downsized the tga files from 1024X512 to 640X480 res

5. Scaled all Extent fields in the gui files (used the nwn GFF editor for this) according to the target resolution - for width and left fields used 640/1440 * the value in those files and for height and top fields transformed according to 480/900*existing values

 

My problem is that the main menu is not loading-up properly. Once I get into the game the dialogs, UI and maps are not visible. But if I alt-tab and reneter the game the UI and dialogs become visible - the mainmenu still doesn't show buttons though.

 

 

My PC config is:

Win 7 Home Premium 64 bit SP1

Core i7 from 2015

Asus Mobo

16 GB RAM (Gskill)

Geforce GTX Titanx (single card config)

60 GBB SSD (Kingston)

PS/2 keyboard and mouse

Viewsonic E771 17 inch CRT monitor

LG DVD drive

 

Request help to resolve the above. TIA

 

60GB SSD? What are you doing with that little storage?

Link to comment
Share on other sites

  • 2 weeks later...
×
×
  • Create New...