Jump to content


DREAMM 2.1 Released

Recommended Posts

DREAMM 2.1 is officially released for Windows, MacOS, and Linux targets (x64 and ARM64). DREAMM is a bespoke emulator for LucasArts titles running on DOS, Windows, and FMTowns platforms.


Download it here: aarongiles.com/dreamm/


Link to what's new (also copied below): aarongiles.com/dreamm/docs/v21

What’s New in 2.1?

DREAMM 2.1 sports a number of significant upgrades over the original 2.0 release. In short, the major changes are:


  • Like 2
  • Thanks 4
  • Chef's Kiss 6
Link to comment
Share on other sites

  • 4 weeks later...

A couple of last-minute fixes and now DREAMM 2.1.1 is officially released!




This is just a bugfix release for 2.1, with a number of reported crashes fixed and support for a few new international game variants.


Full details of the changes:

  • Fixed error/lack of sound with some versions of Yoda Stories
  • Fixed unpredictable audio synchronization in Mortimer
  • Fixed joystick in Outlaws (and other Winodws games)
  • Fixed ARM-specific hangs in Infernal Machine menus
  • Improve handling of very long pathnames during installation
  • Improve behavior of Windows emulation process cleanup to reduce crashes
  • Fix crashes when exiting Indiana Jones and His Desktop Adventures
  • Fix race condition when starting up the 3D rendering threads
  • Fix occasional crash when rendering overlays with custom images
  • Support version 3 MDS image files
  • Add support for a number of new international releases
  • Like 1
  • Thanks 1
  • Chef's Kiss 3
Link to comment
Share on other sites

  • 5 weeks later...

Great work on the Windows emulation. This greatly simplifies getting the Windows games running; no more need for compatibility fixes or workarounds. With macOS and Linux versions of DREAMM, it also makes them more portable!


Having said all that, I did find one issue.

Shadows of the Empire (GOG release) has an issue where the OGG tracks are stuttery, and eventually stop playing entirely. Is this related to the WinMM wrapper (win32.dll) that GOG uses to emulate the CD audio tracks? I've witnessed similar issues with the Windows versions of X-Wing and TIE Fighter (whose WinMM wrapper is named music.dll). I ordered an original CD of the game off eBay, and will test it to see if there are any problems with the tracks.


Rebel Assault II version FA1.08 actually has a native Windows version of the game, which uses DirectX. I imagine there's little point in supporting that (probably doesn't have much improvement over the DOS version), but it's still good to know.


All in all, a fine emulator for LucasArts games. Hopefully, X-Wing Alliance and X-Wing vs. TIE Fighter can be supported in the future to complete the X-Wing series. More classic Star Wars games will certainly help. I've got Phantom Menace on the way from eBay, and that game has severe compatibility issues.

  • Like 1
Link to comment
Share on other sites

I was playing a bit of Curse of Monkey Island again yesterday with the latest version, and noticed an issue I’ve seen before where the music doesn’t play when you first return to gameplay after turning Elaine into a gold statue. The music only kicks in once you’ve left the scene.


I’m almost certain it’s meant to play there… I think!

Link to comment
Share on other sites

It should be the Part 2 The Curse Gets Worse Act screen that has music that continues back into the Puerto Pollo beach/fort, followed by a few strums of harp music before kicking back into some music. Maybe it's getting tripped up trying to find that harp music file/cue, and halting more music?

Link to comment
Share on other sites

Wowie-zowie, that's true, music should play! I can reproduce it too very consistently with my english copy.

EDIT: and THIS is where it gets weird, playing the original EXE without DREAMM consistently yields no music as well. But this is not a collective allucination or some kind of Mandela effect, music is really supposed to start there... I should try to see what happens in the disassembly.


EDIT 2: ever weirder, the issue is not there when running the game with the IDA debugger with the windowed flag, nice 🙂

Edited by AndywinXp
  • Wow 2
  • Confused 1
Link to comment
Share on other sites

I just got my Shadows of the Empire CD, and the CD audio plays without issue in DREAMM. So it looks like the WinMM wrapper is not properly supported. And from there, I found other issues in X-Wing and TIE Fighter.


In TIE Fighter for Windows, selecting the Joystick Flight Options doesn't show any options at all; the list is blank.

In X-Wing for Windows, the joystick buttons can be reassigned without issue. However, rotating the Z-axis causes changing the engine speed, when this shouldn't be doing anything, and indeed does nothing in the joystick configuration.

I can say for certain that these are issues with DirectInput emulation. It's serious in this case, since these games won't run at all without a joystick.

EDIT: Indeed this is an emulation issue, as playing these games directly from Windows doesn't have such problems.


The DOS CD version of X-Wing has a tendency to hang when entering a mission.

EDIT: The DOS versions of X-Wing and TIE Fighter work just fine with the joystick now. It must have been a configuration goof on Windows' part that fixed itself.


The joystick I'm using is the Logitech Extreme 3D Pro, if that matters. It works wonderfully with the Rebel Assault games.


Edited by EOakford
DOS joystick support actually works just fine
  • Like 1
Link to comment
Share on other sites

  • 3 weeks later...

Spotted another two oddities that may or may not be present on original hardware:


1. After looking at EL POLLO DIABLO!!!!!, the music seems to skip back a few seconds each time.



2. A couple of times while doing the banjo challenge, I tried to play my note immediately after the music stopped and the cutscene for me being too slow immediately started. Normally you get a second or two so I think some timing issue sometimes reduces it to nothing. I worked around it by not waiting until the music ends.

  • Like 1
Link to comment
Share on other sites

4 hours ago, Thrik said:

1. After looking at EL POLLO DIABLO!!!!!, the music seems to skip back a few seconds each time.


Oh no no, that's perfectly normal! 🙂


Whenever you do one of the following things:

* Looking at the Pollo Diablo painting;

* Looking at the recipe book;

* (Probably one or two more things I can't remember)...


The engine makes what's called heap savegame (a temporary savestate), and then proceeds to change room to our destination (the painting or the recipe book).

Whenever we have to go back to where we were before, the engine re-loads the heap savegame. That's a neat trick which avoids moving around SCUMM variables to only show a room which has very few interactions.


The caveat here is that the iMUSE state is being saved into the savegame (as it normally should) and then reloaded: this means that the music will restart from the point it was saved before.


So TL;DR: that's normal and happens on the original hardware as well.

Edited by AndywinXp
  • Like 4
  • Wow 1
  • Chef's Kiss 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...