Jump to content


JK2 Linux ded sever => segmentation fault.


Recommended Posts

So here is my problem.

I upgraded my dedicated server for Jedi Knight II (a Linux one) to version 1.3 and copyed the "assets2.pk3" file to avoid the "segmentation fault" error.

The problem appears to be the same withQuake 3 (Retail 1.31)


Everything seems to work fine, since the server now runs (which was not the case befor uploading the pk3 file) and the bots are loaded (I use minimum number of players setting).

The problem comes when peolple enter the game. After a variable period of time, then comes this damn "segmentation fault" again, disconnecting all players, and sometimes cashing the all linux box.


My configuration is as follows :


K6-2 300 Mhz

eth0 : D-link DFE 530-TX

eth1 : 3com 3c509 ethernet controller (server runs on this one by default)

96 Mo RAM


All units are linked by a 16 ports switch (100 Mbits).



I use exactly the same configuration files for both games, except for special values (such as map rotation fo example)


My configuration files :




set dedicated "1"
set sv_pure "0"
set bot_enable "1"
set com_hunkMegs "64"
set sv_maxRate "15000"



// Les infos Publiques
seta sv_hostname "Hell-OnLine - Jedi Knight II 1.03"
seta g_motd "May the force be with YOU..." 
seta sv_maxclients "32"

seta sv_maxRate "15000"
seta g_maxGameClients "0"
seta sv_reconnectlimit "3"
seta sv_zombietime "1"
seta g_inactivity "180"
seta g_forcerespawn "30"
seta g_syncronousclients "0"
seta sv_maxPing "0"
seta sv_minPing "0"
seta sv_floodProtect "1"
set capturelimit 5

rconpassword "********"

seta sv_allowDownload "1"

// Les Logs
seta g_log "logs/games.log"
seta logfile "3"
seta g_logsync "0"

// Les Bots
seta bot_minplayers "5"
seta g_spSkill "3"
seta bot_nochat "1"

// Type de Jeu
// De préférence du Free For all, mais sinon :
// 0=FFA 1=Tournament 2=DM 3=TDM 4=CTF
seta g_gametype "0"
seta timelimit "60"
seta fraglimit "35"
seta capturelimit "0"

// Un petit warmup de 10 secondes pour se chauffer
seta g_doWarmup "1"
seta g_warmup "10"

// Voting
seta g_allowVote "1"

writeconfig jkiiconfig.cfg

// Rotation des maps
set g_autoMapCycle 1
map ffa_bespin


I check the sizes of pk3. they are the same on clients and server...

I tried several parameters on clients but this is allways the same result. :confused: :confused: :confused:


I need your help


Sorry for my poor English (i'm fench as you can notice reading commentaries in *.cfg files)

And Thanx for your future answers :) :):D :D



PS : I can post you the logs if you like, but i looked at them, and nothing appeared concluant to me...

The "Segmentation fault" does not even appear in them:confused:

Link to comment
Share on other sites

Hmmmm I got the same problem but some diffrents. I have download the win32 stuff. Where I create the dedic. server?

I have create in the dedjk2.exe (the file i download) but when I gonna search after my server .. I couldnt find it instead i find it in Local "SwedenTrainingGround[uPD]" [uPD]???????????

Please help ME!!!!!!!!!!!!!!!!!!!!!!!



bluearmyclan@hotmail.com :jawa

Link to comment
Share on other sites

Dead like a graveyard, eh? I guess the 800+ posts I have answering questions don't count for much. *sigh* Are you both running 1.03? or 1.02x? If it's 1.02x then I'd say you need to turn off dismemberment or someone is using an exploit to crash your server. If you are using 1.03, then I'd be surprised since I've had hardly a lick of trouble with it.


If you want help, it's useful to be polite. I'm prone to helping anyway, but I thought I'd mention it anyway.

Link to comment
Share on other sites

I totally agree w/ you MatrixCPA, being polite is the minimum...


Concerning my problem, I am using the 1.03 server.

I am experiencing the same problem w/ quake 3...

I have seen that running the server with "-noudp" can sometimes solve the problem, but it did nothing for me...


Pleeeaassseee... I need your help :( :(

Link to comment
Share on other sites

Well, although dismemberment was "fixed" in 1.03, you could try turning it off and see if that helps. The noudp setting is more related to the master server listing/ability for players to connect from outside the network. Of course, the setting is noudp 0 and noipx 1.

Link to comment
Share on other sites

sorry this amount of questions, but i am not really sures of the right way to set those flags your talking about.

I gueess it should be something like that :

"set noudp 0

set noipx 1"

in my server.cfg file.


What is dismemberment, and how could I disable it as you are suggesting ??


Thx a lot for your help :)

Link to comment
Share on other sites

:( :(


I tried this command and this damn server goes on crashing.


One question :

Does the installation directory matters ??

I installed the binaries in my home directory, may this be the source of the problem ???


thx again for your help :)

Link to comment
Share on other sites

  • 11 years later...

  • Create New...