Jump to content

Home

Looking for bsp file after 1.03 update?


w0ls0n
 Share

Recommended Posts

Hi,

 

I run Jedi Knight II Server on FreeBSD. Ever since I upgraded to the 1.03 update, I cannot run Jedi Knight at all. It is now asking for a .bsp filename and my maps are ending with pk3. I am stuck and don't know where to go from here.

 

I tried renaming the .pk3 file to .bsp and that didn't work and I didn't think it would. I got this for the following error code:

 

ERROR: CM_LoadMap: maps/skyhigh.bsp has wrong version number (10 should be 1)

 

 

 

Thanks!

Bill:confused:

Link to comment
Share on other sites

bsp's (the maps themselves) are held inside the pk3 files, which are literally just zip files.

 

My guess is that 1.03 patched one of the pk3 files with new data, and your server still has the 1.02 version.

 

you can probably copy the pk3 files from a working PC 1.03 install, or try running the patcher again.

Link to comment
Share on other sites

I repatched the Linux server to the 1.03 update and when loading the maps, I am getting the following error:

 

handle 1: qconsole.log

----------------------

30936 files in pk3 files

Loading vm file vm/jk2mpgame.qvm.

VM file jk2mpgame compiled to 1926381 bytes of code

jk2mpgame loaded in 7117280 bytes on the hunk

------- Game Initialization -------

gamename: basejk

gamedate: Mar 04 2002

------------------------------------------------------------

InitGame: \sv_floodProtect\1\sv_maxPing\0\sv_minPing\0\sv_maxRate\10000\sv_maxclients\32\sv_hostname\jkii-linux v1.02\fraglimit\15\version\JK2MP: v1.03a linux-i386 May 15 2002\dmflags\0\timelimit\20\g_maxHolocronCarry\3\g_privateDuel\1\g_saberLocking\1\g_maxForceRank\6\duel_fraglimit\10\g_forceBasedTeams\0\g_duelWeaponDisable\1\g_gametype\0\g_needpass\0\protocol\15\mapname\ffa_bespin\sv_privateClients\0\sv_allowAnonymous\0\sv_allowDownload\0\capturelimit\20\gamename\basejk\g_maxGameClients\0\g_forceRegenTime\200\g_forcePowerDisable\0\g_weaponDisable\0\g_redteam\Empire\g_blueteam\Rebellion

Segmentation fault (core dumped)

 

What is a Segmentation fault?

 

Bill

Link to comment
Share on other sites

it's just a generic "oops I screwed up" error.

 

What it really means is the program tried to access or modify memory it doesn't have access to, and the system booted it's ass out because of it.

 

As to causes, it's beyond me to figure out.

 

It could be a bug in the program or it could be something odd that you're doing.

Link to comment
Share on other sites

Now I am right back to where I started. If I change the map and in my command line I type :

 

./jk2ded +exec server.cfg +map ffa_besbin

 

It does the following:

 

(/usr/games/jk2/) root ./jk2ded +exec server.cfg +map ffa_besbin

JK2MP: v1.03a linux-i386 May 15 2002

Initialising zone memory .....

----- FS_Startup -----

Current search path:

/root/.jkii/base

/usr/games/jk2/base/assets1.pk3 (8011 files)

/usr/games/jk2/base/assets0.pk3 (6674 files)

/usr/games/jk2/base

./jk2ded/base

 

----------------------

14685 files in pk3 files

execing mpdefault.cfg

execing jk2mpserver.cfg

couldn't exec autoexec.cfg

Hunk_Clear: reset the hunk ok

--- Common Initialization Complete ---

logfile opened on Tue May 21 08:59:12 2002

 

Opening IP socket: localhost:28070

Hostname: counterstrike.suscom-maine.net

IP: 207.5.159.160

execing server.cfg

Can't find map maps/ffa_besbin.bsp

Hitch warning: 775 msec frame time

 

Bill

 

I am about ready to hang this whole project up. Ever since this stupid 1,.03 update I have had nothing but problem after problem after problem. Who made this update so I can email them directly?

Link to comment
Share on other sites

I am completely at a loss. I started over from scratch and it is still giving me the same error. I am just about ready to give this up. Who made this update? I have not had a problem until 1.03 came out and 1.02 was working fine.

 

Bill

-- Ripping my hair out

Link to comment
Share on other sites

Hi,

 

Well, I figured out what it was. I decided to read the freakin manual. One line that is in addition to the 1.02 patch is that you have to copy the assets2.pk3 file from the game install. Once I got that working, BLAM! It came up! WOO HOO!

Link to comment
Share on other sites

 Share

×
×
  • Create New...