Jump to content

Home

ForceMod II - Final beta feedback


Recommended Posts

  • Replies 224
  • Created
  • Last Reply

Top Posters In This Topic

cHoSeN-oNe has just informed me of a bug when running a dedicated server.....

 

EDIT: This bug was with the last version. Host dedicated servers to your heart's content. :)

Link to post
Share on other sites

I played forcemod for about 20 minutes with no problems, then i changed the f_saberdroptime to 0. Five minutes later my game crashes. Does this happen to anyone else? When i switched my f_saberdroptime to a non-zero value (in this case 1.5) i encountered no problems.

Link to post
Share on other sites

rut-wa: saberbreaks occur when the very first thing you hit on the opponent is the arm or hand holding the blade you want to destroy. So you must hit the right arm to destroy the dualblade, and the left arm to break the 2nd saber. This is actually quite difficult, because the lightsaber must be on, and it's very hard to hit the saber arm without hitting something else first (esp. the saberblade) with the current collision code.

So it's not a common event - but you'll receive a message if someone breaks your blade, and there will be a small explosion and the person will fall to the ground.

When you say they lose sabers, is it the special blades? or are they stuck with the throwing hand out?

 

Mace_Windu21: I'll tidy those blades up a bit.

 

Classic Luke: I found what was causing the problem with f_saberdroptime and it will be fixed.

Link to post
Share on other sites

It`s when they are stuck with their arm in the throw position. I don`t think it`s a problem with your mod though.

I found a random bug too, on bespin I was having a saber battle against a bot when all of a sudden i found myself stuck to a wall and noticed a green and blue line between my character and the wall. WIERD !!!!. It has only occured once I am trying to recreate it so i can send you a pic.

 

The Mod is stunning BTW ! :D

Link to post
Share on other sites
Originally posted by Azymn

rut-wa: saberbreaks occur when the very first thing you hit on the opponent is the arm or hand holding the blade you want to destroy. So you must hit the right arm to destroy the dualblade, and the left arm to break the 2nd saber. This is actually quite difficult, because the lightsaber must be on, and it's very hard to hit the saber arm without hitting something else first (esp. the saberblade) with the current collision code.

So it's not a common event - but you'll receive a message if someone breaks your blade, and there will be a small explosion and the person will fall to the ground.

When you say they lose sabers, is it the special blades? or are they stuck with the throwing hand out?

 

Mace_Windu21: I'll tidy those blades up a bit.

 

Classic Luke: I found what was causing the problem with f_saberdroptime and it will be fixed.

 

My apologies Azymn

I was using wrong version of your mod I never checked my email after I got the 1st version of beta 3 you posted.

 

I have noticed bots turn sabers off and on alot if bot_honourableduelacceptance cvar is set to 1. Can the seeker droids be disabled for pure saber bots ?

Link to post
Share on other sites

Yeah, those seeker droids get annoying. Desann lost his lightsaber again a few times when I played, and I set the lightsaber block for Lightning AND Drain, but neither worked. Is it because I'm using Twin Lightsabers? Just wondering.

Link to post
Share on other sites
Originally posted by AOTJ_Craig

Yeah, those seeker droids get annoying. Desann lost his lightsaber again a few times when I played, and I set the lightsaber block for Lightning AND Drain, but neither worked. Is it because I'm using Twin Lightsabers? Just wondering.

 

To block drain and lightning you have to keep the crosshair on your opponent.

Link to post
Share on other sites

Did that, it didn't block. Also, with Jedi v. Merc mod off, the Bryar Pistol is unselectable, it wont let me switch to anything but the lightsaber, even if im "Lightsaber and Guns." Mind telling me whats wrong here too?

Link to post
Share on other sites

Ok, found somethin weird. After some extended amount of time of playing on MercMod, JO seems to close out saying it performed an illegal operation. Also, when flying on jetpack and using the grapple it says illegal operation. The seeker drones are getting VERY annoying and making it hard to have a decent fight vs. Bots. In normal game mod (no Jedi Vs. Merc) the Bryar can still be selected, just not directly, its like I have to pick up another gun before it will let me switch to it.

Link to post
Share on other sites

When i perform emotes or rolls, the final arm animations stick for a while, then return to normal. the jetpack fires kinda stops every once in a while, then turns back on. When you jump slighty forward shooting 2 pistols, certain models (maul) will have their torso turned completely around, like a creepy chucky doll. also, when i execute .cfg files, it will occasionally crash my game. and, though this has only happened once, i started bespin streets and spawned in an out-of-map point, then i had to devmap/restart it to fix it. but like i said, it's only happened once. and, lastly, i cant seem to select dual e11's, and i have typed in the console command. that's all i've found for now. AWESOME MOD, btw.

Link to post
Share on other sites

bliv: lol - you're right. I can't believe i posted the wrong version initially. Make sure everyone who has problems has downloaded the version with the main menu that reads:

 

ForceMod II

The Mercs Strike Back

 

,or else you have the old beta 2.

 

I will disable seeker drones for the pure saber users, they actually started buggin me too. :)

 

AOTJ_Craig - I'll fix the bryar when jedivmerc is off. You probably just don't spawn with any ammo. You can still block with Twin sabers - make sure f_saberblockall is set to "1", in addition to the lit/drain blocking.

 

For crashes, try and determine what events are happening right before the crash - i'll check out the jetpack/grapple combo. Is anyone else having the same crashes?

Make sure f_saberdroptime is at least "1" (this will be fixed in the next version). If anyone else can find specific cvars that cause the problem, that would be great.

Link to post
Share on other sites

KiLLeR_SqUiRReL - I'm trying to find ways of fixing those anims...i'll check out the other stuff you mentioned.

Dual e11's (i assume that's the blasters) can only be had if you're a heavy soldier, and f_dualgunshow is "1".

Link to post
Share on other sites

Woo, great job on what I saw. :)

 

Heres the bugs:

- Force Template pages that you have to switch to don't show up until you save one.

- There are some darks in the pure jedi one, light syrup shows up dark, as does white knight. Might do this in other ones, didn't check.

- Level 4 Jump doesn't drain any force

- Can't roll multiple times (Not sure if this was intended, but I like to be able to hold down roll and go untill I let go

- Not really a bug, but is it possible that you could list the emotes in /aminfo?

Link to post
Share on other sites

- Force Template pages that you have to switch to don't show up until you save one.

- There are some darks in the pure jedi one, light syrup shows up dark, as does white knight. Might do this in other ones, didn't check.

The menus are certainly one of the trickiest things i've dealt with. I'll do my best to get them workin right for the final release.

 

- Level 4 Jump doesn't drain any force

You have to adjust the jumpmod settings in the forcemod->force powers menu on the main screen.

 

- Can't roll multiple times (Not sure if this was intended, but I like to be able to hold down roll and go untill I let go

Looking into it...

 

- Not really a bug, but is it possible that you could list the emotes in /aminfo?

You got it.

Link to post
Share on other sites

Squirrel - Can you email me the cfg files that were causing it to crash when you ran them?

 

Also - have any of you noticed that it crashes when a merc dies?

Or when you use the grapple and jetpack at the same time?

 

I'm trying to pinpoint the problem, so any thoughts would help.

Thanks.

Link to post
Share on other sites

×
×
  • Create New...