Jump to content

Home

ForceMod II - Final beta feedback


Recommended Posts

I tried to fix the saber blades so they would be saved differently, because they should load at startup. Check in your jk2mpconfig.cfg to see if tck_red1, tck_green1... are being saved in there.

 

Littleman206 - While you are correct on many of your points, it's important for me to know how other people who aren't familiar with this mod will perceive it. It's fine to point the stuff out, but try a more diplomatic approach next time. :)

 

Padawan_7 - I attempted to address the bugs you listed in your posts. Lemme know which ones are still occuring.

 

mariners2001 - I have removed extended sabers from the menu b/c it is unlikely i will get them implemented in the final release, and they're easily had by editing the tckmodel.cfg file for the character that would have them. And the % chance to break-a-blade on any hit is a bit too strong, and will be reserved for those who like experimenting with cvars, as it was never intended to be that easy a the base ForceMod game. That way there will be fewer servers who have people losing their special blades after one hit. :)

Link to post
Share on other sites
  • Replies 224
  • Created
  • Last Reply

Top Posters In This Topic

Originally posted by Littleman206

Padawan, would you stop winging, heres a bunch of the bugs you reported, and they're all bull****.

 

Grapple not extending or retracting, Azymn's said he's working on this a million times, stop repeating everyone else.

 

I wouldn't know what the other people were saying ... I just joined the beta testing team. ;)

 

Shield recharge has a transparent green box. THATS NOT A BUG!!! It's just the icon you dumbass.

 

It is a bug, of sorts... none of the other icons have a box surrounding them. To me, a person who HAS done some graphic designs before, the icon appears as if the surrounding area was filled with a color that was close in appearance to the transparent color but was simple NOT the transparent color.

 

No space between "weapons:Sniper Rifle" Who cares, you can still see what weapons your getting, why does it matter AT ALL?

 

That's a mistake, none the less.

 

Dual firearms, special mercs only. Heavy soldiers are one of therse special mercs! It says in there weapons dual pistols!!! It's not a bug if its MEANt to be that way.

 

Actually, it says in BOTH the in-game menu and the ForceMod website that Bounty Hunters have dual pistols as their default special ability... and Heavy Soldiers do NOT. And in the ForceMod menu there is no "Bounty Hunters only" option. The closest thing was the option "Special Mercs Only". So, I would assume that it means Bounty Hunters.

 

Start with a stun baton, who cares. Cycle to the next weapon(s) and your fine.

 

Switching mercs gets you starting with different weapons, its becasueit their highest powered weapon. Who cares, same solution as above, change guns!!!

 

Actually, some people do care. I know on professionally made fps with class systems (not meaning that Azymn is not professional ;) ... just referring to a game that you pay money for) like the Elite Force Expansion Pack, all players that spawn with rocket launchers and grenade launchers always start with the standard phaser in hand. I know it's not a earth shattering bug. But, then again, it's a bug, none the less.

 

Troopers have unlimited ammo, it says that in their description. Thats why he/she never ran out.

 

I know that. If you had read my post carefully enough, you would have seen that I had tested the Scout and Heavy Trooper classes and they would NOT use ammo regeneration. I was just merely stating that I thought that maybe the Trooper was indeed working correctly, although I wasn't totally sure since they ended up killing themselves. ;)

 

It does save our colours, default is just white. all you need to do is go into the TCK saber menu for literally a split second so it refreshes your saber to those settings. No dramas there.

 

As I had stated above "Even though the menu saves my rgb saber settings, every time I start the game fresh the saber starts out white." That IS a bug.

 

Double tap for front on wall run.

 

Yes, I know that. I've played JKII EXTENSIVELY since the first week it came out. For some reason or another it just was not working... no matter what force settings I applied.

 

Sorry if I insulted you as I'm sure I have, but complain about something important and actually check the stuff your complaining about.

 

Well, you have a right to your opinion about me. I'm not going to hate you for it. I do think you shouldn't be so quick to judge. I have done beta testing for this community before and I am somewhat of a perfectionist... I was only trying to call them how I seen them. :)

 

Padawan_7

Link to post
Share on other sites

Hmmm, I looked into the jk2mpconfig and i see that the tck_rgb values are all at 50 :(

Also, just as you said, when i set the tck rgb colors up and go back in game, then i return to the tck menu, the rgb values are reset at 50 again:(

However, I must thank-you for increasing the bot emotional attachments to 8 :)) Almost there Azymn!! :)

 

edit: I found out how to SET SABER COLORS for now guys!!!

After thinking about what you said about saber colors loading at startup, I decided to put my desired tck_rgb into my autoexec file and IT WORKED!!! Now if only i knew the command for the saber skins :)))

Link to post
Share on other sites
Originally posted by Littleman206

Padawan, although I dont expect you to believe me or accept it, I'm sorry.

 

Littleman206, I believe you and I totally accept your apology. No hard feelings. :)

 

Padawan_7

Link to post
Share on other sites

Those of you whose saber colors reset everytime:

Check to see if there are two pk3s in the ForceMod folder, and if so delete the one ending in "beta_f3.pk3".

Lemme know if this is/isn't the problem.

Link to post
Share on other sites

Just uploaded a newer version, same link.

 

Lots of little fixes i won't list, so it's okay to list things you've already listed before b/c i probably missed them.

 

The file "cvar_list.txt" is now in it's final version (including a list of clientside cvars), so if you see any typos/errors/questions lemme know.

Link to post
Share on other sites

I forgot to update the main menu setup...i just uploaded the beta again with that file fixed.

 

rut-wa: Even though it shows the blue saber icon, the bots are using the proper stances.

 

My rgb sabers work fine on this build, so if you're having problems, make sure everything's installed properly, and post exactly when/what happens.

Link to post
Share on other sites
Originally posted by Azymn

I forgot to update the main menu setup...i just uploaded the beta again with that file fixed.

 

rut-wa: Even though it shows the blue saber icon, the bots are using the proper stances.

 

My rgb sabers work fine on this build, so if you're having problems, make sure everything's installed properly, and post exactly when/what happens.

 

My mistake about bot stances, sorry:rolleyes:

but regarding the Tck saber menu the slider bars still do not alter the colour preview of the custom saber

Link to post
Share on other sites

Even though I do not have the beta version... I just KNOW this mod is going to be awsome! I'm gonna get it the first day, and put it on our T1 server! Wow! Azynm you are one hell of a modder!

 

~Jedi Master Achilles

Link to post
Share on other sites
Originally posted by rut-wa jodar

...regarding the Tck saber menu the slider bars still do not alter the colour preview of the custom saber

So the preview saber in the menu doesn't change, but the sabers in-game work correctly?

Link to post
Share on other sites

Just checked it now Azymn, yep the tck colors don't appear on the preview saber. I noticed that with bots, they use force grip sporadically if its on level 4. However, on level 3 they seem to grip opponents for a time as I think is proper :) (IMO)

Despite this, however, I sense a release to the public real soon :)

Link to post
Share on other sites

yeah..the rgb preview isn't working here either..

 

also one other bug i noticed was that the watto bot's jets and sounds still aren't gone. this should probably be fixed before release. also, the mandalorians still aren't really using their jets that much and seem to need a boost ;)

Link to post
Share on other sites

1. When i changed my game to basic mercmode, I noticed that as a merc you spawn with a bowcaster, pistol, tazer, and blaster. However, in actuality all you can use when u spawn are the bowcaster and the tazer:(

 

2. Under basic merc mode, when choosing the class of merc it shows the right icon on the player setup menu, but to the right of this is a jumble of descriptions (of the classes and equipment) which overlap eachother.

 

3. When one plays as a merc, you can roll and shoot at the same time (meaning you can shoot while in mid-roll). Hmm, while this makes getting kills easier, I feel this may need to be corrected. Lord knows I was spamming this big time against fellow mercs:).

 

4. Hmm, depending on which hilt one picks, some blade skins appear to be unattached to the hilt if one looks closely.

 

5. When using the tri-engine jetpack, the middle engine is not centered.

 

6. As Rut-Wa said, the preview blade is not registering.

 

7. I am curious as to what everyone thinks of increasing primary bryar pistol damage? I for one am for it:) To get a kill when using primary fire with the pistol is near impossbile even when exchanging fire with a fellow merc armed with a different weapon. It requires a LOT of shots to get a kill:(

 

8. Saber-throw has been improved somewhat I think. But I can forsee mercs having a hell of a time on servers where many others are saber throw enabled. It seems that being in range to illicit a saber throw from a bot will almost always end in death, and note, that this distance is far too great imo. What to do about this, I am unsure. Would decreasing saber-throw damage to say 50 to 70hps be too much? Maybe this damage can be directly to ones hps and not the shields. This i would like to see implemented.

 

9. Like I said, almost there!!! :) Keep up the great work Azymn!!

 

Edit:

10. Hmm, when I went back into basic mercmode, I could not designate myself as a merc at all. Even after respawning many times and checking the setup menu (under class I chose to be a merc), I still spawned with a light saber. I even went as far as to make sure I had absolutely no force powers availible and still no luck.

Link to post
Share on other sites

Eh, told you there'd be some kind of bugs.

 

Ok, just tested, the ones in bold are the ones that bother me most.

 

1. Bots (in FFA, no Mercmod) run around with Bryar too much without shooting

2. As mentioned before, saber preview does not work.

3. This isnt a bug, the annoying Jedi Vs. Merc message is gone, THANK YOU AZYMN!

4. When set to block Lightning and Drain, it still does not block lightning and drain.

5. When you set the Saber type thing to Changeable (not locked), it doesn't change at all until you die. (Note: there IS a sperate option for locked until respawn, so they seem to be one in the same.)

6. Level 4 Force Jump still does not drain force energy.

 

That's all for now, still trying to find some more.

Link to post
Share on other sites

Same Link.

 

Fixes:

- Tck Saber Menu Preview updates correctly now

- Watto and Maw now fly w/out jetpack fx

- Basic JediVMerc now assigns jedi and merc properly, with menu fixes

- f_sthrowdmg now reduces saberthrow dmg by 1/2 in jedivmerc mode

- f_mercjump determines jump level for mercs (0 by default)

- f_jumpmod values rearranged, so costs by default

- Can change sabertype during match if f_forcesabertype settings allow it

 

 

rut-wa: I believe there's a base jk2 cvar that lets you disable certain forcepowers.

Link to post
Share on other sites

When in mid-air, turning off the jetpack results in your player being in an unatural position with arms straight out to the side with legs straight and spread out. (the position your model appears in when initially in Mod View)

 

Edit:

When spectating my bots, I noticed that my clonetrooper once out of ammo with the repeater, would use the ammo regen device only for a split second (enough to generate an attack). Then, the bot would attack and be out of ammo again lol. This cycle continues of course till the bot is killed. I am curious if you can make it so that when bots are out of ammo, they will regen ammo while at the same time using their second weapon of choice. Maybe they can regen ammo to a certain percentage (say 50% full) or until the ammo regen bars are gone. :)

Link to post
Share on other sites

That`s sorted it Azymn , nice one :D

 

You have really worked hard on this mod and all of your efforts have paid off. Raven software should knocking on your door with a job offer ;)

 

 

 

 

 

 

 

 

Re: saber throw disabling I have not found a cvar for it.

Link to post
Share on other sites

I',m not sure if this is a bug or just a nice touch but when using force mod 2 final beta if you fire a rocket at a bot on jedi master skill when they use force push and push it back at you, you see to use force push and push it back at them. This happens except I don't think u lose any force. This works when using the jetpack and when not.

 

If it's a bug you might just wanna have a look into it.

 

Thx for the great work!!!

Link to post
Share on other sites

×
×
  • Create New...