Jump to content

Home

"Awaiting Gamestate" longer than usual


Recommended Posts

Hello,

 

I released a first beta version of my mod recently on my clan server, but I'm having trouble understanding something that only happens there (I don't have the problem on my own computer).

 

Sometimes, I think especially when there are many people on the server, people get stuck at "Awaiting Gamestate". They connect just fine, and the "<name> connected." message is broadcasted correctly. But then they're stuck there for many seconds (a lot longer than the usual 2 seconds) or even timeout before being able to connect. The client game doesn't crash though, the console is still working and the cgame module isn't even loaded yet. This happens with both my modified client, and the original BaseJKA client.

 

So I "set developer 1" on the server and looked at the qconsole.log, and noticed a lot of "dropped gamestate, resending" messages while a client connects. The trouble is, that didn't happen when we were using JA+ on the same server, or even BaseJKA. So I tried compiling the BaseJKA code from the SDK and using it on the server, and strangely it also seems to have the same problem. When using the "true" BaseJKA server module, I can connect in about 2 seconds, but when using the one I compiled, it takes longer (6 seconds at best).

 

.. which leads me to this question: where do you think the problem comes from? my compiler? (Visual Studio .NET 2003 on Windows XP SP2), the server itself? (MammothGame's, but it works normally with the true BaseJKA and JA+...), anything else?

 

Also sometimes there are weird glitches on this server, for example NPCs crashing the whole server, vehicles not spawning, and other random things that work fine on my computers. Please, what's wrong? :'(

 

Thanks for any advice.

Link to post
Share on other sites
×
×
  • Create New...