Jump to content

Home

Jedi_82

Members
  • Posts

    53
  • Joined

  • Last visited

Everything posted by Jedi_82

  1. HP 3,20 ghz, 512 ram geforce 7600 gt 256mt, and 8m/1m full rate speed well if u dont want to know specific info thats most of it hehe.
  2. Well Rogue5 it also depends what kind comp u have. On myne it takes 20 secs to load and runs perfect almost no lag.
  3. Well 512 is enough i my self use 512 and runs fine. And trials of obi wan only addes mustafar and some other things and u seriously need trials of obi to advance higher than cl 60-70. Just buy complete adventures and ur fine.
  4. Darth Idoit. You have to buy whole package. If u buy the newest one it is complete adventures and it has included star wars galaxies empire divided, jump to lightspeed, rage of the wookies and trials of obi wan. Well theres total experience too but it dosent have trials of obi wan so i would sucjest complete adventures. Whole pack is about 30$. BTW u dont have so much RAM do u? heh 256 it will play but it has lots of lag i would sucjest that u buy either 512, 1024 or 2GB. Hope this helps. And Total experience is old fashioned. Just buy the complete adventures. And ul be fine. Jedi_82
  5. LOL, So it dosent mather what dvd il gett in and btw sry i missed to said both dvd's are total experience
  6. Hey! It has been some time when i have played galaxies and i was wondering do i need to use exactly same dvd as i did my first char to play with it? Or cann i just use my newest dvd what already got 2 chars? Please answers. It may sound dumb but i reaaly dont know this thing. Jedi_82
  7. Spawnofthesith when u buyed ur galaxies and tryed to play it says u need to subscribe but dont worry just wait 6-8 days and u cann play that one month. Il writed this too late i think but if i didnt then go ahed and try.
  8. Yeah i got that same too when i first time installed EAW but i just uninstalled daemon tools and thats it no problems after that. And some my friends had have a problem with nero burning program. So eaw didnt run until they uninstalled nero and daemon tools. Hope this helps. Jedi_82
  9. I have used Norton internet security all my life and no problems with empire at war. With both computers i have. But try this, first uninstall empire at war and that norton then first install norton then empire at war. Sry cant help eny more info.
  10. Could it be possible to add diplomacy what was cut from the empire at war?
  11. Well u gyes should definetly try Awaking Of The Rebellion Mod for empire at war. Go to http://www.eawhq.de. I play it it is wery challening try it on HARD setting and u will be screwed ;D Jedi_82
  12. Well some of us cant wait for it ;D
  13. Dam wedge u totally hit the water pipe. Hope Petro will do that it sounds magnifisent. ;D Jedi_82
  14. Well try to make hotmail account and do a new profile on http://www.fileplanet.com and put ur new nick name and email there and think a password. Thats it. Hope this helps. ;D
  15. Hope u tried to change host location and chat lobby check it out it helps if u havent done it
  16. Well i have played online since the second day after release and no major online probs only lag if have 4vs4. Orao maybe u should try switch ur router newest one if it is old like i have only nearly 20 years old lol pretty much eh? but still working fine
×
×
  • Create New...