Jump to content


Help! "recursive error after MAX_CVARS" (when using OJP Basic & Siege)


Recommended Posts

So you guys have a new forum, but I thought I'd post here as well in case anyone is reading it, since this problem is really bugging me lately!



Okay I know this is one of those common problems, but I never used to have this problem...


I'm using basejka (JA with the 1.01 patch applied), and OJP Basic v012.


Whenever I try to play Siege, on say, Hoth, or Korriban, I get a crash followed by a MAX_CVARS error every so often. Sometimes it's when I'm adding some bots, other times it's when I win the match, other times it happens right when I pick a class and join in. It seems to happen randomly, and it's super annoying. It used to happen every time I tried to exec a certain cfg file I made (which just added four bots, with custom names on teams). I figured the cfg was to blame, so I removed it from my base. But the problem persisted...


Just to give some details:


I DID google it, and the suggestions I've been given included reinstalling JA in a fresh directory after uninstalling (tried that, no dice).


It was suggested that delete my extraneous cfg files in my base folder (no effect), or delete all my extra pk3 files (tried that) in my base folder.


I tried deleting jampconfig.cfg and starting over with settings. I tried removing my autoexec.cfg (with my preferred settings). I tried combination of the above. Still getting the errors.


I have tried running OJP the "correct way" via the batch file with OJP in a mod folder. I have tried just putting the two OJP pk3 files into my base and just starting up JAMP.exe, still the same problem.


I'm using "create a server" on my home PC (I have no rented server space at this time). I'm running Windows 2000 professional (with all latest updates), 256 mb ram, AMD AthlonXP 1800+ (I know, it's old, can't afford an upgrade yet), ati all in wonder 9600 (latest drivers), DX 9.0a, cable internet.


I can play FFA or PowerDuel with bots until the cows come home... no problems. I've joined servers (with a couple of people) on Duel and played for a bit, no problem. But Siege brings up the ugly MAX_CVARS glitch seemingly every time.


Any help? Is there an update for OJP?

Link to comment
Share on other sites

Hey Kurgan! You sound like you have a strange problem there. You've tried everything I can think of. Its sounds like corrupt files, but you seems to have addressed that already. This is a question for Razorace. I don't think anyone from the currant OJP has done anything to OJP basic or a year or two so I doubt they will be able to help much.


In other news, sadly for OJP Enhanced (now Jedi Knight Enhanced) the team is losing interest and will probably retire after the next release to work on another project. I've been mostly retired myself, but I'd hate to see it go. If you know any good coders who like ojp enhanced and want to take up working on it, let me know. It has a pretty decent following these days compared to previous times.


Heh, I got an award while I was away! Woo hoo! ;)

Link to comment
Share on other sites

  • 1 year later...

Sorry, Kurgan, you've suggested everything that I can think of at the moment. Did the problem ever go away? My understanding is that the engine is freaking because there are too many CVARs being used at once. Not sure why this would be a problem with a fresh install thou....

Link to comment
Share on other sites

I'm guessing this was a limitation of the Windows version, since it basically disappeared when I got a rented server (Linux).


Apparently if you run it off your home PC, you just can't use a lot of cvars (coming from many mods, and Siege mode), without it crashing all the time.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...