Jump to content


Glitch prevents me from progressing


Recommended Posts

After a long time without playing this game, I decided to get 100% on it again. However, I've found a problem: Episode I, Chapter 5. In the last part, where you need to save the pilots, there are 4 groups. Two of them have one droid and one pilot (platform on the far left corner and above the main door), one has two droids and two pilots (in the ground, near the fighters) and another one has one droid and two pilots (above the area where some droids come out, in the middle. Lifting a crate for another Jedi to help you is necessary to get there). Well, instead of having one droid and two pilots in this last area, there is only one pilot, and sometimes, nothing. This one pilot also won't go to the fighter. I've tried reinstalling the game, making another save, and even downloading a pirate version, but nothing worked. Any ideas?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...