Jump to content


XWA doesn't see my 3D hardware


Recommended Posts



XWA will only run in software rendering mode. In the preferences, under Video Options, it does not see that I have any 3D hardware. It simply reports "no 3d hardware".


My setup:

AthlonXP 2400+

Radeon 9800 Pro w/most recent Catalyst drivers.

WinXP Pro SP2 and all updates

DirectX 9c

XWA 2.0.2


I have tried all the compatibility modes (W95, W98, NT4, W2K), with no success. I've reinstalled XWA and DirectX multiple times.


It plays fine in software, but it sure is ugly.


Any help would be greatly appreciated.



Link to comment
Share on other sites

I couldn't get mine to say those exact words, so I'm not sure where it says that. The first two options are where you set it.


Video Display Driver = Primary Display Driver

3d Hardware = Yes (click this to toggle between yes and no, default is no)


Not sure that will help you, but that's how mine is set to get 3d acceleration

Link to comment
Share on other sites

  • 3 weeks later...
  • 1 year later...

There are a few files found on LucasFiles that deal with that problem. The first one, the "all resolutions" fix, seems to work well. If you're using a newer nVidia card (say, models that came out in the last year), you may also find that the targeting box in the HUD view around the craft you're targeting is not to be found. We are aware of this problem too and are researching it.

Link to comment
Share on other sites

I am having a similar issue, a few days ago I found my X-Wing Alliance Cd and decided to play it. I installed it and played it just fine for a few days then all of the sudden I got a BSOD. The BSOD referenced the video card, I restarted and tried to reload the game but then I got an error that said no 3d hardware found switching to software mode. I have un-installed/re-installed both Xwing and my video drivers and I keep getting the same error. I also reinstalled DX9.0c. I can not install Xwing without the 2.0.2 patch as it is included with my game. I have had no issues up until that BSOD. Any ideas?


AMD XP 3200

ATi 9800 Pro (latest drivers as of 4-25-07)

XP Pro Sp2




XWA w/2.0.2 English


Thank you

Link to comment
Share on other sites

  • 6 years later...

I have a very similar problem.


I can chose the 3D-Hardware, but when the mission-loading-screen appears, the game tells me, that it wasn`t successfull in detecting my 3D - hardware.


This is VERY annoying, since it worked before my system new installation.


I`v got a ATI Radeon HD 5570 card.


Please help me somebody! The hints above don`t work with my system...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...