Jump to content


XWA freezes mid-game


Recommended Posts

I recently upgraded my GPU from a 6600GT to a 7600GS after it died on me. Before I upgraded, XWA ran perfectly in full settings. But with the new card, it refused to recognize it. After running a system analysis, it found my GPU and I was away. However, halfway into the 3rd mission, the image suddenly freezes, while the game keeps playing underneath. Also, I can make inputs (like firing) and hear their sounds, just not see them. If I press escape or anything, my monitor goes into standby mode, then when it comes back on I have to restart my computer. If I press Q and Space then it just goes back to he main menu as normal. I finished this level with no hardware no-problems, but every other level since than always does the same thing between 5 and 15 mins in. It makes it almost impossible to finish any missions. I'm up to the second Rebel training mission and I can't get any further. I've tried DirectX 9 and 6, disabling hyperthreading, I'm fully patched, I've got the latest drivers and I've pretty much tried everything. I'm getting incredibly frustrated with this, as I love the game but this has been holding me back for weeks. Is there any way to fix this? Help much appreciated, thanks in advance.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...