Jump to content

Home

Monkey Island 2: LeChuck's Revenge - Ultimate Talkie Edition Projekt


LogicDeLuxe
 Share

Recommended Posts

first of all thanks for making those ultimate talkie editions, they rock!

 

unfortunately I am having severe problems running those on a real DOS pc with a LAPC-I + SB16 (made a pentium1 pc for old DOS gaming some 3 years back and it's the first time I get this behavior).

Both original DOS MIs play fine as every other DOS game I've thrown into the machine.

The talking builders complete without errors (image with both games's files + crc32) and I get games that work on DOSBOX and on my 486DX2 pc. But on the p1 I get severe SB problems and freezes.

I tried disabling both L1+L2 caches (so I get a pc that is slower than a 386DX) , tried leaving ~14MB of free ram under the first 16MB and even tried putting on the pentium the 8bit sound blaster that my 486 has.

I still can't make them work, roland music works fantastically but the sb part suffers.

 

* If I use roland+sb , music is fine but at some point during speech the game will freeze. Color cycling of the cursor will still continue , music will continue but controls/keyboard are frozen. A reset is needed.

 

* If I use sb-only then the game just make some horrible "music" coming from the FM chip and strangely enough speech is OK. A reset won't help here , the game/pc works but until you do a power-cycle you can't get rid of the sb's sounds.

 

I made a video of this behavior (showing MI1 , MI2 has the same behavior):

 

(This BBCode requires its accompanying plugin to work properly.)

 

Is there a chance of squashing this bug? I must stress that the pc has no irq/dma/hardware problems, I have ~100 games installed (my whole originals collection -> gallery link) and never had this problem, only speed related ones on older titles that get solved with slowdown utilities.

I'll be more than happy to provide more info/testing if the creators decide it's worth checking, thanks in advance!

 

edit: made further tests, if I disable only L1 cache then the sb driver works. Still I get the freezing. I also put the sound buffers to 64 , I could delay the freezing but eventually I got it again.

 

edit2: made more tests, run the game with KGB in the background keeping a log on activity, nothing important and the game just access monkey.001 as usual when the freeze happens

I also substituted the games directory to S: so I run the game from "fake" S: in case there was a problem and the game did not like the c:\games\mi1se path... made no difference too...

Last thing I did was run the game with GM music, still no difference

Edited by keropi
Link to comment
Share on other sites

  • Replies 115
  • Created
  • Last Reply

Top Posters In This Topic

Well, after testing with 3 different mobos that use the VIA MVP3 chipset I have concluded that the freezing occurs when one uses a PS2 mouse on the onboard ps2 connector!

With a serial mouse the game never freezes, no matter how hard I try or for how long I play.

With a ps2 mouse it's just a matter of spending some time clicking like hell on the sleeping pirates (thus you hear a piece of dialog that restarts on the next click without delay).

 

I have no idea if there is a workaround for that PS2 mouse problem, I can only assume that the game doesn't like the ps2 port's address/irq on MVP3 chipsets or it's general implementation...?

Link to comment
Share on other sites

If you suspect an issue with the Ultimate Talkie Editions, you should check if Indy 4 talkie (or its self running demo) has the same issue. Then, it is most likely a problem with the executable and the sound drivers coming with it.

 

The Adlib music issue is usually a too fast PC. This also can lead to hanging notes on midi devices. So disabling CPU cache is always a good idea for old LucasArts adventures.

 

I have a similar DOS PC (Pentium 200mmx with a VIA chipset and Award BIOS) and encountered those issues occasionally, but never found a fix that worked every time, unfortunately. I don't have a PS/2 mouse but a serial mouse connected to it (like you usually do on AT boards), so it can't be just that. I found, when I run the game from within Windows 95, then it runs fine most of the time. Sometimes, I get crackling speech, but no game hanging like in pure DOS.

 

Maybe the game doesn't like some drivers (probably mouse and/or sound). It should be possible to play through it, as I tested it successfully on that PC along with others.

Link to comment
Share on other sites

thanks for the tips, I will check indy4 and report...

I did try to run the game from 98SE (forgot to mention that) and I got the exact same freezing but this time due to windows I could alt+tab my way out of it....

 

In regards of drivers the SB16 does not use any... just an init program on startup (not a pnp card btw) or nothing at all... and I also tried with the 8bit SoundBlaster, it only needs the BLASTER variable.

And for mouse I used either ctmouse or MS's mouse.com... I even tried without a mouse driver installed, in my case if you have a mouse plugged in the mouse port then it somehow causes this... maybe it's the mouseport's IRQ12? or it's mem address?

Link to comment
Share on other sites

well, unfortunately indy4 behaves the same... freezes/locks ( kinda differently though, if you wait a little it can unfreeze but fail after a while again, this time permanently)... even with the update patches and icache to disable L1 , it does not work well... maybe it's a chipset thing after all , never really played the "talkie editions" ... :(

I will try the chipset theory tomorrow with a slot1 intel-based machine and a 233mhz PII

 

edit: did a test without a mouse connected, I could not make monkey2 freeze but indy4 just rebooted my pc during the intro dialogues...

I never knew lucas stuff to be so picky on hardware!

Edited by keropi
Link to comment
Share on other sites

I also use ctmouse, no problem with that, it seems.

I just figured out, the problems appear for me when I use SB IRQ 7, but they disappear completely if I change it to IRQ 5. For me too, none of the other games on that PC have this issue.

Link to comment
Share on other sites

^ that's very strange because the SB16 that I use (CT-2230) uses IRQ5 by default (like all sb16s, DMA=1 , HDMA=5 , IRQ=5 , PORT=220 and MPU=300 so roland has 330)

Also in BIOS/PNP page I have assigned all relevant irqs/dmas to ISA-Legacy ...

 

Didn't get the chance to test on the PII system today....

Link to comment
Share on other sites

slot1 test was a failure... I found no way to disable L1 or L2 caches on my 440BX mobo and ofcourse with a 400mhz PII the sb sound was terrible... didn't bother to test more since I could not really trust the result with such a speedy machine

Link to comment
Share on other sites

  • 4 months later...

1. I tried the ultimate talkie version of MI1 in scummvm with the ogg and flac installer, and got a slight crackling throughout the audio. Has anyone else experienced this? I cant tell if its a part of the music.. Its especially noticable talking to the blind guy at the begining of MI1, during the music.

2. Also with MI1 what do I need to do to get rid of the ripping reminder? I made a 0bit file called track1 and I tried naming it also track1.midi, and put it in all

MI1_Ultimate_Talkie_Edition\cd_music_ogg

MI1_Ultimate_Talkie_Edition\se_music_ogg

MI1_Ultimate_Talkie_Edition

folders but none of those worked

3. I also cant seem to find the fan_patched file for MI2 anywhere. Where do I get it and how do I use it?

Thanks!

Edited by p1r473
Link to comment
Share on other sites

  • 2 months later...
Ah, righto - my mistake. Should have realised there'd be a limit on effects of that sort.

 

Anyway, have just finished Part II and have a mammoth list of bugs and dialogue changes ready for you. That's probably the largest part of the game out of the way now. I might see if I can do Parts III and IV all at once when I next get the chance to play, since they're both pretty small and self-contained.

 

Dialogue Changes:

Talking to DeWaat on Booty:

What? They doin' a treasure hunt again this year? = What? They're doin' a treasure hunt again this year?

 

Looking at the Spit Plaque:

It's a plaque with an old-looking gob of something on it. = It's a plaque with an odd-looking gob of something on it.

 

Talking to Elaine:

You know, I do have work to do. = You know, I have work to do.

Go tell it to your mamma. = Go tell it to your mother.

 

Talking to the Fisherman on Phatt:

I think you're just trying to get your hands on my pole. = I think you're just trying to get your hands on my fishing pole.

I'll give you my prize-winning pole. = I'll give you my prize-winning fishing pole.

Think I'll just drop a line right here. = Think I'll drop a line right here.

 

Looking at the mirror at Rum Rogers':

That's a nice looking beard. = That is a nice looking beard. (Unless the SE subtitle for this replacement line really says "That's" rather than "That is", in which case just leave it as is - I haven't had a chance to check this, so thought I'd mention it regardless).

 

Delivery Men in Scabb Island Swamp:

Hey, Rich. I could use a hand with this one. = Hey, Rich. I sure could use a hand with this one.

 

In LeChuck's Fortress (cutscene):

You will regret a lot more if he finds another. = You will regret it a lot more if he finds another.

 

On Captain Kate's Ship:

This ship is so small, the rats leaving it are humpbacked. = This ship is so small, the rats are leaving it humpbacked.

 

Typos:

-Talking to DeWaat on Booty, the line Well, if it's a party your looking for... has a typo; your should be you're in this context.

-At Stan's, I'm pretty sure the line Making plot reservations now insures you a space at our popular Scabb Island Internment Park™... has a typo - the context of the line suggests that insures is actually intended to be ensures, as in "guarantees". Not sure about this one, though.

-During the bone dance, rib bone is consistently mis-spelt as rip bone in all of the lines sung by the skeletons. This doesn't affect any of Guybrush's lines or the lyrics written on the paper as far as I could see.

 

Bugs:

Booty Island:

-In the Antique Shop, if you talk to the parrot while the antique dealer is talking, after finishing its line the parrot doesn't stop its' talking animation. Instead, the animation will continue until the dealer finishes his remaining lines of dialogue.

-At Stan's, Guybrush still points the wrong way if facing the coffin and selecting the dialogue option How much is that coffin?. Adding the same check to see which way he's facing that you added to the Could you show me that coffin again? dialogue option should fix this.

-Sometimes, when Stan is in the coffin, if you open the coffin just as Stan's line is ending, even though the coffin is open his next line will be said in the "coffin closed" muffled voice and his talking animation will not play. Sometimes this also affects it the other way - if you close the coffin sometimes he will speak his next line in the "out of the coffin" voice. This seems harder to do than the other way around, though.

-At the Spitting Contest, there's an art goof - the banner on the far right reads "Pirate's Spit Contest!" rather than "Pirates' Spit Contest" as it should. Originally all the banners were incorrect, but this was fixed sometime between the demo and the full game; however, this banner was apparently missed when they fixed the other two.

-At Governor Marley's Party, when the skeleton guest says It's alright., the audio says Yep. instead. This seems like it's probably using the wrong audio file, rather than being a dialogue change, as the same Yep. is also correctly used elsewhere.

-Also at the party, the Pig-mask guest on the far right seems to have the audio files for his (cheap sexual innuendo) and (mindless retort) lines the wrong way around - currently his (cheap sexual innuendo) is a reply to the clown's (cheap sexual innuendo), while his (mindless retort) is him telling his own tale of innuendo.

 

Phatt Island:

-In the Jail, When offering the bone to Walt, Guybrush's whistle sounds occur at the same time as his dialogue lines Here, doggie doggie. and Here boy! It would be impossible for him to whistle to the dog and speak at the same time. Is it possible to make each whistle happen just before each of his lines instead?

-Also in the Jail, When talking to Captain Kate, Guybrush's line, I can explain, I--, gets cut off earlier than it should.

-At the top of the waterfall, when I used the monkey on the pump, the waterfall sound cut out after Guybrush had taken the monkey out of his pocket but before he'd actually used it to turn off the pump. Not sure what caused this.

 

Scabb Island:

-At the Voodoo Shack, the bug I mentioned before where the Voodoo Lady has two heads when taking Rapp Scallion's ashes from you still occurs. It looks like her head from her sitting/talking animation stays in place while her body plays the animation for taking the ashes, resulting in her briefly having two heads.

-On the close-up of Rapp Scallion's coffin, this bug occurred. Rapp Scallion's map piece was the third I got. Guybrush's line, That makes three map pieces - only one to go! occurred at the same time as Rapp's disappearing animation. Although the audio for the line played, no text was displayed despite being in Speech and Subtitles mode. Is this Rapp's animation interfering with the line? If so, is it possible to delay the appropriate

That's the (X)th map piece line until after Rapp is done disappearing?

 

 

One last question - I didn't include this in the bugs list as it would involve heavy modification of a background, and I wasn't sure if it was appropriate for this project, but: are there any plans to fix the lack of any floor outside the Woodcutter's door in Woodtick, or will this be left as-is to preserve the original background art as-is?

 

Anyway, hope that's not too mammoth of a list for you! = ) I've tried to be incredibly thorough on this playthrough to maxmise the amount of bugs I'm catching, so I'm afraid it's quite a large info-dump at once. Will let you know as soon as I have anything more, k? Until then, keep up the good work! = D

 

SORRY,IF THIS IS OLD NEWS,BUT I THINK THE LINE:

They doin' a treasure hunt again this year?

should be left the way it is.

I'm from london uk and the way it's said ,sounds correct.

Imagine saying it as a cockney londoner or a cornish pirate.

That is how they would say it.

I don't think this is a mistake or mispronunciation.

Link to comment
Share on other sites

  • 10 months later...
  • 1 year later...
 Share


×
×
  • Create New...