Jump to content

Home

3d Accel Problems on new video cards


Xzero
 Share

Recommended Posts

Anyone having issues with JK on their new video cards? I bought an ATI Radeon HD 3870 a little while back and I can't play JK with 3d accel on :S

 

I'm more then certain it's a driver issue, but I'm posting in hopes someone might have a fix for it.

Link to comment
Share on other sites

  • 3 weeks later...

Got a 780G motherboard with HD3200 graphics.

 

WinXP SP3 & Catalyst 8.6.

 

SW mode works but with unreliable menu switching. Stable in-game tho.

 

3D accel mode crashes the game when starting levels.

 

Tested all compatibility modes & display settings.

 

Pretty sure this is hardware, driver, DX9 & OS mismatch.

 

The game is just too old.

Edited by Naught Snoot
Link to comment
Share on other sites

For some reson i have no problem running jedi knight.I don't know why the heck it won't work for you guys.ODD...

I have a okay graphics card and have Windows XP.

But also sadly i have a new computer and i lost jk so i'm buying a new one.But the parts and programs were on the original computer has jk.

Link to comment
Share on other sites

Ok, so I know it's been a while since I was here, but I've changed to a NVidia 8800GT, and no problems so far.

 

Seems like Radeon doesn't support older games anymore, and if they'll fix this problem, remains a mystery.

 

I already know how to fix menu issues (a simple alt-tab works.) That or run it in a window :)

 

So, warning to everyone! Don't get a 3*** series if you plan on playing old games too!

Link to comment
Share on other sites

Xzero

 

I hear ya! This is specific to new Radeon hardware and the current driver sets.

 

Works perfectly fine with older Radeons and driver sets.

 

Noticed there are many more older games that lack proper support with new Radeons. It's actually becoming a problem when no emulators exist.

 

I managed to dig into the matter with ATI aswell, but it seems they are not giving DX5/DX6 compatibility much priority with new hardware. They'd rather use resources for what is new & shiny.

 

Understandable, but kind of a shame IMO because we see more and more 3D titles becoming "retro nostalgia". People will still want to play them for that very reason.

 

Maybe someone will pick up on this and write some new DX5/6/7 emulators for retro gaming?

Link to comment
Share on other sites

  • 1 month later...

Hey,

 

I have a quite new laptop with an Nvidia chipset and the latest drivers.

The game runs fine in 2D mode, but if I try to enable 3D acceleration and return to the game, I see the HUD and the weapon but no environment or anything else. If I fire the weapon, no bolt comes out, and the frames of the recoil get captured, so after a few moves it looks like I have several hundred bowcasters....

 

This is really annoying me, particularly because I cannot play Jedi Knight Enhanced.

 

Any help would be appreciated,

 

Alex

Link to comment
Share on other sites

  • 4 months later...

I'm having the same exact issues with my Radeon 3650 HD as everyone else with Jedi Knight. It also is happening and doing the same exact thing with X-Wing Alliance too! A lot of black blotchy square tiling saturated mess like digital cable tv on a bad day. I really hope ATI addresses and corrects this issue.

Edited by StarWarsGooN
Link to comment
Share on other sites

 Share

×
×
  • Create New...