Jump to content

Home

Game problems (crashing, lock-ups)


CondorFalco
 Share

Recommended Posts

Hi, I've got the retail version of SWBF2, and I've had major problems running it:

 

1. On every 2nd or 3rd map I play, the game just locks-up, and the sound sometimes keeps playing, and other times the sound stops as well, and the computer reboots. Other times, I can go for 4 or 5 maps without it locking up and crashing.

 

2. To try and solve this problem, I reinstalled STBF2, and downloaded and installed the latest drivers for my nForce 4, and I will be downloading the drivers for my motherboard once I am comfortable that I have the right drivers (never fiddled with the motherboard before). However, even once I did this, the game kept crashing. I even tried running the game in Windows 2000 compatibility mode as someone suggested, and that has not worked.

 

3. My system specs are:

 

AMD Athlon 64 X2 Dual Core Processor 4800+ (2.4GHz)

2x NVIDIA GeForce 7800 GTX (SLI enabled) driver v81.85

2GB RAM

Audigy 4 Pro

DirectX 9.0c

Windows XP Professional

Motherboard: A8N-SLI DELUXE + nForce4

 

4. I have been running the game with full graphical detail, and EAX

 

5. Any advice?

 

 

 

I really hope someone can help,

 

Condor out.

Link to comment
Share on other sites

Ok, thanks. I looked on the AMD website, and couldn't find anything obvious, i'll have another look. I'll also post this message on the other forums.

 

Thanks again,

 

Condor out.

 

 

PS. Funny how someone with a pretty good rig can't run the latest games isn't it? :)

Link to comment
Share on other sites

PS. Funny how someone with a pretty good rig can't run the latest games isn't it? :)

Yeah, it always takes some time before everything supports it (or doesn't support it anymore :p) Its actually strange it doesn't works, because the AMD 64 X2 series have been released back in Februari, so I thought SWBFII could handle it.

Link to comment
Share on other sites

Yeh, I read something on the AMD site suggesting to only run the game through one core, that didn't work. Thing is, I don't really want to run the game on lower graphics, since I kinda buy FPSs for their graphics mostly, and even though SWBF2 doesn't exactly have Battlefield 2 graphics, they're not that bad, but if I lower the detail any more, they'll probably look like boxes :). I might try and download the motherboard drivers tomorrow.

 

Again, thanks for the help,

 

Condor out.

Link to comment
Share on other sites

Yes I too am finding this a problem...I have all the latest drivers for video and audio cards including motherboard and BIOS, direct x9c etc etc and I can play the game however after a few maps of single player campaign it suddenly locks up with the screen freezing and the sound stuttering....Please help!!! I then cannot Ctrl, Alt, delete or Alt F4 out I have to physically hard re-boot the machine

 

I have tried max and min settings and Hardware and software sound in every combination....It's driving me bonkers...

Link to comment
Share on other sites

I have an AMD XP 2400+ dual processor setup (dual processor, not dual core) and I don't have this problem. It may be becasue you have 64 bit processor instead of 32 bit. I'm sorry to say having the latest and 'greatest' hardware isn't always best. Are you using a 64bit version of Windows?

Link to comment
Share on other sites

Well according to the web:

When playing Star Wars Battlefront II on a graphics card with a NVIDIA GeForce 6 or 7 family chipset, the game may suddenly freeze or your computer may reboot when using the NVIDIA ForceWare 78.01 (6.14.0010.7801) or earlier driver. Lowering your graphics settings in the Video Options menu may correct this issue. We recommend that you check for updated drivers, which may correct this issue.

 

I found that the latest drivers weren't 78.01 but infact 81.85 so try that first

 

Also for sound sticking try this (if that udate didn't work):

Several of the following card specific issues refer to stuttering, skipping, or hitching sound in the game. This issue is improved on most hardware by adding a command line switch to a shortcut for the BattlefrontII.exe. Adding this switch helps correct stuttering, skipping, or hitching in the games soundtrack. To do this:

 

• Navigate to the GameData folder where you installed the game

• Right-click on BattlefrontII.exe and select Create a Shortcut from the menu.

• Right-click on the shortcut you just created and select Properties from the menu.

• Set your cursor after the parenthesis at the end of the path in the Target dialogue box.

• Hit the space bar once and then type /audiomixbuffer 50.

• Click the Ok button.

• Launch Star Wars Battlefront II from the shortcut you just made.

Link to comment
Share on other sites

I'm having the same issue on my Dell Inspiron 9300 notebook. Brief specs:

-Pentium M 1.73Ghz

-1GB RAM

-256MB NVIDIA GeForce GO 6800 Forceware v78.11

-Audigy 2 ZS Notebook PCMCIA Card

 

 

I've tried the "/audiomixbuffer 50" switch with no luck. The game just hangs and I have to manually reset the notebook. This happened with the BETA version as well. I've closed all background apps and tried various in-game settings but it always hangs. Any ideas?

-SC

Link to comment
Share on other sites

Same problems here. x2 3800 [@ 2.63], BFG 7800GTX OC, 2gb of OCZ Platinum EL @ 3-4-4-8, 1T. My computer is 100% stable, so its not my settings. I can play BF2 and all the other intensive games without a hiccup. SFBF2 locks up during first map, not even 2nd for me :(. Its the game as I can go back to windows and end the task. As for the AMD solution - I have installed the AMD dual core driver and have the latest drivers for everything [vid/chipset etc..].. I think this is a software issue..

Link to comment
Share on other sites

OK everyone, I seem to have found the cause of my issue. I changed the bit depth in Windows to 16 bit rather than 32 bit and that solved my problem. For noobs here is how:

-Click Start>Control Panel>Display.

-Click the "Settings" tab.

-Change the "Color Quality" from 32 bit to 16 bit.

-Click "OK" and try BF2.

 

Post back with results. Perhaps it only fixed the issue for me.

 

UPDATE: It turns out that this did -NOT- completely resolve my issue. I have been able to play several times without crashing but just now ater plaing about three times longer than normal is hung.

-SC

Link to comment
Share on other sites

Some interesting information for anyone having the same rig as mine, and SWBF2 crashing:

 

"Playing the game on a dual core processor (AMD X2) will make it crash and the NVIDIA GeForce 7800 GTX (SLI enabled) is not compatible with SWBFII.

These problems are noticed and will be solved with the first coming patch. Unfortunately there is no further info about when this will be released."

 

This I got from another forum from someone called Katootje.

Link to comment
Share on other sites

I hadde the same issue, Nvidia 4200 TI, 81 Version an old card but supports T/L so never had an issue with another game, even JO-E. I had the lock ups in in this one during 2nd map also.

 

I went into adv. settings and deselected App Control. Turned all off, 60hz, Image to High Performance and Mip to BiLin and Text clamp to On. Trip Buff off and Clamp Neg LOD.

 

Played 2 full maps but were short battles with no lock ups. Not sure which change did it. If I lock up again Ill post back.

Link to comment
Share on other sites

I rolled back my Geforce 6600GT driver to the origoinal 68.01 that came on the original CD and it works a treat now....Try rolling back your drivers to as far back as the originals and then try it. If it works you can gradually update until you know which set work best for that game! - Good luck!

Link to comment
Share on other sites

I have a 6800 and the crashing really started to tick me off. After getting the latest driver it still crashed. I finally found that limiting your card acceleration by 2 or 3 notches solves the problem (right click desktop, go to the last tab, click advanced and eventually you'll find the hardware acceleration) and lowering ingame graphics.

Link to comment
Share on other sites

 Share

×
×
  • Create New...