Jump to content


SP Dismemberment and Battle Scars


Recommended Posts

I believe I read somewhere that to enable full dismemberment in SP I had to write g_sabermorerealistic 1 or something like that but when I did it says it is write protected, how can I edit this for full dismemberment?


One of the very first mods I had or JO was an SP dismemberment mod but I don't know if it would work here. Anyone know how to edit dismemberment? And if I do it would I have to star SP over as JO usually did whenever you changed something/


Also, has anyone had the battle scars from saber attacks appear very less frequent and disappear much faster than the demo? Battle scars barely appear in my SP game, I don't know if it was something I changed in the graphics section or what (I put everything in highest settings) but in the very small instances the scars appear they vanish really quickly. Unlike the demo where they were extremely visible and lasted a good amount of time. Anyone have any ideas how to prolong the scars?


Thanks for any help.

Link to comment
Share on other sites

You mean activate cheats before putting in the dismemberment command?


I can activate cheats by writing "devmap" or "devmapall"


But so far I've found 3 different commands that supposedly activate SP dismemberment.


"g_saberrealisticcombat" - JO old command which did nothing for me


"g_sabermorerealistic" - Which says default 0 and is copy protected so I can't change.


"g_dismemberment" - Which I haven't tried.


I'll give another try after activating cheats and if none work I'll put the Enyak Mutilate mod and see if it has any effect in JA.

Link to comment
Share on other sites

The saberrealisticcombat line does nothing believe me I've tried it numerous times.


What does work is the g_sabermorerealistic 1-3 but it is copy protected, so you can write it into the JAconfig file with 2 other lines mentioned in another thread and load a map from the console and it will work. But if you shut off the game and turn it back on it is overwritten even if you had it in the JAconfig file and can't change it back through the console.


Thanks for the scar line Kurgan, I'll test it tomorrow after class.

Link to comment
Share on other sites

i got the dismember thing to work i just got game and all i did is put these three comands into the ja.cfg file in ur base folder


seta g_dismember 100

seta g_dismemberprobabilities 1 or set to ur liking

seta g_sabermorerealistic 3 or to liking again


all those have to go into ur cfg file if u want to open it just open it in ur notepad it lets u see all the rite fonts in stead of the blocks

Link to comment
Share on other sites

Yes I did that too but after I turned off the game and turned it back on it didn't work anymore. Like the game had reverted back to what it had before I had put those lines in the JAconfig.cfg.


If there's a way to have the game keep those settings without going back then I have a solution to my problems :)

Link to comment
Share on other sites

Yes I have dismemberment on in the options and yep it's also the retail version.


I just checked my JAconfig file and it had reverted my changes, they appear now as:


seta g_dismember 1

seta g_dismemberprobabilities 1 (that's the same as I set it)

seta g_sabermorerealistic 0


I don't know why it changed the file back to this. What is the file name I have to save from the console? Maybe that's what's missing and that's why it eliminates my changes.

Link to comment
Share on other sites

Okay so I tested it a bit and here are my results.


I reopened the cfg and set everything back to dismemberment options:

seta g_dismember 100

seta g_dismemberprobabilities 1

seta g_sabermorerealistic 2


then I turned on the game, loaded the last level I was on, put in devmapall and saved it through the console as dismembermod.


I noticed that while the settings for the game were as I put them; g_sabermorerealistic was set to 2 it still indicated that default is 0 while before I loaded the game both were set to 2.


I exited the game and turned it back on 3 times. The first time I restarted the game everything was fine. When I checked the file it still had the settings I had put.


But the second and third test failed. I reloaded twice the save game made when I renamed it and though it still had the g_dismember 100 the G-sabermorerealistic was again 0. Every time I changed it back to 2 it appeared as before: the setting is running 2 but default is 0 and as soon as I exited and restarted the game setting would completely revert back to 0. So unless I change g_sabermorerealistic to 2 every time before I restart the game it doesn't seem to work.


Thanks for the help.

Link to comment
Share on other sites

Hey guys, check this out, here's an alternate method to getting dismemberment (SP) to work in the full version.


Okay, first find the jasp.exe and create a shortcut to it on your desktop.


Now right click on the shortcut and click on properties. Now in the box it should look something like this:


Target: C:\games\JediAcademy\GameData\jasp.exe


(it'll be different, but you see that it points to the directory where your game is installed)


Now edit the line and make it look like this:


C:\games\JediAcademy\GameData\jasp.exe +set g_sabermorerealistic 2 +devmapall +load quick +set g_sabermorerealistic 2


Then hit apply/okay and you're set.


Now here is what it does:


The "devmapall" part turns on cheats (and clears the cache to save memory).


g_sabermorerealistic is write protected, but if you run it from the command line the game will just set it to that value at the beginning.


The "load quick" part will load whatever game you have saved in your QuickSave slot. In fact, it will launch the game directly from the shortcut (you won't have to watch the intro screens or wait for the menu to pop up). So just use your QuickSave (mine is F7, but whatever your's is) and take a spot where you want to begin with dismemberment on.


Now as to the value you put for sabermorerealistic:


g_sabermorerealistic 1 seems to (I'm guessing) just be increased damage (but dismemberment is very very rare).


g_sabermorerealistic 2 is full dismemberment (with almost every hit). But idle saber does no damage to NPC's.


g_sabermorerealistic 3 is the "idle saber cuts you up into teeny tiny bits" mode which is more like the classic "saberrealisticcombat" from JK2.

Link to comment
Share on other sites

hey Kurgan, thanks but i had to change it for me.


In target (on win XP at least) you need quotes in the actual location to load the jasp.exe


so for me it needed to look like.



"C:\Program Files\LucasArts\Star Wars Jedi Knight Jedi Academy\GameData\jasp.exe" +set g_sabermorerealistic 2 +devmapall +load quick +set g_sabermorerealistic 2



otherwise without the quotes it wouldnt even let me save it again.

Link to comment
Share on other sites

Originally posted by IronFryman

It should work, just type in helpusobi 1, then g_Saberealisticcombat 2. I have it binded so that everytime i start up, i can have it. Its just strong enough to dismember people, but not to easy that i just cant walk into people. But it doesnt work on the beta, or so i hear.

That works perfectly, they don't fall apart when you touch em but you can still dismember pretty easily - nearest to perfection imo :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...