Jump to content


TSL: ATI driver issues and Dantooine Lag Fix


Recommended Posts

If you are having problems running TSL, and you are using an ATI Radeon video card, chances are your problem can be documented like this:


You go through the character creation proccess and watch the intro movies. Then, the screen goes black with music playing in the backround.




Your problem is that TSL doesn't like whatever version of the ATI Catalyst drivers that you happen to be using. To fix the problem, follow these simple steps below:


1.) Download and Install the latest Catalyst Drivers

The link: http://ati.amd.com/support/driver.html

  • First, select your operating system.
  • Next, select the "Graphic Driver" option.
  • Next, select the "RADEON Family" option.
  • Finally, select your video card from the list.
  • The next webpage will offer you two download options: the internatonal and the english versions. Choose the one that will do you best.
  • Its an executable file, so you shouldn't have much trouble installing it.

NOTE: The latest Catalyst Drivers are version 7.1



2.) Edit the "swkotor2.ini" file- Fixes the Dantooine Lag Issue

This edit is no longer required for most ATI users since the Catalyst 5.4 drivers have fixed the Dantooine Lag issue. However, I still recommend this step since the 5.4 drivers still don't give you the best performance on Dantooine.


Also, if you are still having problems with Dantooine, then this step is not optional. You will need to take this step to fix the problem.


  • First, figure out where the .ini is installed. Default is "C:\Program Files\Lucasarts\swkotor2\swkotor2.ini". If its not in that location, then your going to have to do some searching around on the hard drive a bit.
  • When you find it, just double-click on the file to open it in Notepad.
  • Scroll down the file until you find the Graphics Options
  • Under the last line, add "Disable Vertex Buffer Objects=1", without the quotes.
  • Goto File, then Save.


SINCE THE 4.11 CATALYST DRIVERS ARE NO LONGER AVAILABLE FOR DOWNLOAD, THIS STEP HAS BEEN REMOVED. However, if you do manage to find a link to the 4.11 drivers, then please post that information below. ;)


NOTE: All ATI users should check out the handy tweak guide below. thanks to Acleacious for finding it. :)


the link: http://www.tweakguides.com/ATICAT_1.html


anyways, feel free to post questions or comments below. :)

Link to comment
Share on other sites

  • Replies 94
  • Created
  • Last Reply



I heard a lot of people are having issues with the latest Catalyst drivers: 5.1 and 5.2. I am currently running the game with 4.11 and have not encountered any issues so far (from what I have read, this seems to be the driver that works the best for Kotor 2 too )


I have the following machine:

Athlon64 3400+

1024MB RAM

ATI Radeon 9800 Pro

Link to comment
Share on other sites

well, sorry about not replying sooner, but thats because i've gotten tsl to work on my machine. you do the math. ;)


anyways, i've been running tsl without any problems with the new 5.2 catalyst drivers as long as i don't turn on the AA or AF. otherwise, the game freezes after loading 5-6 modules.


during my, ehh, 9 hr binge (made me miss my 8:30 class :rolleyes: ) last nite, i had a silkly smooth framerate with some descent visual quality, although some areas were begging for some good AA. i'm just hoping the AA and AF issues will be addressed in the first patch, well, assuming there will be a patch, anyway.


oh well, if anybody has problems using the 5.2 catalyst drivers with tsl, then post here. i'd be more than welcome to offer a couple of suggestions. :)


note: i had no problems with the frame buffer effects whatsoever. :D

Link to comment
Share on other sites

my specs:

Motherboard:Asus P4P800 Deluxe

CPU:P4 2.533

HSF:Zalman 7000a alcu

Memory:samsung(2x512DDR333)dual mode

Monitor:ViewSonic P95f+B

Video:ATI Radeon AIW 9700 pro

PCI Cards:Sound Blaster Audigy X-Gamer

Storage:WD WD80GB

Optical Drives:Lite-on CDRW +Lite-on DVD

O/S:Win XPpro SP1


I'm useing cats 5.1 with Frame buffer, smooth shadows, grass, AA @ 2 and AF @ 4 and the game has been smooth (I mean really smooth. there are still some frame loss when there are alot of particle effects, but I'm getting better proformance than I ever did in KotOR) right until I reached




Everthing was fine then all of a sudden it slowed to a halt. I figured that it must have something to do with Framebuffer effects so I turned it off went back to the game and no change so I turned it back on and everything was back to being smooth again :confused: I have encountered it a couple more times and turning off and on frame buffer stops the frame loss.


I also encountered a total game freeze then crash once. There wasn't any warning signs it just froze and 30 seconds later it crashed.

Link to comment
Share on other sites


hmm?? i don't understand why can't you update your drivers for the mobility chip. it uses the same graphics processor, except that its been "under"clocked to save battery power (hence the "go" part, but granted, its still the best mobile GPU).


as far as my understanding goes, you should be able to use the same drivers as a standard radeon card (thus, you should be able to use the 5.2 catalyst drivers). now, if your refering to the catalyst control center, then yes, i can understand where you're coming from. but, thats an optional part, especially since you need the .NET framework installed.

Link to comment
Share on other sites

hmm, perhaps i'll just stick to my desktop.... :rolleyes:


actually, i did a little bit of research, and it turns out that ATI doesn't offer the latest drivers for their mobility chips. intstead, they want you to get the latest drivers from whoever manufactured your laptop because of the built-in screen.


i'll refer you to this page:



i hope that helps. :)

Link to comment
Share on other sites

Just thought I would post my solution, till I get a chance to try Darth333's suggestion, im starting a new game and can not check it now.

Go in the options menu select Graphics, then Advanced change the detail from high to medium, then back to high and click ok.

Return to the game and you should be fine.

There are 3 or so maps this needs to be done, I wont list then since its obvious when this happens :)


Edit: PS, im using Omega based on 5.1.

Link to comment
Share on other sites

Not only can you use Omega drivers on laptops, you can use Mobility Modder to fix the normal Catalyst driver so you can install it. You can find it at http://www.driverheaven.net/patje/



Be warned that KOTOR 2 is not designed for laptops or older desktop video cards, and you might not have much luck getting it to run.


KOTOR 2 requires hardware OpenGL 1.3 support on nVidia cards and 1.4 on ATI cards. This is not the version number of your driver, but the functions designed into the chip.

Link to comment
Share on other sites

breadmaster, if you mean there is a slowdown on Dantooine, you must edit swkotor2.ini and add the line Disable Vertex Buffer Objects=1 under the [Graphics Options] section. That should restore your speed on Dantooine.


If you mean later in the game..I've heard there is a problem but I haven't read about it until I finish the game.

Link to comment
Share on other sites

  • 2 weeks later...

"Disable Vertex Buffer" setting did not work for me.


I was able to dig up a permanet solution for most ATI cards, thou.


Download the version 4.11 Cats, you can get them here.



Then extract them but dont let it install, go to the drivers folder and look for the atioglxx.dl_ file.

Then open a dos window and extract that file with this command.

expand atioglxx.dl_ atioglxx.dll

Then place the atioglxx.dll in your KotOR 2 main directory (this works with KotOR as well).

This way you retain your most up to date drivers for all your other games but use the best functioning ATI driver for KotOR 2.

Not my orginal solution, passing it along I tested it and works smooth as silk.

I was droping to single digits frame rate, now when you get off the ship at Dantooine im at 60 fps, SWEET!


Good Luck.

Link to comment
Share on other sites



I'm gonna try that out.


I'm assuming that the process of extraction the atioglxx.dll file using dos is the same as using winzip.


So what I'll do is I'm gonna try using 5.2atioglxx.dll in the C:\windows\system32\ folder and 4.11 (or 4.3) atioglxx.dll in the Kotor2 folder.


Acleacius, what catalyst are you using (one for the driver and the one for atioglxx.dll). Also what is your ATi graphic card?

Link to comment
Share on other sites

Originally posted by Acleacius ... place the atioglxx.dll in your KotOR 2 main directory (this works with KotOR as well)....

Thank you so much... that worked like a charm.


Dantooine runs smooth, with framebuffer effects working fine:




EDIT: BTW - the ending has to suck very very much to not have made KOTOR2 worth the money.

Its been ages since a game kept me enthralled in its story like this - for the good of my education, I hope their next game is far in the future.

Link to comment
Share on other sites

"Acleacius, what catalyst are you using (one for the driver and the one for atioglxx.dll). Also what is your ATi graphic card?"


I am using the 4.11 Cats, I dont think Omega has a 4.11, (I did see a DNA 4.11), for KotOR TSL.


I am using the the Omega 5.1 (no 5.2 yet) and my card is 9800 Pro for all other games.


The author of the Omegas has fine tuned the OpenGL drivers to a degree ATI have not been able to (to the best of my understanding) so all OpenGL games are seeing vast improvements in performance, nowdays.

The one exception seems to be KotOR series (maybe other older games too) which probably is using an older instruction set (I think) and since the engine is on its last days, I can only guess Lucas Arts decided it is not worth the effort or the engine just cant be fixed within reason.



"Thank you so much"


Hey no prob, I am just glad it worked.

Nothing takes the fun out of a great game quicker than crashes/bugs, Ekkk! :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...