Jump to content


Crash Fix For Catalyst 10.5+


Recommended Posts

Those of you with ATI graphics cards may have noticed that the latest drivers versions (Catalyst 10.5+) will crash Jedi Academy as well as other old games which rely on old OpenGL (this is the graphics library used for 3D rendering) functionality. Newer games which rely on OpenGL shoudn't be affected as they will use the newer functionality. After searching through the ATI forums, I came across a fix which works (this particular topic). So here it is:


  1. Go to the driver download selection page at the ATI website: http://support.amd.com/us/gpudownload/Pages/index.aspx
  2. Select the options which suit your graphics card, and then click Display Results.
  3. Under the heading which starts ATI Catalyst™ 10.6 Suite for..., click the Previous Drivers link.
  4. Click Catalyst 10.4.
  5. Download the Display Driver (downloading the Full Software Suite also works, but the Display Driver download is slightly smaller :))
  6. Run the installer, and make a note of where the ATI install files will be extracted to. By default it will be C:\ATI.
  7. Wait for the files to extract, and on the next window (should be the Catalyst Install Manager), click Cancel to cancel the installation.
  8. Go to the directory you wrote down earlier, where the install files were extracted, and navigate into the Support directory, and then the directory which begins 10-4_.
  9. Navigate into the Packages/Drivers directory.
  10. Keep entering the first (and only) directory visible until there are no more directories to enter. For me, this was C:\ATI\Support\10-4_vista64_win7_64_dd\Packages\Drivers\Display\W76A_INF\B_98282 (for a Windows 7 64-bit driver).
  11. Find the file atioglxx.dl_, and copy this file to your Jedi Academy's GameData directory.
  12. Copy and paste the below batch script into a file called atifix.bat, and save it to the GameData folder.
    expand atioglxx.dl_ atioglxx.dll

    Alternatively, you can run the command directly from the command prompt, and skip the last step.

  13. Run the atifix.bat file.

If you have any problems, just reply to this topic and hopefully I or someone else can help.

Link to comment
Share on other sites

  • Replies 57
  • Created
  • Last Reply
Yeah I noticed that, pity AMD doesn't pay attention to the older games.


If I downgrade will it ruin compatibility with newer openGL games (portal, hl2, ext.)?

Like acdcfanbill said, as the DLL is only in JKA's GameData folder, it's only going to affect JKA. Also, only a small handful of games use OpenGL nowadays (mainly games running on the iD Tech engines like ET:QW, Prey, Q4, etc). The rest of the games like Portal and HL2, use DirectX.

Link to comment
Share on other sites

As I said earlier, games which run on the iD Tech engines, like Enemy Territory: Quake Wars, Prey, they use OpenGL. A lot of indie game developers also choose to use OpenGL because it works on other operating systems. ATI have to update their OpenGL to keep up with the newest OpenGL versions. Not updating, would be like continuing to use DirectX 8 when the latest version is DirectX 11. Keep in mind it's not only games that use the graphics card, so they can't just drop support for something which is widely used by other software.

Link to comment
Share on other sites

  • 1 month later...

Well, this seemed pretty promising since after downloading the game from Direct2Drive I kept getting a basic crash with the initial JA screen. This didnt seem to help me much. I notice that my base folder has the 4 assets files in .pak format. Wondering if this is causing the issue with the game.


Vista 64 etc, tried administrator, XP SP2 mode, etc....no luck to get the game going. I am thinking the game just wasnt unpacked properly using their executable.


Edit: Was able to download on a cpu with Windows XP and the game ran fine. So obviously its a Vista issue. Trouble is, I had the game a couple years ago but the game CD was destroyed. It worked previously on this cpu.

Link to comment
Share on other sites

OK apparently I get an error saying can't open output file atioglxx.dll whenever I execute the .bat or from the command prompt. Apparently this is the problem I am having. Any ideas on what is causing an error?



Edit: Haha apparently you can run command prompt in administrator mode and now it worked. Lets see how this goes.



Edit 2: OK now that I have the proper .dll file the game is working. Now to get the 16/9 and dismemberment going. So this is a good fix for ATI users.....when it's implemented correctly.

Link to comment
Share on other sites

if it doesnt list 16:9 rez for you to choose from, you can set the resolution manually using hte console (shift + ~) using these commands one at a time.


r_mode -1

r_customwidth 1280

r_customheight 720




you can use w/e rez you want, i just chose a common 16:9 one.

Link to comment
Share on other sites

ok NM i figured it all out. the issue was that the bat file was not working properly for me, so i had to go into cmd prompt and force expand the file that way, and then had to go find the newly expanded .dll in the system folder and move it over. but both Jedi Outcast and Academy games work great now. i'm very grateful that I found a thread on this as there's not a ton of info floating around about the problem unless you look very hard.

Link to comment
Share on other sites

  • 4 weeks later...

i just did all of this; downloaded ati driver and added the dl_ file to the game directory. but i don't understand the part about the .bat file. how do i force expand it? it's driving me crazy trying to figure it out.. and yes, i'm doing this for jedi outcast 2

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...