Jump to content

Home

Crash Fix For ATI videocards: Jedi Outcast/Jedi Academy (tested on Catalyst 10.11)


g0dFather
 Share

Recommended Posts

My kids love this game so I had to figure out a fix. Existing fixes that others posted weren't working. Thanks to all the existing suggestions I found on several sites, plus four hours of trial and error, I was able to figure it out! :)

 

1. Go to the GLDirect page on SourceForge. Download gldirect5_opensource.zip.

 

2. Extract the contents. Go to the gldirect5\bin\release folder.

 

3. Copy opengl32.dll to your GameData folder.

 

4. Play the game!!

 

Tested on Windows XP x86 with a Radeon HD 3850 AGP running Catalyst 10.11 drivers...Success!!

Tested on Windows 7 x64 with a Radeon HD 4870 PCIe running Catalyst 10.11 drivers...Success!!

 

Enjoy! :)

 

1/2/2012 Update: I installed the 11.12 ATI drivers and the problem seems to be resolved. If you are still experiencing this issue, make sure you have the latest drivers first.

Edited by g0dFather
Link to comment
Share on other sites

I guess I can't fully celebrate just yet. There are a few people on other forums reporting that it did not work for them, but then...there are a few that say it does. :)

 

None of the ATI extraction methods worked for me. :\

 

The fix did dumb down my graphics a little, but is still playable. This DLL is only 1.4MB versus ATI's 15MB+/- version, which could be why. Some people are reporting garbled graphics and/or garbled or no audio. A Windows 7 32bit user said it didn't work.

 

Please post your results if it doesn't work for you and you find a solution. Good luck!

 

UPDATE: It did reset all my graphics to the lowest setting at first launch, but I changed my video settings back accordingly and it works great now.

Edited by g0dFather
update
Link to comment
Share on other sites

  • 2 weeks later...

This may sound dumb.. But without using any of the Ati .dll inserts rename jk2mp.exe to quake3.exe and try to run. this means remove the extra files you added. I did this and my game runs flawlessly full graphics.. running Windows 7 x64 ultimate and ATI Radeon HD 6870.

Link to comment
Share on other sites

  • 4 weeks later...
sub dude, so i dont find this folder called "gameadata", i play it with steam. so i dont know where to search for it?

 

bye

 

Kapo

 

I still run the retail version. After searching online, the default path for the Steam version appears to be:

C:\Program Files (x86)\Steam\steamapps\common\jedi academy\GameData

Link to comment
Share on other sites

Hi Need help:Problem signature:

Problem Event Name: APPCRASH

Application Name: jasp.exe

Application Version: 1.0.1.0

Application Timestamp: 3f999a27

Fault Module Name: StackHash_9b02

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 00000000

Exception Code: c0000005

Exception Offset: 564e5f4c

OS Version: 6.1.7600.2.0.0.256.1

Locale ID: 1033

Additional Information 1: 9b02

Additional Information 2: 9b022142d2d01e396e8e174ed72fc01b

Additional Information 3: bff4

Additional Information 4: bff4159960f924e8cc5481986c45f561

 

************************************************************************

 

Problem signature:

Problem Event Name: BEX

Application Name: jamp.exe

Application Version: 1.0.0.0

Application Timestamp: 3f1cc0ec

Fault Module Name: StackHash_f994

Fault Module Version: 0.0.0.0

Fault Module Timestamp: 00000000

Exception Offset: 7463656c

Exception Code: c0000005

Exception Data: 00000008

OS Version: 6.1.7600.2.0.0.256.1

Locale ID: 1033

Additional Information 1: f994

Additional Information 2: f994a64ef724727d60419cc768abf57e

Additional Information 3: ee4a

Additional Information 4: ee4a8898addab00dfa01b9dd49cde082

*****************

Sys specs:Dell Lap

Primary Adapter

Graphics Card Manufacturer Powered by ATI

Graphics Chipset ATI Mobility Radeon HD 5470

Device ID 68E0

Vendor 1002

 

Subsystem ID 0447

Subsystem Vendor ID 1028

 

Graphics Bus Capability PCI Express 2.0

Maximum Bus Setting PCI Express 2.0 x16

 

BIOS Version 012.018.000.004

BIOS Part Number BR036653.001

BIOS Date 2010/02/25

 

Memory Size 512 MB

Memory Type DDR3

 

Core Clock in MHz 750 MHz

Memory Clock in MHz 800 MHz

Total Memory Bandwidth in GByte/s 12.8 GByte/s

Link to comment
Share on other sites

Hello, when I use this fix on Catalyst 10.12 consol says:

GLW_StartOpenGL() - could not load OpenGL subsystem

Method with the older drivers and file atifix.bat (atioglxx.dll) does not work for me...

Any idea how fix my problem?

 

My PC:

Windows 7 Ultimate x64

I7 870

HD 6950

 

Sorry for my English

Link to comment
Share on other sites

  • 2 weeks later...
  • 6 months later...

Glad this thread exists. I've had my ATI Allinwonder 9600 for years (under 2000) and never had a problem with JA/JK2 (only problem I ever had with the card was with the "tv" portion which stopped working, and that was before the digital changeover so I didn't use it much, sadly). I also had an old ATI Mobility Radeon with XP that worked fine.

 

But, I'll be getting a new machine with win7 (and ATI Radeon HD 6490M) in the next couple of weeks, and I'll let you know how it goes!

 

Of course I'll be using my old JA CD's, rather than dealing with steam.

Link to comment
Share on other sites

  • 1 month later...
My kids love this game so I had to figure out a fix. Existing fixes that others posted weren't working. Thanks to all the existing suggestions I found on several sites, plus four hours of trial and error, I was able to figure it out! :)

 

1. Go to the GLDirect page on SourceForge. Download gldirect5_opensource.zip.

 

2. Extract the contents. Go to the gldirect5\bin\release folder.

 

3. Copy opengl32.dll to your GameData folder.

 

4. Play the game!!

 

Tested on Windows XP x86 with a Radeon HD 3850 AGP running Catalyst 10.11 drivers...Success!!

Tested on Windows 7 x64 with a Radeon HD 4870 PCIe running Catalyst 10.11 drivers...Success!!

 

Enjoy! :)

 

Thanks a lot Dude! Respect!! Very helpfull!

Link to comment
Share on other sites

  • 2 months later...
Hello, when I use this fix on Catalyst 10.12 consol says:

 

GLW_StartOpenGL() - could not load OpenGL subsystem

 

Method with the older drivers and file atifix.bat (atioglxx.dll) does not work for me...

Any idea how fix my problem?

 

My PC:

Windows 7 Ultimate x64

I7 870

HD 6950

 

Sorry for my English

 

I guess you've already solved this problem, but anyway:

 

Make sure you have latest drivers - I guess you do. Some time ago, this problem could be caused by write-protected opengl library, so it was not updated even with the latest drivers. In this case, you could copy OpenGL32.dll to the GameData directory (where jk2sp.exe or jasp.exe resides). There was also a possibility that color depth of the display is less than 16bit colors, but I guess this will not happen in these days - well, make sure that it is highcolor (16) or truecolor (32).

 

Well, that is all I know :-)

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...
My kids love this game so I had to figure out a fix. Existing fixes that others posted weren't working. Thanks to all the existing suggestions I found on several sites, plus four hours of trial and error, I was able to figure it out! :)

 

It worked for me. Thank you very much for your time and effort.

-----

Cleveland

Link to comment
Share on other sites

  • 1 month later...
Hello, when I use this fix on Catalyst 10.12 consol says:

 

GLW_StartOpenGL() - could not load OpenGL subsystem

 

Method with the older drivers and file atifix.bat (atioglxx.dll) does not work for me...

Any idea how fix my problem?

 

My PC:

Windows 7 Ultimate x64

I7 870

HD 6950

 

Sorry for my English

 

I'm having the same problem with a similar computer. Does anyone knows how to fix it ? Thank you. (None of the former solutions works)

Link to comment
Share on other sites

  • 2 weeks later...

I had a lot of video driver problems on my new laptop, but I have since learned that laptops are their own animal, they require SPECIAL video card drivers found on the laptop company's web page. The other drivers, even if they are newer, either won't install or goof things up!

Link to comment
Share on other sites

  • 2 months later...

Ok I have Relised..at I have Intel Chipset Family Express..But Quake 3 and quake 3 team arena works even JK original and expansion and even doom 1 too two..but only Jedi knight jedi outcast and jedi academy has this issue..I Installed Jk2 Then just went to the shortcut and Had the compibility on Windows xp service pack 3 and run as administrator..That didn't work..and when I putted the open gl file to the gamedata ( wished it workeD) ..It just became completely gray screen nothing happend..even tried changing the Jk2.SpExe into Quake 3 didn't work...so I am all out of advices Video Card >>>> Intel ®8295G/GV/910GL express chipset family Need help

Link to comment
Share on other sites

  • 3 years later...

hello

I have a problem - I did what I had to do, I've mounted 1st CD, install, then unmount - mount CD2 (when I was trying to "insert CD2" by choosing second mounted CD on the second driver, it wasn't OK and didn't 'see' the second CD). Finally I installed the game (after some time of trying ^^) , I did choose Single Player, the window of the game disappears, it should be all black and enter the game, but "error" comes up - "no disc inserted"

 

aaand here I surrender. does anyone knows what should I do? I got Windows 7

 

bless! :yelhelp::smoke2:

Link to comment
Share on other sites

So, since you have the CDs and both jk2 and jka have been opensourced, I would recommend using openjk to play the game. It's a community updated version of the engine source code (it doesn't have any art/sound assets). It fixes a lot of bugs that crop up on newer machines.

 

https://github.com/JACoders/OpenJK

 

scroll down to the README and they have a link to binaries for whatever OS you use.

Link to comment
Share on other sites

 Share

×
×
  • Create New...