Jump to content

Home

Will JK2 run on a Voodoo 5?


[xeno]DarkStar
 Share

Recommended Posts

  • Replies 129
  • Created
  • Last Reply

Top Posters In This Topic

It is an honest question, though I do believe that it has been asked once or twice. I used to have a 3dfx voodoo 3 card, and it worked on all games after they sold to Nvidia. I do believe that they are (100%) openGL compliant. If you read the system info on the Jedi Outcast page,

 

http://www.lucasarts.com/products/outcast/html/system.html

 

it will tell you what is required for the cards. And it says that they have to be 100% opengl supported. Which I do believe that 3dfx put that into all of their cards. All can do is try to play it and if it doesn't work, then you know you might want to get a new card. The voodoo5 is a pretty powerful card, it was made to go against the geforce 3 i believe...though I could be wrong.

 

I am almost positive that it will work.

 

If you look, Geforce 4 isn't even supported. But it will work. Alot of games say that they are supported but have alot of unsupported cards on a list that work just fine.

 

there you go buddy.

Link to comment
Share on other sites

It should work with a Voodoo 5 5500 AGP, but may take bit of tinkering.

 

When I first installed and ran the a similar game such as Medal of Honour: Allied Assault, none of the video sequences at the start would show and the menu system's text was so horribly corrupted that it made menu navigation impossible.

 

Heres how I fixed it:

 

1) I downloaded WickedGL from http://www.wicked3d.com/technology/wickedgl.htm and installed it.

 

2) I went into the dir where I installed Medal of Honour: Allied Assault and found the exe file, and I renamed it quake3.exe

 

3) Then I ran the WickedGL control panel, and told it to look for the game Quake 3 in my Medal of Honour: Allied Assault dir.

 

4) It told me it had found a copy and asked me if I wanted to install the MiniGL driver there, so I clicked OK.

 

5) I closed the WickedGL control panel, went back into my Medal of Honour: Allied Assault dir and renamed quake3.exe back to its original name

 

Now when I run the game I get the WickedGL shareware message which says press 'C' to continue, and then the game works fine!

 

My PC is as follows:

PIII 700mhz

320MB RAM

Voodoo 5 5500 AGP

SB LiVE! Value

Windows 2000 Pro

DirectX 8.1

 

The game runs like a dream on my machine in 800x600x32 :D

 

This should also work with Jedi Knight II seeing as though the graphics engine is also based on the Quake 3 engine. Give it a try and make sure you have the latest drivers for your card!!

Link to comment
Share on other sites

Ah! Many thanks UrzaTRI! I was having the exact prob with my Voodoo 5 for Outcast as you had for Medal of Honor. I was getting no opening movies and the screen was garbled. Also my saves weren't working. I followed your instructions for the WickedGL drivers and I'm running 100% now.

I wonder what is causing the exact same problem on two different games? Oh well.

 

Thanks again!

 

Nate

Link to comment
Share on other sites

Wow, thx, Urza!

 

I was havin CRAP framerates in MOH:AA as well; blackscreen intro movies; no text adjustment - especially in vast environments.

 

I had already downloaded WickdGL for Tribes2 last fall, but never tried tricking it into using the MiniGL Quake3 drivers. It worked: I see the intro movies, and the text isn't screwed up.. . .I just wish I could get more framerates out of it. I still have to have the detail rpetty much at LOWEST settings at 1024 X 768.

 

 

 

My system:

 

AMD Duron 800MHz

256 PC133 RAM

Asus A7V133 Motherboard

Voodoo5 5500 64MB AGP

SBLive Value!

KDS XTreme Flat 19" monitor (mmm, just got this a month ago)

30GB Hard drive (that REALLY needs a fresh reformat! 2GB freespace is asking for problems I hear.)

 

 

Which version of WickedGL did you use? I think I have a couple versions from last fall (beta and "reg").

 

And, will that trick work for ANY Quake3-engine game?

 

I'm using the x3dfx_V5_Win9X_1.08.04 drivers for my Voodoo5.

Link to comment
Share on other sites

Oops spoke too soon. I'm not quite 100%. The games not displaying a sky texture. All I get is a big white light sky or a big black sky. Thing is on the save game screen shots the sky is there. Other than that though the game runs great. And is quite good btw.

If anybody has any ideas on my sky problem let me know.

 

Nate

Link to comment
Share on other sites

I really don't know anything about Windows XP nor do I know how the Voodoo5 card works with XP (I have a Voodoo 5 5500 as well). You did try the WickedGL solution, right?

 

p.s. NatePalm - I have the same setup as you and my JO is showing me clouds and sky just fine. Don't know why you don't see it.

Link to comment
Share on other sites

Installed WickedGL and most of my problems have gone away...

 

I'm not seeing the sky either (though in my case the save screen shots don't show it either), and I have absolutely no gamma control whatsoever...

 

Any suggestions? (other than buying a geforce...)

 

-Chicanery

Link to comment
Share on other sites

I've downloaded the demo version of wicked GL. And the fix by changing the exe to quake3 worked. However in the setup screen for video preference, If I raise the screen resolution other than default the game locks up. The phrase about buying wicked gl comes up and I can hit c to continue. it just freeze there. Any ideas?

Scotsman

Link to comment
Share on other sites

Ok, I figured out how to get the sky working and the gamma back to normal.

 

You will need to open the jk2mpconfig.cfg file in Wordpad and change a few numbers.

This file is located in: "\Jedi Outcast\GameData\base"

 

To fix the sky, find the line that reads:

seta r_fastsky "1"

 

Change the 1 to a 0 and the sky should reappear.

 

Now, to fix the gamma, find the line that reads:

seta r_ignorehwgamma "0"

 

Change the 0 to a 1 and the gamma should be normal.

 

Save the file, load JO and you should be good to go. Hope this works out for you... way to go WickedGL drivers for saving the day...

 

-ds

Link to comment
Share on other sites

thought up a possible work around to the renaming directory thing.

 

in the wickedgl folder there is a file called wglgames (not sure what version i have..might be different). Copy the quake 3 line..paste it in there and then edit..

 

"Jedi Knight",jk2sp.exe,opengl32.dll

 

not sure if it would work..havent tried it..i did enter a fake game name using above method and then ran wickedgl install and it showed up on list of games.

 

i might try later.

 

What i really want though is the ability to switch in-game from my geforcemx2 to my V2 sli's (and u though v5 was old...ha)..want to be able to test both..see which is better for me tweaking wise.

 

Creep

Link to comment
Share on other sites

That fixed the sky problem... Still no gamma control. Can't figure out why...

 

There are three gamma settings in the cfg (I'm using jk2config.cfg, btw... not the multiplayer config).

 

seta r_ext_gamma_control "0"

seta r_ignorehwgamma "0"

seta r_gamma "2.511719"

 

I'm playin' with 'em... But not getting very far... Nice to have a sky though.

 

-Chicanery

Link to comment
Share on other sites

You shouldn't have to rename the EXE's or folders to install WickedGL. All you need to do is to copy the opengl32.dll (from the WickedGL folder) into the JO/GameData/ folder.

 

If you want to use the hi-res version of the WGL driver, copy the ogl_hres.dll and rename it to opengl32.dll .

 

Remember, any file named "opengl32.dll" will be the GL driver JO uses.

 

-ds

Link to comment
Share on other sites

Chicanery

 

If you want to set the gamma for multiplayer, you must use jk2mpconfig.cfg and play with the gamma variables.

 

Otherwise, jk2config.cfg is only used by the single player exe.

 

I think if you keep playing with those gamma vars, you will get results.

Maybe try this:

 

seta r_ignorehwgamma "1"

seta r_gamma "5"

 

I'm not at home to test this, but I will get back to you soon.

 

-ds

 

PS- There is also a brightness setting in the advanced display options which might help. :cool:

Link to comment
Share on other sites

 Share


×
×
  • Create New...