Jump to content


Skyrim: Elder Scrolls 5


Recommended Posts

  • Replies 610
  • Created
  • Last Reply

Just found the Dragon Priest mask that has the following bonuses.


'Prices are 20% better, carry 20 points more, and can breathe underwater.'


The mask is called Volsung, it can be found in Volskygge.


Volskygge(for those that don't know), can be found near Deepwood Redoubt, Pinefrost Tower, Northwatch Keep(Northwatch Keep can be found along the Solitude coastline).

Link to comment
Share on other sites

East of Morthal, up the top of the mountain. Just look for the giant smarmy looking bloke. You'll find it as part of a quest chain, and can't get inside the actual shrine unless on that quest. I don't think any Daedra spawn outside it randomly.



Found the shrine, and you where right. There ain't any Daedra here at the moment.


This quest chain? Where and when do i get it?

Link to comment
Share on other sites

Play long enough and some courier should hand you a flyer advertising a museum in Dawnstar eventually, which starts the quest (Pieces of the Past). Apparently you have to collect a Daedric artefact (i.e. a Daedric weapon quest reward) and be level 20+ for the courier to be triggered. In theory though just going straight to the museum should trigger the quest. Only one way to find out.

Link to comment
Share on other sites

Just now, when i fast travelled, i saw a 3D model of a 'statue' with about eight Dragon Priest masks.


Are we supposed to collect the masks and return them to this statue?


The altar with the 8 masks from the load screen can be found outdoors in the ruin called Labyrinthian under a dome-shaped structure. There's also a wooden mask on the ground right next to it. I haven't gotten all the Dragon Priest masks yet so I don't know what happens if you bring them all there yet.


Stumbled upon it while on a quest for the Mage College. :)


Hmmm...apparently dragons will attack you inside towns. Riverwood is now minus one citizen and a few Whiterun guards.


Seems to happen at all the towns and cities that aren't in a separate worldspace. And unfortunately those random dragon attacks aren't deactivated during major quests in those areas. A poorly timed dragon attack at the Mage College made the final quest in their plot arc very hard. :wonder:

Link to comment
Share on other sites

Btw, i now have just over 73.000 septims in my ingame money pouch...


That is *after* getting both houses (Whiterun/Riften) fully decorated.


I'm hoping i can buy houses in some of the other cities as well, and that their *really* expensive.


Oh btw, this doesn't count the dozens of gemstones and jewelry i've got stashed in my riften house. :)


Edit: Hey, stoffe? Just went to Labyrinthian myself. Have you tried putting on the wooden mask yet? It seems to take you to Labyrintian before the place fell apart.


And, the statue has eight empty lots where the masks are supposed to go.


It seems we *are* infact supposed to collect the masks and bring them back there. :)

Link to comment
Share on other sites

Ok. :)


Show spoiler
(hidden content - requires Javascript to show)
Well, i've got another problem.


I'm doing the Darkbrotherhood questline, and just had the coffin incident with the nightmother, i am now supposed to get a new mission from Nazir...


My problem is, when ever i try talking with him, there is no line for me to choose said quest from.


I've tried leaving the sanctuary, i've tried sleeping, i've tried waiting...


Edit: After a bit of searching i found this:

Warning there is a glitch that can happen after the coffin scene where you are told to speak to Nazir to find more contacts and there will be no option. Preventing you to continue the Dark Brotherhood quest line.*'

-- How to fix it: Enter the Night Mothers Coffin, then press "Wait" and do so for an hour or two.

^ Waiting does not always work.

Edit2: Well the waiting trick doesn't work as i get kicked out of said coffin every time i try.

I also tried loading an auto save from before getting the quest of spying on Cicero. The glich still happened. :(:(


I guess i've lost that character. :(:(:( 106 hrs of work lost...

Link to comment
Share on other sites

After a couple of false starts, I finally finished the main quest this weekend.


A couple of spoiler-free thoughts:


1) I have to give Bethesda kudos for figuring out a way to keep the game going, even when you've "finished". Morrowind just kinda set you loose, with a "You rock. Go forth and be awesome". Oblivion didn't even go that far. There is still much to do in Skyrim (not just dungeon clearing) once the dragon issue is resolved.


2) Same thing goes for leveling. Once my character reaches "badass" status, I tend to lose interest (one-hit killing things is only fun for so long). However, in Skyrim, even if you max out your skills or hit the level cap, there are still Shouts to find/upgrade.


3) Perhaps this is a function of my impatient desire to wrap up the main quest, but much of the 2nd and 3rd act felt...less coherent than the beginning. One particularly important cutscene felt comic. The last hour or so had that whirlwind feel where you start to wonder if they're throwing a whole lot of stuff at you in an effort to distract you from plot holes or shoddy writing. It could be that there's a whole lot of context that I missed my first time through, but I kept thinking that in the end, Skyrim was turning into Oblivion, when it so wanted to be Morrowind.


Fun game though. I think I have at least a couple more playthroughs on the horizon.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...