Jump to content

Home

ForceMod II - Final beta feedback


Azymn
 Share

Recommended Posts

  • Replies 224
  • Created
  • Last Reply

Top Posters In This Topic

Another question:

 

I was using Forcemod 1 and had, in my opinion, a major problem...might or might not be mod related, but it works in Gen-X....

 

Cheataccess... give all and noclip do not work...even when rcon grants cheataccess to a client the client cannpot use them (can use g2animent however).

 

Now, under the base game (no modding) or gen-X...these do work when cheataccess is granted through the console.

 

These commands, while not used by most, are VERY usefull for Admins and Clan Leaders. It supercedes ALL MOD admin commands and gives over TRUE control of the server.

 

Anyway...something to think about. :)

Link to comment
Share on other sites

I'm not sure if I got a bug or if it's just my machine. But when I give the bots a number five in the fm_classes.cfg to make them a trooper, they all come out as heavy troopers. So instead of stormtroopers using blasters they all start with rocket launchers and repeaters then start flying everywhere. very annoying so if you could fix it up I'd appreciate it.

Thanking you in advance, Littleman

Link to comment
Share on other sites

Hellfire Jedi - i just saw that post. :S

 

The answer is simple: it's a lie.

 

Would i really log on as "Azymn" and abuse the first person to try out the mod?

It's an unfortunate thing that this person would accuse anyone of such a thing. I don't even know who the guy is, or why he would say something like that. :(

 

I encourage everyone to go see the post for themselves. I have nothing to hide, and no lies, or tricks up my sleeve:

http://www.pcgamemods.com/forums//showthread.php?s=&postid=15212#post15212

Link to comment
Share on other sites

what the hell is wrong with people? some people have waaay too much time on their hands....

 

i hope this doesn't ruin the release of this brilliant mod. i'm behind you 100% Azmyn.

 

5.4 on pcgamemods.com???? Seriously, someone is being a huge !@#$. Screw off whoever you are.

Link to comment
Share on other sites

Azymn I agree with you. oh and by the way

 

one downside is that even though I edited certain bots so they cant use sabers they still do in ForceMod so then I went and edited the CLass cfg file in forcemod and chnged the one I wanted to have no jetpack and saber to "Clonetrooper" 50-000 and I still get cool troopers with sabers ahhh.

 

OK so I know that my bot files are edited and they work with no sabers in regular game but when I launch new game with ForceMod 2 they still do like I said above.

Here is exactly what I changed in fm_classes.cfg file:

 

IGNORE the missing spaces between the model name and the numbers because for some reason you cant have aton of spaces in one line when you post in forums

EXAMPLE: "tex_qui-gon" 50-122

 

//--------------------------------------------------

// ForceMod Model Class Config

//

// <name> - name of the actual model as found in the file path

// <class> - 0 = Jedi/Sith, 1 = Scout, 2 = Bounty Hunter, 3 = Heavy Soldier, 4 = HotShot, 5 = Trooper

// <jetpack> - 0 = No jetpack, 1 = Single Thrust, 2 = Dual Thrust, 3 = Tri-Thrust, 4 = Dual Thrust (No Model), 5 = No FX (For Flying Characters)

// <sabertype> - 0 = Jedi/Sith will also use guns, 1 = Single Blade Only, 2 = Dualblade Only, 3 = Twin Sabers Only

// <saberblade>- 0 = Standard, 1-6 = "Episode #" Saber blade type, 7 = Ancient Blade

// <acrobatics>- 0 = Default Roll, 1 = Butterflies, 2 = Cartwheels, 3 = Arial Flips

//

// Syntax:

// "<model name>" <class><jetpack>-<sabertype><saberblade><acrobatics>

//--------------------------------------------------

 

"4lom" 10-000

"Aayla" 00-122

"ackbar" 50-000

"adi" 00-122

"admiral_rieek" 50-000

"ak-buz" 30-000

"Anakin" 00-322

"anhluke" 00-020

"ani-gel" 00-122

"arco_palpatine" 00-120

"atatpilot" 50-000

"aurra" 00-322

"bartender" 10-000

"battle3po" 50-000

"battle_droid" 50-000

"battledroid" 50-000

"beedo" 20-000

"bespin_cop" 40-000

"blacktrooper" 50-000

"boba_fett" 22-000

"BobaFett" 22-000

"boushh" 10-000

"c3po" 50-000

"calsann2" 00-122

"camotrooper" 50-000

"canor_jax" 00-122

"cheshire_vader" 00-150

"chewie" 40-000

"chiss" 10-000

"chromeshadowtrooper" 00-122

"clonecommander" 50-000

"CloneTr" 50-000

"clone_trooper" 50-000

"clonetrooper" 50-000

"coleman_trebor" 00-122

"commander" 50-000

"ct_fisto" 00-122

"ct_sidious" 00-100

"d" 00-121

"darkyoda" 00-122

"Darth_Sidious" 00-120

"darthseph" 00-121

"dash rendar" 40-000

"dash_rendar" 40-000

"desann" 00-222

"dooku" 00-123

"gl_dooku" 00-123

"dug_jedi" 00-121

"eerin_bant" 00-122

"eerin_bant_robe" 00-122

"ep1_obi" 00-122

"ep2anakin" 00-122

"ep2windu" 00-122

"epiI_obi" 00-122

"esb_ghost" 00-122

"esb_yoda" 00-122

"ewok" 40-000

"exar_kun" 00-121

"exarkun_sithii" 00-121

"fenn_shysa" 20-000

"galak" 20-000

"gamorrean" 50-000

"gee" 50-000

"geonosis" 50-000

"gl_dooku" 00-123

"grafox_palpatine" 00-100

"gran" 50-000

"grayfox" 20-000

"greedo" 40-000

"gungan" 50-000

"han_anh" 40-000

"han_esb" 40-000

"han_roj" 40-000

"han_solo" 40-000

"hornett_trooper" 50-000

"hutt" 50-000

"ig-88" 20-000

"imperial" 50-000

"imperialcommando" 50-000

"imperial_worker" 50-000

"infantry" 50-000

"jan" 10-000

"jango_fett" 22-000

"JangoFett" 22-000

"jar-jar" 50-000

"jarjar" 50-000

"jawa" 50-000

"jawa_hybrid" 50-000

"jedi" 00-122

"jedi_dooku" 00-123

"jeditrainer" 00-122

"jerec" 50-000

"jodo_kast" 20-000

"kaia_yoda" 00-122

"keiran" 50-000

"ki_adi" 00-122

"ki_adi_mundi" 00-122

"ki_adi_vm" 00-122

"ki_moot" 00-122

"kir_kanos" 00-122

"kit_fisto_vm" 00-122

"kit_mitsu" 00-122

"koh_tu" 00-122

"krussk" 30-000

"kui_masu" 00-122

"kyle" 00-062

"kylearmor" 00-022

"kyparmor" 00-022

"khyron_jinn" 20-000

"lando" 40-000

"leia" 40-000

"luke" 00-122

"luke-bespin" 00-022

"luke-dagobah" 00-022

"lukearmor" 00-121

"luminara" 00-122

"mace-windu" 00-122

"mara jade" 00-122

"mara" 00-122

"mara_jade" 00-122

"master_yoda" 00-122

"Maul" 00-221

"maul_deluxe" 00-221

"maw" 05-321

"mc_jarjar" 50-000

"monmothma" 40-000

"morgan" 40-000

"motskyle" 00-122

"obivm" 00-122

"oldben" 00-120

"padme" 40-000

"padme2k3" 40-000

"padme_geonosis" 40-000

"padme_geonosis_battle" 40-000

"palpatine" 00-122

"pilot" 50-000

"plo koon" 00-122

"plo_koon" 00-122

"plokoon" 00-122

"prince_xizor" 00-122

"prisoner" 50-000

"Qui-Gon" 00-122

"quigonvm" 00-120

"quigonvm2" 00-120

"ra7" 20-000

"raith_armor" 20-000

"realluke" 00-120

"rebel" 50-000

"reborn" 00-121

"reelo" 10-000

"rodian" 50-000

"royalguard" 00-322

"samuel_l" 00-123

"sand_shoulder" 50-000

"sariss" 00-122

"sebulba" 50-000

"sebulba_racer" 50-000

"security" 50-000

"shaak ti" 00-122

"shaak_ti" 00-122

"shadowtrooper" 00-120

"sirrya" 00-123

"sithlord_palpatine" 00-120

"sithyodavm" 00-221

"solo" 40-000

"stormcommander" 50-000

"stormpilot" 50-000

"stormtrooper" 50-000

"swamptrooper" 50-000

"swluke" 00-020

"tavion" 00-121

"tc14" 20-000

"terpfen" 00-122

"tex_quigon" 00-122

"the_emporer" 00-120

"trandoshan" 50-000

"trooper" 50-000

"trueanakin" 00-322

"tusken" 50-000

"tusken_raider" 50-000

"tyranus" 00-121

"ugnaught" 50-000

"ulic" 50-000

"vader" 00-120

"vigo_morn" 50-000

"watto" 35-000

"weequay" 50-000

"windu" 00-123

"wolfe" 00-322

"wookiee" 40-000

"yarael" 00-112

"yarael_poof" 00-122

"yarael_sith" 00-322

"yin" 00-122

"yoda" 00-122

"esb_yoda" 00-122

"yoda_ghost" 00-122

"yodaghost" 00-122

"yodamaul" 00-122

"yuuzhanvongketo" 00-322

"zabrak" 00-222

"zabrak_jedi" 00-222

"zam_wesell" 11-000

Link to comment
Share on other sites

DarkLord60, I used to have problems like you're describing, but for several builds now my bots have all been well behaved (figuratively speaking of course :)).

 

I just added Watto as a flying Trooper and he's working out fine.

 

If you'd like I could send you some of my bot files and .cfg's to see if that works.

 

Feel welcome to PM me if there's anything I can do to help.

Link to comment
Share on other sites

Oh and while I'm thinking of it, speaking of bots...

 

This might sound silly, but is there a way to create a bot that doesn't use ANY weapons (neither saber nor guns)?

 

Before you all start chuckling, I ask for two reasons. First I'd like to make a Palpatine/Sidius bot who uses nothing but the Force. Secondly I thought it might be fun to create an "innocent bystander" bot - a bot Light Side players could try to protect and Naughty Side players could try to abuse (sort of a twisted version of capture the flag). :)

Link to comment
Share on other sites

Terrific Mod. I have two questions though.

 

1. When using the Darth maul saber hilt, I get two strange effects. You seem to have implemented some code that makes the second blade extend from where the second emitter should be, but the hilt appears as only being half as long as it should be.

 

2. Did you say that you could add your own custom skins? If so, is it possible to make the blade vanish altogether for forcepikes and things?

Link to comment
Share on other sites

I was thinking in an up comming update maybe that thier could be different saber sounds to choose from like for example Darth mauls saber sound, yodas saber from epo.2 also when saber fighten u could in knock the saber out of the players hand then while fighten try to retrieve it. Just a thought for updates

Link to comment
Share on other sites

Originally posted by JEDICW

I was thinking in an up comming update maybe that thier could be different saber sounds to choose from like for example Darth mauls saber sound, yodas saber from epo.2 also when saber fighten u could in knock the saber out of the players hand then while fighten try to retrieve it. Just a thought for updates

 

 

Some interesting ideas you have for future updates but I think they would be difficult implement into the game especially the custom saber sounds. I`m sure though if anyone can do it Azymn can.

Link to comment
Share on other sites

I'm running into a few problems...one of which is that my bots don't have class. I.E. When I try to bring in Jango instead of being a bounty hunter the screen gives me a "class could not be found" and Jango starts to use a lightsaber as well.

 

Second problem is the scaling. Simple enough, it doesn't work. Yoda is the same size as the others. However the scaling still does work in the original forcemod.

 

Please suggest any solutions you might have.

Link to comment
Share on other sites

A few things I've noticed:

 

Enabling client-side size controls causes all of my characters to start at the minimum size, not their tck defaults.

 

Mod_timescale no longer works at all for me, and this feature was VERY important for playing JKII with my 56k friends.

 

Finally, how can I enable a new model as a "Mandalorian" without enabling jetpacks for all of a certain class. I ask because the Montross model is not considered a Mandalorian by ForceMod II, and it should be.

 

Great mod, otherwise.

Link to comment
Share on other sites

Here's a few things that I've discovered that may help some of you...

 

First off, there are many different models (and model names) floating around out there. We can't expect Azymn to keep track of them all. For example, there are at least 3 different BattleDroid models (and probably at least as many Jango's and Clone Troopers). Make sure your model name matches what is in both the tckmodel.cfg and the fm_classes.cfg files respectively. To find out the exact name of your model, use a pk3 viewing utility or choose the problem model in-game and in the console type: "model."

 

For example, if I look inside the pk3 of my Zam Wesell model, I see this:

 

models/players/zamvme

 

"zamvme" is the official name of my model not zam_wesell (an older Zam model) as appears in the currently shipping version of ForceMod II.

 

Also, both the tckmodel.cfg and fm_classes.cfg files appear to be case sensitive. What I mean by that is, I had problems when I added Zam as "ZamVME" - after I changed it to "zamvme" the model worked perfectly.

 

Don't forget there is also a handy cvar called "f_defaultclass" that should help if you've added a new model not listed in the fm_classes.cfg file (read more about how to use it in ForceMod's documentation).

 

Ol-Gil, I too had problems getting mod_timescale to work for me at first (I love a good slow-mo game every now and then). But as soon as I complained about it, it started working again (isn't it funny how that happens sometimes?). I can guarantee you that it still works, I'm just afraid I don't know what I did differently. I suggest you make sure you're hosting the server you're trying to set it in and don't give up trying. :)

 

JEDICW, leave no stone unturned... make sure you look at every menu item in-game (some are a lil tricky to find). If you're trying to chose a Jedi/Sith class, you should find that where you choose your Force Powers. As for Jedi/Merc, that should be right in the same spot you pick your model.

 

Hope that helps!

Link to comment
Share on other sites

 Share


×
×
  • Create New...